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User Guide - Specification Manager

15 July, 2016

The Specification Manager
In developing a model, you can use a wide range of Enterprise Architect tools to create the model specification. For the
preliminary specification, such as defining Requirements, you can adopt one of two general methods:

·

Diagram-based, creating UML-defined element icons in, for example, Requirements diagrams, and building the
model graphically, or

·

Text-based, creating elements as simple text descriptions, sketching out the elements, relationships and properties in
a broad definition that you - or team members with more specific roles - can refine and develop into a more
complete model

Your 'sketch pad' for the second approach is the Specification Manager.
The Specification Manager is a simple document-based interface to a selected Package in the model, providing the means
of creating and reviewing elements as text representations of objects in the model, using a process that is familiar to all
users including business professionals and management, who might not have expertise in model development.

<anonymous>
The Specification Manager is also an interactive reporting tool for displaying, in icon form, the status of various other
features against each entry and providing access to edit each feature.
In the Specification Manager you can:

·

Work on the element entries as paragraph text in the same way as you would edit a document using a word
processor; this includes copying or dragging text from an external file into the Specification Manager, and importing
data from an external spreadsheet (.csv) file

·
·
·

Switch easily from element to element in a single mouse click or key stroke
Show and in-place edit the current status of a number of properties of each entry
Directly interface to a range of Enterprise Architect tools that you can quickly invoke to display, edit and discuss the
properties of the selected Package or element; these tools span the range of Project Management and Model
Management facilities, including:
- Traceability (Traceability window and Relationship Matrix)
- Change Management (Baselines and Auditing)
- Maintenance
- Testing
- Risk Management
- Documentation (document format, web format, and spreadsheet format)
- Metrics
- Review and Discussion (Team Review, Element Discussions and Model Mail)

Once any tool window is open, the details reflect the currently-selected element in the Specification Manager, so you can
quickly run through the properties of a number of elements just by selecting them in sequence in the list
The Specification Manager makes it very easy to develop a simple, visual description of your model for initial
specification, ongoing development and program management, with immediate access to a range of types of detailed
information on any selected element, should you need this detail.
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Specification Manager - Overview
The Specification Manager is a document-based interface to a selected Package in the model, providing the means of
creating and reviewing elements as text representations of model objects in that Package. You can rapidly define or edit
properties of the elements in the Specification Manager window itself, and also immediately open a range of windows
and dialogs to add or review further properties and characteristics specific to each element. A key feature of the
Specification Manager is the speed and ease with which you can create, filter and review a large number of elements
from one point, without necessarily developing or examining complex detail on each element.

Access
Ribbon

Design > Package > Specification View

Menu

Package | View as Requirement List
Tools | Specification Manager

Context Menu

Right-click on Package | Specification Manager

Keyboard Shortcuts

Ctrl + Shift + X

The Specification Manager View
The Specification Manager initially displays as a tabbed view in the application work area, containing a:

·
·
·

Tailored instance of the Navigator Toolbar
List header bar of column names, and
Blank work area

The selected Package defaults to the first top-level View or Package in your model, and the element type defaults to any
type held in the Package.

If you prefer, you can drag the 'Specification Manager' tab out of the application workspace and use it as a floating or
docked window.
To begin you:

·

Select an existing Package to review, or create a new Package, using the Navigator toolbar

·

If you want to select a specific type of element to review, use the second button from the right in the Navigator
toolbar - this also provides the option of switching back to displaying elements of any type in the Package

You can also adjust the list header bar to include the columns that show the information of interest to you, and the
display Filter bar to further isolate particular elements for review. For an existing Package, the Specification Manager
might now resemble this:
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The display shows:

·
·

The element names and any notes they might have (you can configure the display to hide the notes)

·

Icons in several columns, which indicate that the element has an associated object, file or linked document; you can
double-click on these icons to display the object properties or document in the window in which it was created and,
if necessary, you can edit the details

·

The elements in parent/child relationships

The text values of each property represented by a column, where those values have been set; you can quickly edit
any of the values

After you become familiar with what each indicator icon represents, you can display them all within the single 'All
Indicators' column to save space.
When you click on an element in the display, it is marked by a vertical colored line in the left margin to indicate that the
element is selected, and a vertical or horizontal line against the element property you clicked on, to indicate that the
focus is on that property. In the illustration, the status of the 'Logout Use Case' element is selected. If you click again on
the element property, the margin line changes color, to indicate that the property is open for editing. For example:

Adding, displaying and changing information
When you create or review an element on the Specification Manager, you operate through one of three areas:
1. The Navigator toolbar, which provides options to:
- Change the Package or type of element under review
- Open tools to create, display or review the properties, characteristics and associated records of the Package
or specific elements in the Package
- Configure the appearance of the Specification Manager display and the types of information you might
develop from the data in the display
2. The display area itself, where you can:
- Perform in-place editing by directly editing text (such as Version, Phase or element notes) or selecting alternative
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values from drop-down lists (such as Difficulty, Status or Priority)
- Double-click on an indicator icon and review the record or document attached to the element
- Drag in elements from any page of the Diagram Toolbox
3. The element context menu, which you can display by right-clicking anywhere on an entry in the display; this provides
options for:
- Creating and deleting elements
- Editing element properties (including adding and reviewing extended properties, or Tagged Values)
- Locating the element in the Project Browser and
- Refreshing the display

Notes
·

In the Corporate and extended editions of Enterprise Architect, a User Security system can be applied that restricts
or enables access to a range of operations and functions; if you cannot access a function in the Specification
Manager, check with your System Administrator or Security Administrator to see if you have access permissions to
work with that function

(c) Sparx Systems 2015 - 2016
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Specification Specify Ribbon
The 'Specification Specify' ribbon provides a selection of facilities that you might use when creating and editing model
elements as a text-based specification, using the Specification Manager. The ribbon becomes available when the
Specification Manager is open.

Panels
Panel

Description

Specification

The 'Specification' panel brings together a broad range of facilities that are
commonly used in creating and reviewing specifications. There are facilities for
managing change within your Specifications Package, such as Package Baselines,
and Auditing. There are also facilities for managing tasks and reviewing work
associated with elements of the Specification Package, such as the Gantt Chart view
and the Team Review facilities. Options available on this panel provide for
configuring what information is displayed and how it is presented by the
Specification Manager, such as restricting the display to a particular element type
or specifying which element properties are displayed and the layout of that display.
The Relationship Matrix and Traceability window for the selected Package are
easily accessed from this panel and there is easy access to management of Project
Reference Data that is commonly used within the Specification Manager.

Element

The 'Element' panel offers a range of facilities for working with the elements that
are displayed in the Specification Manager view. There are facilities for adding
new elements, viewing and editing the Properties of elements, as well as creating,
viewing and managing other items associated with the elements, such as Tests,
Maintenance items (such as Defects, Issues, Changes and Tasks), Resource
Allocations and Element Discussions.

Display

The 'Display' panel provides a range of options that make it possible to tailor the
appearance of the Specification Manager view, to better display the information
you want to examine. There are options providing visual cues, such as highlighting
the selected element and using bold fonts to emphasize element names, as well as
options to filter the list of elements that are displayed.
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Using the Specification Manager
When you begin working in the Specification Manager, there are three general areas of activity you work through:

·
·
·

Setting up the Specification Manager to suit your work requirements
Creating and/or organizing the elements in the View
Performing whatever work you need to do on the elements

The Specification Manager is extremely versatile, and you can use it very simply to create a set of basic elements or at
varying levels of complexity to develop and manage those elements in your project, as you need.

Access
Ribbon

Design > Package > Specification View

Menu

Package | View as Requirement List
Tools | Specification Manager

Context Menu

Right-click on Package | Specification Manager

Keyboard Shortcuts

Ctrl + Shift + X

Initial tasks
Task
Specify the type of element
to work on

Action
Either:

·
·

Work with the default (all element types) or
Select a specific type of element

You specify the element type first because when you come to browse for or select
the Specification Package, if you have specified a particular element type the
system automatically filters the Package selection to only those that contain
elements of that type.
Select the Package to work
in

Set up List Header and
Filter bars

Either:

·
·
·

Work with the default Package
Select another existing Package in the model, or
Create a new Package in the model

Use the 'Field Chooser' dialog to organize the columns that contain the type of
information you want to work with. You can use the Filter bar to select for
information that includes specific values, or hide the Filter bar altogether.
Some of the columns contain indicators that represent records and documents
associated with an element. You can access the item represented by an indicator by
clicking on it.
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As you begin, or at any other time in your use of the Specification Manager, you
can change the appearance of the display to, for example, use smaller or larger text
font, partially or totally hide Notes text, or show the element names in bold.
You can further configure the display and the element definition by including level
numbering and automatic naming, and by applying customized properties such as
additional Requirement Types, Glossary entries and Tagged Value Types.

Organize elements
Task

Action

Add new elements

Create new elements in the model as direct members of the Package or as child
elements of those members.

Delete elements

You can filter out elements from the display by type or according to the value of
various properties. However, if an element does not belong in the Package and
model, you can delete it completely.

Reorganize elements

The Specification Manager reflects the sequence of elements in the Package as
shown in the Project Browser.
To put the elements in the Specification Manager in a different order, move them in
the Project Browser.

Review the elements
Task
Create and Review
Relationships

Action
You can examine existing relationships and create new ones using the Relationship
Matrix, creating and using specific Matrix Profiles.
You can also review existing relationships by opening the Traceability window,
either from the Toolbar or by double-clicking on the blue arrow displayed in the
'Relationship' and 'All Indicators' columns. If the element has no relationships, the
blue arrow is not shown.

Discuss and review
elements amongst project
members

It is possible to create review documents and have recorded text message
discussions on the development of your elements, using the Team Review, Element
Discussion and Model Mail facilities.
If an element has an existing Element Discussion, this is represented by a 'speech
bubble' icon in the 'Discussion' and 'All Indicators' columns. You can open the
discussion by double-clicking on that icon.

Make, Review and Manage
Changes

You can easily view and edit elements directly in the Specification Manager or by
displaying the appropriate window such as the Properties window or Tagged
Values window.
You can also monitor changes to the selected Package or element made anywhere
in the system, using the Baselines and Auditing Facilities.
Further, you can manage changes made by other users, opening the 'Project
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Management' window to quickly assign resources and risks to the work on the
element. You can review work on the elements in the Package by displaying the
Specification Manager in another tab in the form of the Project Gantt chart.
Maintenance and Testing are integrated and easily available to help improve
software quality from the beginning of your project.
Existing records of these items are indicated by icons in the corresponding column,
and can be quickly opened by double-clicking on the icon.
Print the list of entries

A print-out of the Specification Manager element list is a document containing a
simplified version of the screen display:

·
·
·
·

All elements are included, both parent and child elements
The columns are narrowed to fit the page width (if necessary)
The indicator icons are not printed
The font size and type face are uniform across the report

To generate the print-out:

Generate reports

1.

Click on the
drop-down arrow in the Navigator Toolbar and select the
'Documentation & QA | Generate Documentation' option.
On the 'Generate Documentation' dialog, the 'Template' field defaults to
'Specification Manager List'.

2.

If necessary, specify the output file and output format, then click on the
Generate button.

3.

Display and print the output file.

If you should need to extract and/or publish more of the information in the
Specification Manager, you can do so in a range of forms such as:

·

Generating standard or customized document reports in RTF, DOCX or PDF
format

·
·

Publishing on the web in HTML, or
Exporting to a spreadsheet tool in CSV format

Notes
·

As you work on the information on the Specification Manager, periodically press F5 to refresh the view to include
any updates performed by other users elsewhere in the system

·

In the Corporate and extended editions of Enterprise Architect, a User Security system can be applied that restricts
or enables access to a range of operations and functions; if you cannot access a function in the Specification
Manager, check with your System Administrator or Security Administrator to see if you have access permissions to
work with that function
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Select Specification Type
When you start to use the Specification Manager you can work on elements of all types in the Package (the default) or
identify a specific type of element to work on. You can select any type of element supported by Enterprise Architect or
the MDG Technologies that are integrated with the system.
If you specify the element type first, when you go on to locate the Package to work in, the system automatically filters
for Packages that already contain that type of element.

Access
Ribbon

Specification-Specify > Specification > Set Default Type > <Any> or
Specification-Specify > Specification > Set Default Type > Other > select <type>

Select the element type
Click on either:

·

'Other', and expand the technologies and element groups until you can click on a specific element type to filter for,
or

·

select an element type from the list of recently used types (if you have not previously selected a specific element, or
you have cleared the list, this list is not available)

Also check that the 'Limit Display to Selected Type' option is selected.
To revert to listing any type of element in the Package, click on either the:

·
·

'<Any>' option or
'Limit Display to Selected Type' option again to deselect it

(c) Sparx Systems 2015 - 2016
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Select Specification Package
When you start to work with the Specification Manager, you identify the Package in which to build your specification.
When you open the facility, the Specification Package defaults to the first top-level Package in your model, as indicated
by the 'breadcrumb trail' in the Navigator toolbar. If this is the Package in which you intend to work, you can go on to
configure the display and create or review elements.
You might, however, want to use a different Package that:

·
·
·
·

Already exists in the model and already contains elements of the specified type
Already exists in the model but contains no elements of the specified type
You will create underneath the current Specification Package, OR
You will create underneath a different Package elsewhere in the model

You can perform these tasks using the 'native' facilities of the Navigator Toolbar, or through various procedures
described here.

Access
Ribbon

Specification-Specify > Specification > Package > Open
Specification-Specify > Specification > Package > New

Context Menu

Right-click on Package | Specification Manager

Keyboard Shortcuts

Ctrl + Shift + X

Locate existing Package containing specification elements
Step
1

Action
Click on the ribbon option 'Specification-Specify > Specification > Package > Open'.
The 'Select a Specification Package' dialog displays. This dialog presents your model hierarchy, filtered to
show only those Packages that already contain elements of the type you selected as the Specification
element type.

2

To expand a Package, click on the expansion box next to the Package name, or click on the Expand All
button.

3

Click on the required Package, and click on the OK button.
The Package name displays in the 'breadcrumb trail' in the toolbar, and the elements in the Package are
shown in the main body of the Specification Manager window, filtered to the specified type if
appropriate.

4

Customize the columns and/or add elements to the Package.

(c) Sparx Systems 2015 - 2016
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Locate existing Package
It is possible that you want to create your specification in a Package that has been set up for this purpose but does not yet
contain any elements (or any of the specified type). In this case the Package would not be included in the 'Select a
Specification Package' dialog. To select this Package for the Specification Manager:

·

Right-click on the Package name in the Project Browser and select 'Specification Manager' from the context menu,
or

·
·

Select the Pacakge in the Project Browser, then press 'Ctrl + shift + X', or
With the Specification Manager window already open, double-click on the Package name in the Project Browser

The Package name displays in the view header and Toolbar.
If this does not work as described, display the 'Preferences' dialog ('Start > Workspace > Preferences > Preferences'),
select the 'General' page and click on the 'Shows Properties' radio button in the 'Double Click on Browser' panel.

Create new Package
This method creates a new Package underneath the current Specification Package.
Step
1

Action
From the ribbon bar, select 'Specification-Specify > Specification > Package > New'.
The 'New Package' dialog displays.

2

In the 'Name' field, type the name of the new Package.
(Optionally, you can also select a radio button to automatically create a new diagram in the Package.)

3

Click on the OK button.
The new Package becomes the current Specification Package in the Navigator toolbar. The Package is
also added to the Project Browser, underneath the previous Specification Package.

4

Customize the columns and/or add elements to the Package.

Create new Package elsewhere in the Model
This method creates a new Package underneath a different Package in the model.
Step
1

Action
From the ribbon bar, select 'Specification-Specify > Specification > Package > New'.
The 'New Package' dialog displays.

2

Click on the Browse button beside the 'Owner' field.
The 'Select Owner' dialog displays.

3

Browse through the model and click on the existing Package under which to create the new Package.
Click on the OK button.
The 'Owner' field in the 'New Package' dialog is updated.
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4

In the 'Name' field, type the name of the new Package. Optionally, you can also select a radio button to
automatically create a new diagram in the Package.

5

Click on the OK button.
The new Package becomes the current Specification Package, named in the window toolbar. The Package
is also added to the Project Browser, underneath the selected parent Package.

6

Customize the columns and/or add elements to the Package.
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Customize Columns
The Specification Manager can display a wide range of properties for the elements in the selected Specification
Package, each property being shown in a separate column. Using the 'Field Chooser' dialog, you can customize the
display of the columns so that you show as many or as few as you need, in an appropriate sequence. Also, you can add
columns to show the values of specific tags used in individual elements or globally across the Package.
Having added the columns you need, you can use full or partial property values in the Filter bar as a means of filtering
the display to show only those elements that have property values that match the filters.

Access
Other

Right-click column headings | Field Chooser
Right-click column headings | Toggle Filter Bar

Using the Field Chooser
Drag the column headings that you want to include out of the 'Field Chooser' and onto the header bar, in the position you
want the column to occupy in the sequence of column headings. You can drag an existing heading from its current
position in the bar to another position in the sequence, including making it the final column.
If you do not want to include a column that is already in the heading bar, drag it up or down out of the bar. It is
automatically returned to the 'Field Chooser' dialog.

Using the Filter bar
In the Filter bar, you define a text string that any displayed values in the corresponding column must include.
In the filter field for a column, type the character or string that must form part of the value shown in each row of that
column. As you type the string, element rows in the Specification Manager that do not match the filter are hidden from
display.
To clear the text in the filter field, click on the green cross at the right of the field.
You can display or hide the Filter bar using either the right-click context menu or
'Toggle Filter Bar' option.

| 'Appearance', and selecting the

Add Tagged Value Column
If you want to show the value that any element in the list has for a particular tag, you can add a column specifically for
that tag. There are two ways in which to do this:
Method

Action

1

Open the Tagged Values window for the element and drag the tag onto the
Specification Manager; a new column is added for each tag you drag onto the list.

2

Either:
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Right-click on the element in the Specification Manager, or
Right-click on the column headings

Then select the 'Add Tag Value Column' option; the 'Add Tag Value Column'
dialog displays.
Either type the tag name into the 'Tagged Value' field, or select one of the two
radio buttons:

·

Global Tagged Values - populates the 'Tagged Value' drop-down list with all
global Tagged Values in the project; you can select a Tagged Value that is
applicable to a large number of elements

·

Tagged Values from the selected Element - populates the 'Tagged Value'
drop-down list with the Tagged Values defined for the selected element (as
listed on the Tagged Values window for that element); select the Tagged Value
from this filtered list of tags

When you have selected the required tag, click on the OK button to add a column
for that tag to the Specification Manager columns.

Notes
·
·

You can edit the values of the tags in the Tagged Value columns; see Editing Elements

·

You can hide a Tagged Value column by dragging the column title off the header bar - as for any other column - so
that the column header is added to the 'Field Chooser' dialog

·

You can remove a Tagged Value column altogether by right-clicking on the column header and selecting the
'Remove Tag Value Column' option

The column layout for any added Tagged Value columns is preserved when you close the Specification Manager
and re-open it for the same Package

(c) Sparx Systems 2015 - 2016
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Adding Elements
The Specification Manager is an excellent model development tool, through which you can create elements in the
Package you are reviewing in a number of ways. You can add new elements either:

·
·

Directly to the Package or
As child elements of an element in the Package

There are several methods of adding a new element, some of which vary depending on whether you have set a specific
element type as the Specification Type, or set the display to list all types of element in the Package. If you import a set of
element data from an external spreadsheet (.csv) file, this setting will also filter the imported information to show
elements of the specified type or all types.

Access
With the Specification Manager window open;
Diagram Toolbox

Drag an element icon from an appropriate page of the Diagram Toolbox

Ribbon

Specification-Specify > Element > Add > Add Default
Specification-Specify > Element > Add > Add Child
Specification-Specify > Element > Add > Repeat Previous
Specification-Specify > Element > Add > Add Other

Context Menu

Right-click window | Add New Element
Right-click window | Add New Child
Right-click window | Repeat Last Element

Keyboard Shortcuts

Ctrl+N

(new element)

Ctrl+Shift+N (new child element)
Shift+F3

(repeat previous element)

Add an element from the Diagram Toolbox
When you have the appropriate page of the Diagram Toolbox displayed (press Alt+5 and use the More tools button to
locate the page), you can drag an element icon to a specific point on the Specification Manager View. The element
entry immediately above the cursor is indicated by a blue side-bar, and a context menu displays with three options:

·
·
·

'Insert after Selection' - the new element will be added as a peer immediately underneath the highlighted element
'Insert as Child' - the new element will be added as a child of the highlighted element
'Add to End of Document' - the new element will be added to the end of the list, as a peer of the highest level of the
hierarchy

Add element of predefined Specification Type
If you have set the Specification Type to a particular type of element:

·

An element of that type is immediately added to the Specification Manager; the element has either the system
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default element name or a name that you have set up under your own naming conventions

·
·

The name is highlighted and, if you want to change it, you can immediately type in an alternative name
If the element is a child of an existing element, the entry is added underneath the parent, indented and in a smaller
font; the parent element is given a +/- expansion box

Add element of any Specification Type
If the Specification Manager is listing elements of any type, or if you have set the 'Specification Type' to '<Any>', the
'New Element' dialog displays. You can use this dialog to create an element of any type that the model supports.

Add elements from Pattern
Enterprise Architect provides Patterns in the Diagram Toolbox and in the Resources window, and you can create your
own Patterns and make them available from the same places. Patterns are a great way to create template structures of
elements in your specifications, and you can 'drag and drop' them from the Toolbox or Resources window into the
Specification Manager.
When you release the mouse button to 'drop' the Pattern, a short menu displays from which you select to add the Pattern
elements underneath the item immediately above either as a peer structure or as a child structure.

Notes
·

If you add an element of the defined Specification Type to the selected Package in the Project Browser, it is also
added to the Specification Manager

·

In the Corporate and extended editions of Enterprise Architect, a User Security system can be applied that restricts
or enables access to a range of operations and functions; if you cannot access a function in the Specification
Manager, check with your System Administrator or Security Administrator to see if you have access permissions to
work with that function
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Deleting Elements
The Specification Manager provides a direct view of a Package in your model, and reflects the contents of the Package
as it appears in the Project Browser. If you delete an element from the Specification Manager, it is removed from the
model and therefore also disappears from the Project Browser. Any child objects that the element has are also deleted
from the model.

Access
Context Menu

Right-click on Element | Delete Selected

Keyboard Shortcuts

Ctrl + D
Ctrl + Del

Delete an element
When you select to delete an element in the Specification Manager, a prompt displays to confirm that you want to
delete the element from the model.
Click on the Yes button. The element is removed from the Specification Manager and all other windows and diagrams in
which it appears.

Notes
·

You cannot select more than one separate element at a time in the Specification Manager, and therefore you cannot
delete multiple elements there; you can, however, select and delete multiple elements from the Project Browser,
which also removes them all from the Specification Manager in one operation

·

In the Corporate and extended editions of Enterprise Architect, a User Security system can be applied that restricts
or enables access to a range of operations and functions; if you cannot access a function in the Specification
Manager, check with your System Administrator or Security Administrator to see if you have access permissions to
work with that function
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Editing Elements
When you have created elements in the Specification Manager, you can add and review the properties and
characteristics of each element to whatever extent you need. You could simply set some basic properties such as the
element version, status and general description, or you could develop extended properties (Tagged Values) or add a
Linked Document to add more detailed and extensive information on the element.

Editing tasks
Task
Display/Edit Element
Properties

Action
Where a column in the Specification Manager contains a property value, you can
double-click on the value and either:

·
·

Type a different value (such as the element name) or
Click on the field to display a drop-down arrow and select a value from the list

Alternatively, click on the value and press F2.
Otherwise, you can right-click on the item and select the:

Edit Element Notes

·

'Properties' menu option (or press Alt+Enter) to display the 'Properties' dialog,
or

·

'Properties window' menu option (or press Alt+1) to display the Properties
window

The Specification Manager provides the facility for viewing existing Notes text on
each element, or for creating and editing Notes, depending on how you have
configured the display of Notes on the screen.
If you select the 'Notes Preview' option, the first line of any Notes text in the Notes
window displays underneath the element name. You cannot add or edit text in this
space, but you can work on the text in the Notes window itself (click on the text and
press the Space bar).
If you select the 'Full Notes' option, either inline or in column, the complete text of
any existing Notes displays underneath or to the right of the element name,
respectively. You can now create and edit the Notes directly in the field - simply
click twice on the area and type in the text.
The text you type here can also be viewed in the Notes window; text edits in one of
the views (Notes window or Specification Manager) are updated in the other view
as soon as you click off the item.
In either view, you can also right-click on a text string to display the 'Notes' context
menu and perform further operations, and use keyboard shortcuts. These operations
include:
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·

Creating a Glossary definition from the text, and inserting existing definitions
in the text

·

Generating a new element in the same Package, with the selected text as the
name and linked to the text

·

Generating a new element linked to the text, that you effectively drag directly
onto an open diagram

·

Creating a link from the selected text to an existing element in the model (in
the Notes window only)

·

Creating a hyperlink to a wide range of target objects, including image files,
diagram images, web pages, text files, Help topics and Enterprise Architect
commands (Notes in the Specification Manager, or using the 'Hyperlink' icon
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in the Notes window toolbar)

·

Searching for instances of the selected text in a range of sources (options
derived from the 'Code Editor' context menu)

·

Editing the text, with cut, copy, paste and delete

You can also select an option to hide the Notes text altogether on the Specification
Manager, in which case the element rows close up.
Locate a selected element
in the Project Browser

Right-click on the element item and select the 'Find in Project Browser' option (or
click on the item and press Ctrl+F).
The system expands the Project Browser and highlights the element name.

Review extended
properties (Tagged Values)
on an element

Right-click on the element item and select the 'Extended Properties' option (or click
on the item and press Ctrl+Shift+6).
The Tagged Values window displays, through which you can view, add, edit and
delete Tagged Values on the selected element.
Once the Tagged Values window is open, you can click on any element in the
Specification Manager and immediately switch the focus of the Tagged Values
window to that element.
You can also show the values for specific tags used in the Package, with a Tagged
Values column for each named tag. See Customize Columns. If an element has a
Tagged Value that matches the column header, you can edit the value. For:

·

Values selected from a defined list, double-click on the value and change it in
the Tagged Values window

·

Free-text values, whether simple or <memo> type, click twice on the value and
edit it in place

The field is not editable if the element does not have the tag, is locked or has
duplicate tag names.
Create, edit and delete a
linked document on an
element

There are several ways in which you can create documentation on an element in the
Specification Package, through the window Toolbar options.
You can also create a linked document on the selected element, by:

·

Right-clicking on the element line and selecting the 'Create Linked Document'
option, or

·

Clicking on the element line and pressing Ctrl+Alt+D

The 'New Linked Document From Template' dialog displays, from which you select
any template you want to base the document on, or 'None' for a free-style document
with no template.
When you click on the OK button, the 'Linked Document Editor' view becomes
active, and you can create a document describing any aspect of the selected
element.
If the element already has a linked document, the menu options available change to:

·
·
Finishing and Saving your
changes

'Edit Linked Document' (Ctrl+Alt+D) and
'Delete Linked Document'

A quick way to save your changes and exit from the item editor is to press Esc.

Notes
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·

You can also copy-and-paste text from a text file into the Specification Manager, using the text to fill the element
name or notes text area of an existing element entry

·

In the Corporate and extended editions of Enterprise Architect, a User Security system can be applied that restricts
or enables access to a range of operations and functions; if you cannot access a function in the Specification
Manager, check with your System Administrator or Security Administrator to see if you have access permissions to
work with that function

(c) Sparx Systems 2015 - 2016

Page 22 of 48

Created with Enterprise Architect

User Guide - Specification Manager

15 July, 2016

Indicator Columns
An element specification can have any of a number of resources associated with it. You can obtain a quick indication that
resources exist for the element by displaying the corresponding column (selected from the 'Field Chooser' dialog) on the
Specification Manager; if the resource exists, an icon displays in the column against that element. When an indicator is
displayed, you can double-click on the icon to immediately access the record or the first in a set of records for the
element, in the corresponding window. You can use these windows to edit, delete or (where appropriate) add to the
records against the element.

Columns
Column Header

Indicator

Relationship
Indicates that...: The selected element has at least one relationship to another
element, which is shown in the Traceability window.
Resource
Indicates that...: There is at least one resource assigned to a task on the element, in
the Resource Allocation window.
Risk
Indicates that...: There is at least one Risk item defined for the element, in the Risk
window.
Maintenance
Indicates that...: There is at least one Maintenance item defined for the element, in
the Maintenance window.
Test
Indicates that...: There is at least one Test item defined for the element, in the
Testing window.
File
Indicates that...: The selected element has at least one associated file, defined on the
'File' page of the element 'Properties' dialog.
Discussion
Indicates that...: There is a discussion thread on this element, in the Element
Discussions window.
Document
Indicates that...: There is a linked document for this element.
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Indicates that...: Any or all of the above items exist for the element, as indicated by
the corresponding icon.
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Traceability
As you create and set up the elements in your Specification Package, using the Specification Manager, it is critical to:

·

Trace any existing relationships those elements have to the elements in the model that realize them, or are realized
by them

·

Follow the relationships of such elements further, to check how changes to a source element or its relationships
might affect other relationship chains in which the target elements are involved

·

Create new relationships, where you can do so quickly and with an immediate view of how elements as a group are
connected across the model

The two most significant tools for this are the Traceability window and the Relationship Matrix.
When you display the Traceability window, you can review every relationship in which the element selected in the
Specification Manager is the source or target, the details of each of the related elements, and the relationships in which
each of those elements are involved.
In the context of the Specification Manager, the Relationship Matrix provides a view of the relationships between the
elements within the Specification Package, or between the elements of the Specification Package and a different
Package. You can also use it to quickly create many relationships between the elements, defining a simple organization
within the Specification Package and defining its relationships with other Packages.

Access
Ribbon

Specification-Specify > Specification > Matrix > <options>
Specification-Specify > Specification > Traceability

Keyboard Shortcuts
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Create Matrix Profile
In using the Specification Manager you work on a specific Package and element type. If you want to use a
Relationship Matrix profile to look more closely at the relationships of elements in that Package, it is therefore more
logical to define the profile from the information already set in the Specification Manager, before you open the
Relationship Matrix. The system helps you to do this. You can also apply this procedure to creating the matrix profile
represented by a Matrix Specification Artifact element.

Access
Ribbon

Specification-Specify > Specification > Matrix > Matrix Profiles > Create new
Profile

Create the Matrix Profile
Field/Option/Button

Action

Profile Name

Type in a name to identify the profile.

Source

Displays the name of the current Specification Package, as the source Package in
the Relationship Matrix.
If necessary, you can click on the

button and select a different Package.

Type

(For the Source Package) Displays the name of the current Specification element
type. If necessary, you can click on the drop-down arrow and select a different
element type.

Target

Defaults to the name of the current Specification Package as the target Package of
elements in the relationships to examine.
If you want to examine relationships to elements in a different target Package, click
on the
Package.

button and, on the 'Browse Project' dialog, locate and select that

Click on the OK button to put the Package name in the 'Target' field.
Type

(For the Target Package) Defaults to '<All>' target element types.
If you want to examine relationships to a specific type of element, click on the drop
down arrow and click on the element type name.

Relationship

Defaults to 'Realization' as the type of relationship to display.
If you want to examine relationships of a different type, click on the drop down
arrow and click on the relationship type name.

Direction

Defaults to 'Source -> Target' as the direction of the relationships to examine.
If you want to examine relationships in the opposite direction, or in both directions,
click on the drop-down arrow and select the appropriate option.
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Click on this button to create the profile and close the dialog.
The Relationship Matrix automatically opens, applying the Profile that you have
just defined.

Cancel

Click on this button to discard any values you have entered, and to return to the
Specification Manager.

Notes
·

After you have created a Matrix profile, the name of the profile is added to a list of profiles that include the
Specification Package and Specification element type, under the 'Create new Profile' menu option; when you click
on the profile name, the Relationship Matrix immediately displays with that profile in effect

·

In the Navigator Toolbar, when you click on the 'Package' arrow the drop-down menu also includes the 'Create new
Profile' option and the list of existing profiles that you can select to open and apply to the Relationship Matrix

·

In the Corporate and extended editions of Enterprise Architect, a User Security system can be applied that restricts
or enables access to a range of operations and functions; if you cannot access a function in the Specification
Manager, check with your System Administrator or Security Administrator to see if you have access permissions to
work with that function
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Open Relationship Matrix
If you want to quickly create relationships on the elements in your Specification Package, or review the relationships that
already exist, you can do so very easily using the Relationship Matrix. By opening the Relationship Matrix from within
the Specification Manager, you can use the parameters already set in the Specification Manager to automatically
configure the Relationship Matrix.

Access
Ribbon

Specification-Specify > Specification > Matrix > <options>

Open the Relationship Matrix
Option
As Source

Action
Open the Relationship Matrix with the Specification Package set as the Source
Package and the Specification Type element type as the Source element type.
Other fields default from the last settings of the Relationship Matrix; you can
change any fields as necessary.

As Target

Open the Relationship Matrix with the Specification Package set as the Target
Package and the Specification Type element type as the Target element type.
Other fields default from the last settings of the Relationship Matrix; you can
change any fields as necessary.

As Both

Open the Relationship Matrix with the Specification Package set as both the
Source Package and the Target Package, and the Specification Type element type as
the Source and Target element type.
Other fields default from the last settings of the Relationship Matrix; you can
change any fields as necessary.

Matrix Profiles
Option
Previous Settings

Action
Open the Relationship Matrix using the previously-processed settings; that is, the
last settings under which changes were saved to the repository.
These settings could have been defined during your use of the Specification
Manager, or in the Relationship Matrix independent of any use of the Specification
Manager.

Create New Profile
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Define a Matrix profile with the Specification Package set as the Source Package
and the Specification element type set as the Source element type, and
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automatically open the Relationship Matrix with this profile in effect.
<Profile names>

Select an existing Matrix profile from the list of profiles that include the
Specification Package and Specification element type, and automatically open the
Relationship Matrix with this profile in effect.

Notes
·

In the Corporate and extended editions of Enterprise Architect, a User Security system can be applied that restricts
or enables access to a range of operations and functions; if you cannot access a function in the Specification
Manager, check with your System Administrator or Security Administrator to see if you have access permissions to
work with that function
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Reviewing Elements
When you are managing or working as a member of a project team, it is useful to have mechanisms for reviewing the
work you are doing and keeping some record of those reviews, whether they are casual discussions between peers or
coordinated, structured and formal reviews. The Specification Manager provides a number of facilities that support the
full range of review types, focused on the elements that are defined in the Specification Package.

Access
Ribbon

Show > Window > Team Review
Construct > Project > Team Review
Specification-Specify > Specification > Team Review > Open Team Review
Specification-Specify > Specification > Team Review > Create Review Document
Specification-Specify > Specification > Team Review > Auto Generate Review
Specification-Specify > Specification > Team Review > Bind Package to Team
Review Folder
Specification-Specify > Specification > Team Review > Model Mail
Specification-Specify > Element > Discuss

Review facilities
Facility
Review Documents

Description
It is possible to create any number of 'Review Documents' on the elements of the
Specification Package, both to formalize and guide specific review processes and to
present the element information to be reviewed.
The documents are stored in and easily accessed from the 'Team Review' feature.

Bind Package to Team
Review Folder

By default, 'Review Documents' are stored in folders under a special category of the
Team Review, called 'Formal Reviews'. You can, however, generate those
documents elsewhere in the Team Review, by binding the Specification Package to
whichever Team Review folder (topic) is most appropriate to the Package.

Team Review

The Team Review tools provide a number of other facilities that can be of use in
discussing the development and features of an element, such as the 'Resources'
folder or the ability to develop a sequence of communications on a specific
element, on a group of elements, or on some broader aspect of the model
development.

Element Discussions

Using the 'Element Discussions' facility, you can initiate or respond to a general,
ad-hoc discussion amongst your team members, on a specific element. The facility
maintains a record of each initial comment or question, and every response to that
comment.
There is no limit on the number of different discussions, on the number of
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responses, or on the length of each item, although the facility is better suited to
short queries and responses.
When there is a discussion on an element, the
icon displays in the 'Discussion'
and 'All Indicators' columns on the Specification Manager. Simply double-click
on the icon to display the discussion.
You can also access the 'Element Discussion' window through the 'Navigator
Toolbar' menu path.
Model Mail

The Model Mail facility is a personal, project-internal email service. You can use it
to send emails to specific individuals or groups on your project, concerning the
Specification Manager contents or functions, or any other subject you need to
discuss.
If you want to discuss a particular element, click on it in the Specification Manager
and use the Model Mail 'Create | Link to Existing Element' context menu option to
create a hyperlink in the mail message to the element.
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Create Review Document
When you are managing the work of a project team, it is useful to have a mechanism for coordinating and guiding the
work that the team members are required to do on the elements in the Specification Package, such as a review document.
You can generate this type of document quickly and simply within the Specification Manager, to be distributed,
accessed and read through the Team Review facility.
There are, broadly, two types of review document that you can generate:

·

A specification document that contains the material to be reviewed - the individual features of each element - such as
a Model Overview, List of Issues or Maintenance Report, and

·

A management or review document that guides the reader in applying tests, checks and procedures across the
Package, such a Phase Review, Test Plan or Training Plan

You can generate both kinds of document from one of a range of templates, or create a document without using any
template. The templates are all those available through the Report Generator (specification documents) or Linked
Document Editor (management documents), whether system-provided or user-designed.
The specification documents automatically structure information from the Specification Manager according to the
selected template and should not require further editing to serve their purpose (although it is possible to edit them if you
wish). They are therefore termed 'auto-generated documents'.
By default, 'Review Documents' are stored in folders (Topics) in a special category of the Team Review, called 'Formal
Reviews'. You can, however, generate those documents elsewhere in the Team Review, by binding the Specification
Package to whichever Team Review folder is most appropriate to the Package. For example, if you have a modular
structure in the Team Review, you might want to hold the 'Review Documents' for a Specification Package in the same
section of the Team Review as folders containing discussions and documents on the part of the model containing that
Package.

Access
Ribbon

Specification-Specify > Specification > Team Review > Create Review Document
Specification-Specify > Specification > Team Review > Auto Generate Review
Specification-Specify > Specification > Team Review > Bind Package to Team
Review Folder

Create a Review Document
Field/Option/Button
Name

Action
On the 'Review Document' dialog, type a name for the document.
This is the name that you use to recognize and open the document in the Team
Review folders.

RTF Template

Click on the drop-down arrow and select either:

·
·
OK
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'None' to create a free-format document yourself, or
A document template name, to create a document of that type

Click on this button to open the document in the 'Document Editor', which you can
use to populate the document with text and images, format it and print it.

Page 32 of 48

Created with Enterprise Architect

User Guide - Specification Manager

15 July, 2016

At the same time:

·
·

The 'Team Review' window opens

·

A folder is created with the same name as the Specification Package (if it does
not already exist) in the 'Formal Reviews' category

·

The review document name is added to this folder

The 'Formal Reviews' category is created (if it does not already exist) in the
Team Review

If you have bound the Package to a different Team Review folder, the 'Review
Document' is created in that folder instead of under the 'Formal Reviews' category.

Auto-generate a Review Document
Field/Option/Button
Name

Action
On the 'Review Document' dialog, type a name for the document.
This is the name that you use to recognize and open the document in the Team
Review folders.

RTF Template

Click on the drop-down arrow and select a document report system-template name,
to create a document of that type

OK

Click on this button to generate the document through the Document Report
Generator, containing the information currently displayed in the Specification
Manager, within the parameters of the report template.
At the same time:

·
·

The 'Team Review' window opens

·

A folder is created with the same name as the Specification Package (if it does
not already exist) in the 'Formal Reviews' category

·

The review document name is added to this folder

The 'Formal Reviews' category is created (if it does not already exist) in the
Team Review

The document is displayed in the 'Team Review' tab for any further editing and
modification you need, although the document is effectively ready for immediate
use.
If you have bound the Package to a different 'Team Review' folder, the 'Review
Document' is created in that folder instead of under the 'Formal Reviews' category.

Bind Package to different Team Review folder
Step

Action

1

On the 'Select a Topic to Link' dialog, click on the expansion box next to the appropriate category name to
display the topic folders it contains.

2

Click on the appropriate topic folder name.
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Click on the OK button.
When you:

·
·

Create a 'Review Document', it will now be automatically stored in the selected topic folder

·

Select the 'Current Reviews' option, the submenu will list the documents held in the selected folder;
click on one to open it

Select the 'Show Current Review Folder' option, the Team Review window will open with the
selected folder name highlighted and expanded

Notes
·

For a given Specification Package, you can generate as many review documents as you require

·

Before you generate a Review Document from the Specification Manager, you could run the system Spell Checker
over the Specification Package to remove any errors in the text
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View Review Document
In the Specification Manager, you can generate a range of documents that either guide a structured review of the
elements you have listed, or provide the actual material - the descriptions, features and properties of the elements - to be
reviewed. These documents are, by default, stored in the 'Formal Reviews' category of the Team Review, from which
point they can be accessed in a number of ways. Whichever access path you select, the document opens in the application
work area and you can read the document online, edit it and/or print it.
If you want to edit or print the document, you can do so using the facilities of the common document editor, which is
used in creating and editing both documents and document templates.
The Specification Manager also provides a facility for changing the default folder into which the 'Review Documents' are
generated, and from which you can select the documents to open.

Access
Ribbon

Specification-Specify > Specification > Team Review > Current Reviews >
<document name>
Specification-Specify > Specification > Team Review > Current Reviews > Show
Current Review Folder
To open Team Review window:

·
·
·
Other

Show > Window > Team Review or
Construct > Project > Team Review or
Specification-Specify > Specification > Team Review > Open Team Review

From the Team Review window:

·

Formal Reviews | <Package name> | double-click <document name>

Notes
·

If you have changed the default folder for the Package (by binding the Package to a folder other than those in the
'Formal Reviews' category), the 'Current Reviews' and 'Show Current Review Folder' options will automatically
show the new default folder and the documents it contains; if you access the Team Review window directly, you
would need to know the name and location of the new default folder
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Managing Changes
If you are responsible for a team of people who are working on the specification, you can manage their work and monitor
the changes that they are making within the Specification Manager. You can use the Specification Manager options and
column indicators to open a number of management and monitoring tools, keeping the focus on the specification work
rather than having to establish the focus in each management tool separately.

Access
Ribbon

Specification-Specify > Specification > Package > Manage Baselines
Specification-Specify > Specification > Package > Auditing
Construct > Task Management > Resource Allocation
Construct > Change Management > [maintenance items]
Construct > Testing > Test Windows > [test class]
Specification-Specify > Specification > Package > View Package as Gantt

Management and Monitoring facilities
Facility
Manage Package Baselines

Description
Click on this option to open the 'Package Baselines' dialog, which you can use to
capture the state of development of the Specification Package at any appropriate
point in time, as a Baseline. You can then compare the current state of the Package
with a previously-captured Baseline and establish the changes that have been made
since that Baseline was made.
You can also roll back any of the changes that you do not want to keep.

View Audit Trail

Click on this option to display the 'Audit View' and the 'Audit History' tab of the
'System Output' window.
You can use the 'Audit View' initially to turn on and configure Auditing, and then
to perform audit checks on changes to the elements and connectors in the
Specification Package (which might include changes to objects other than those of
the Specification element type). The results of the audit check are displayed both in
the 'Audit View' and in the 'System Output' window.

Resources

Click on this option to display the 'Resource Allocation' window. You can use this
window to define and allocate work for the people (resources) working on the
Specification Package, either at Package level or at element level (select an element
on the Specification Manager before defining the work).
You can also select the 'Risk', 'Effort' and 'Metrics' windows to define other aspects
of work on an element.
Once you have allocated a resource or defined a risk, an icon displays on the
element row in the corresponding column of the Specification Manager, and in the
'All Indicators' column. You can double-click on the icon to redisplay the
appropriate 'Project Management' window and review the record, and to add more
records if necessary.
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Click on this option to display a submenu of Maintenance items:

·
·
·
·
·
·

Defects
Changes
Issues
Tasks
Decisions
Events

Select one of these options to display the corresponding version of the
Maintenance window, on which you can create a record to define the maintenance
item for the Specification Package or a selected element within it.
When you create one of these records, an icon displays on the element row in the
'Maintenance' and 'All Indicators' columns of the Specification Manager. You can
double-click on the icon to redisplay the Maintenance window and review the
record, and to add more records if necessary.
Testing

Click on this option to display a submenu of test types:

·
·
·
·
·
·
·

All
Inspection
Unit
Integration
System
Acceptance
Scenario

Select one of these options to display the corresponding version of the 'Testing'
window, on which you can create a record to define a Test for the Specification
Package or a selected element within it.
When you create one of these records, an icon displays on the element row in the
'Test' and 'All Indicators' columns of the Specification Manager. You can
double-click on the icon to redisplay the 'Testing' window and review the record,
and to add more records if necessary.
View Package as Gantt

Click on this option to display the 'Package Browser' view in Gantt format, for the
Specification Package. This view lists all the elements in the Package, showing
their assigned resources and the progress of work on their separate tasks, both in
text on the left hand side and as a graphical timeline on a calendar on the right.
You can review the element properties or resource details by double-clicking on the
item.

Notes
·

If a record or entry does not display on the Specification Manager when you save the record, press F5 to refresh the
display

·
·

Package Baselines and Auditing are available in the Corporate and extended editions of Enterprise Architect
In the Corporate and extended editions of Enterprise Architect, a User Security system can be applied that restricts
or enables access to a range of operations and functions; if you cannot access a function in the Specification
Manager, check with your System Administrator or Security Administrator to see if you have access permissions to
work with that function
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Reporting
As you develop the elements in the Specification Package, you can produce a number of documents and reports to either
disseminate the information you have compiled or to extract additional information on the elements from other aspects of
model development and management, that might not be immediately visible in the Specification Manager.
You can also export the data you have created to a .csv file and perhaps onwards to another tool, or import element
information created outside Enterprise Architect.

Access
Ribbon

Publish > Documentation > Document > Generate Documentation
Publish > Documentation > Web > Standard HTML Report
Publish > CSV > CSV Import/Export
Construct > Project > Status > QA Reports and Use Case Metrics
Publish > Docuementation > Spelling > Spell Check the Current Package

Review facilities
Facility
Generate documentation in
report document format

Description
Enterprise Architect provides a comprehensive report generation facility, through
which you can create a range of reports on different aspects of your model. You can
apply this facility to the elements of a Specification Package, to generate a report in
any of these formats:

·
·
·

RTF
PDF
DOCX

Select the 'Generate Documentation (RTF/PDF/DOCX)' option.
The 'Generate Documentation' dialog displays, with the 'Element' field set to
'Selected Elements' (the Specification Package elements, as the target contents of
the report).
Generate documentation in
web page format (HTML)

As you develop the Specification Package elements you can publish them on the
web, where the outline structure closely mirrors the Package structure and makes it
very simple to explore on-line. You export the Package to web pages, where the
web report provides an easy to use, highly detailed, Javascript-based structure. In
addition, any hyperlinks in the elements make browsing to related information very
simple.
Select the 'Publish as HTML' option.
The 'Publish as HTML' dialog displays, with the Specification Package name in the
'Package' and 'Title' fields.

Generate spreadsheet file
(CSV) and import from a
spreadsheet
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export element data from a Package into a .csv file.
You can perform both of these operations within the Specification Manager, to
bring in an existing set of element definitions to the Specification Package or
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transfer the Enterprise Architect element definitions to a different location.
Select the 'CSV Import/Export' option.
As part of either operation, you need to create a CSV Specification file.
Whilst your display might be filtered to show a specific type of element, the
operations work on the Package itself and incorporate all types of element within
the Package.
After you perform an import, refresh the display (press F5) to show the imported
elements.
Generate Quality
Assurance reports and
Metrics

Enterprise Architect provides several Quality Assurance reports for checking the
development and impact of development of the elements in a Package. You can
access these within the Specification Manager, so that the Specification Package is
automatically the target of the report.
You can also view and adjust the metrics report should you want to monitor the
impact on the project metrics of the work that the elements in the specification
might entail.

Spell-check the Package

Before generating and/or printing any information from the Specification
Manager, you could run the system Spell Checker over the Specification Package
to remove any errors that might exist in the element names and text.
Select the 'Spell Check Current Package' option to display the 'Spell Check:
<Package Name>' dialog, and click on the Start button.

Notes
·

In the Corporate and extended editions of Enterprise Architect, a User Security system can be applied that restricts
or enables access to a range of operations and functions; if you cannot access a function in the Specification
Manager, check with your System Administrator or Security Administrator to see if you have access permissions to
work with that function

(c) Sparx Systems 2015 - 2016
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Specification Manager Configuration
As you work with the Specification Manager, you can tailor the display to provide more precise information, and to
better represent the information. The Specification Manager provides options to:

·
·
·

Create reference data to work from
Modify the appearance of the entries, including the amount of Notes text to show
Apply level numbering and automatic element naming and numbering

(c) Sparx Systems 2015 - 2016
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Appearance Options
It is possible to tailor the appearance of the Specification Manager view to better display the information you want to
examine.

Access
Ribbon

Specification-Specify > Element > Notes Format > [format option]
Specification-Specify > Display > Bold Names
Specification-Specify > Display > Collapsible Regions
Specification-Specify > Display > Highlight Selection
Specification-Specify > Display > Font Size > [size option]

Adjust the appearance of the display
Aspect
Display of Notes

Description
In the Specification Manager you can choose to hide, check, or create and edit
Notes text on the screen.
Click on one of these options:

·
·

'Hide Notes' to not show the Notes at all; the element rows close up

·

'Full Notes Inline' to show the complete Notes text for each element underneath
the element name; in this mode you can create, edit and delete Notes text in the
Specification Manager and perform the same operations as are available in the
Notes window context menu

·

'Full Notes in Column' to show the complete Notes text for each element in a
new column next to the element names; you have the same freedom to edit the
text as for 'Full Notes Inline'

'Notes Preview' to show the first line of Notes text for each element; in this
mode, you cannot edit the Notes text in the Specification Manager, only in the
Notes window

Display element names in
bold

Click on the 'Bold Requirement Name' option. All element names, including the
names of child elements, are displayed in bold.

Enable the use of
Expansion boxes on parent
elements

If an element has child elements, you can configure the Specification Manager to
either:

Highlight the current
element details

(c) Sparx Systems 2015 - 2016

·

Hide the child elements but provide an expansion box that you can click on to
open and collapse the element hierarchy (select the 'Allow Collapsible Regions'
option), or

·

Automatically display the child elements indented underneath the parent
element (deselect the 'Allow Collapsible Regions' option)

When you click on an element name or property, the Specification Manager
defaults to indicating the selection with side bars and/or underlines. You can, if you
prefer, also highlight the entire row of data for the element, by toggling the
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'Highlight Selected Row' option.
Change Font Sizes of
display

Across the Specification Manager view, the various display components such as
parent element names, child element names, Notes/property values and column
headings each have their own font size. You can select to increase or decrease the
font sizes as a set across the display, relative to the current sizes.
Select the 'Font Size' option and either:

·
·
·

(c) Sparx Systems 2015 - 2016

'Small'
'Medium' or
'Large'
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Model Options
The Specification Manager helps you to develop the elements in a Package from 'the ground up'. You use standard, or
reference, data in doing this, such as the names of team members who can create and edit model data, or the automatic
naming system to apply in creating your elements. Because you can start from an early stage in the model's
development, some of the reference data you want to use might not exist. The Specification Manager, therefore, also
makes it easier to call up the facilities for defining the types of data you need.

Access
Ribbon

Publish > Documentation > Glossary
Configure > Reference Data > Project Types > General Types > Requirement
Configure > Reference Data > Project Types > People > Project Authors
Configure > Reference Data > Settings > Auto Names and Counters
Configure > Reference Data > UML Types > Tagged Value Types

Configure data for development
Data Type/Option

Description

Project Glossary

It is possible to create a Glossary of terms and definitions used throughout the
Project, and to automatically link to the definition of a term where it occurs in the
model text.

Requirement Types

Requirement elements can be of one of several system-defined types, as shown in
the 'Stereotype' column of the Specification Manager, if you have selected to work
on Requirements.
If these types are not sufficient for your needs, you can define alternatives on the
'Requirement' tab of the 'General Types' dialog.

Project Authors

A Project Author is a system user who has responsibility for creating modeling
structures and data in a project. Initially there are no Project Authors defined on
the system, and you might need to identify the users who are in your development
team.
Click on this menu option to display the 'People' dialog, on which you define the
Project Authors.

Auto Names and Counters

When you start to create elements in your model, the system automatically gives
them a name based on the element type and the number of elements of that type that
already exist. For example, if you create a series of Requirement elements the
default names are 'Requirement1', 'Requirement2', 'Requirement3' and so on. You
then edit these default names.
Alternatively, you can define your own default naming and numbering system for
specific element types, for either the element name, the element alias, or both.
Display the 'Auto Name Counters' dialog, with which you can define your naming
and numbering system.

(c) Sparx Systems 2015 - 2016
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You can add Extended Properties (Tagged Values) to your elements in the
Specification Manager, using the 'Extended Properties' option on the element
content menu.
However, you might want to use a type of Tagged Value that is not currently
available; in this case, you can create that type using the 'Tagged Value Types' tab
of the 'UML Types' dialog.
Click on this menu option to display the 'UML Types' dialog.

Notes
·

In the Corporate and extended editions of Enterprise Architect, a User Security system can be applied that restricts
or enables access to a range of operations and functions; if you cannot access a function in the Specification
Manager, check with your System Administrator or Security Administrator to see if you have access permissions to
work with that function

(c) Sparx Systems 2015 - 2016
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Package Options
As you define the elements in your specification you can make them easier to reference by giving them more appropriate
element names and/or numbers, either as the elements are created or retrospectively when a naming and numbering
system has been finalized. You can also make the elements easier to locate and view by enabling level-numbering and
indenting, helping you to organize and review the sequence and arrangement of the elements in the Specification
Package. If you have been exploring other areas of the Project Browser, you can return focus to the Specification
Package in the Project Browser.

Access
Ribbon

Specification-Specifiy > Specification > Package > Find in Project Browser
Specification-Specifiy > Specification > Apply Auto Naming
Specification-Specifiy > Specification > Level Numbering > Enable
Specification-Specifiy > Specification > Level Numbering > Indent Description

Configure Package options
Option

Description

Locate Current in Project
Browser

Highlight the name of the Specification Package in the Project Browser.

Apply Auto Naming to
Elements

If you had to create elements before setting up an auto-naming and/or
auto-numbering system, you can select this option to apply the system to the
existing elements retrospectively.
If you set up an auto-naming and/or auto-numbering system before creating your
elements, that system is automatically applied as you create the elements.

Level Numbering - Enable

Click on this option to apply level numbering to the elements in the Specification
Package and indent each successive level, both in the Specification Manager and
in the Project Browser. Nested elements are numbered hierarchically; that is:
1 Name
2 Name
2.1 Name
2.1.1 Name
2.1.2 Name
3
The option in the Specification Manager is the same as the option in the Project
Browser Package context menu; turning the option on or off in one window also
turns the option on or off in the other.

Level Numbering - Indent
Description

(c) Sparx Systems 2015 - 2016

If you have enabled level numbering, this option is available to indent the element
description under each element name, to align with the element name. If the option
is not selected, the text is aligned with the left-hand edge of the level number. For
example:
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Option ON:
1 Name
Description
2 Name
Description
2.1 Name
Description
2.1.1 Name
Description
2.1.2 Name
Description
3 Name
Description
Option OFF:
1 Name
Description
2 Name
Description
2.1 Name
Description
2.1.1 Name
Description
2.1.2 Name
Description
3 Name
Description

Notes
·

In the Corporate and extended editions of Enterprise Architect, a User Security system can be applied that restricts
or enables access to a range of operations and functions; if you cannot access a function in the Specification
Manager, check with your System Administrator or Security Administrator to see if you have access permissions to
work with that function
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