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Génération de documents

Le moteur de documentation vous permet de créer une documentation professionnelle de haute qualité qui peut
complètement remplacer la nécessité de créer des documents artisanaux. Enterprise Architect fournit un ensemble
complet de gabarits qui seront utiles dans de nombreuses situations. Ces gabarits peuvent être ajustés ou de nouveaux
créés pour personnaliser complètement la documentation selon les exigences de reporting d'un projet ou d'une
méthodologie particulière, y compris les pages de couverture et les styles. La documentation standard facilité vous aide à
créer des rapports sur n'importe quel Paquetage ou élément du référentiel, et avec la facilité de documents virtuels, vous
pouvez sélectionner sélectivement le contenu de n'importe quelle section du modèle et du style et l'ordonner selon vos
besoins. Il existe également un ensemble de rapports intégrés avec du contenu et des styles préconfigurés qui vous
donnent des informations immédiates sur des groupes spécifiques d'éléments ou de propriétés du modèle. Vous avez les
options de :

Générer l'un des nombreux rapports fournis par le système sur des aspects spécifiques de votre modèle·
Génération d'un rapport à partir d'un gabarit fourni par le système, avec contrôle de la sortie du rapport via des·
feuilles de style, des pages de couverture et tableaux de contenus complémentaires, des filtres et un large éventail
d'options dialogue

Création de vos propres gabarits , feuilles de style et pages de compléments à partir desquels générer des rapports,·
en appliquant un degré de contrôle encore plus grand sur le contenu et le format de la sortie.

Les formats de document sont communs à de nombreux traitements de texte. Vous pouvez donc également travailler sur
les rapports dans d'autres outils de traitement de texte pour, par exemple, intégrer le rapport dans un document plus
volumineux créé en externe.

Solutions documentaires

Fonctionnalité Détail

Génération de documents Le générateur de documents comprend un éditeur de documents WYSIWYG
multifonctions que vous pouvez utiliser pour :

Importer et exporter gabarits de documents à l'aide de XML·
Personnaliser des copies des gabarits de base fournis par le système·
Créez gabarits entièrement nouveaux de votre propre conception·
Test gabarits au fur et à mesure que vous les concevez, en générant des·
rapports ad hoc dans le concepteur

Créez et personnalisez des feuilles de style, Tableaux des matières et des·
feuilles de couverture indépendantes à appliquer à n'importe lequel de vos
rapports.

Il fonctionnalités également un générateur de documentation qui :

Fournit un large éventail d'options simples pour filtrer et modifier la sortie du·
rapport

Génère des documents détaillés et complets basés sur les gabarits·
Dispose d'une visionneuse intégrée pour lire les documents générés·
directement dans Enterprise Architect

Un didacticiel sur l'utilisation du générateur de documents et la création de rapports
de documents est disponible sur le site Web Sparx Systems .

Documents virtuels Si vous souhaitez créer des documents très ciblés et spécifiques, avec une plus
grande complexité et présentant différentes vues de vos données de modèle, vous
pouvez le faire à l'aide de documents virtuels. Pour ceux-ci, vous configurez un
élément Rapport Paquetage et/ou des éléments Modèle Document, et liez
Paquetages ou des recherches de modèles (pour les éléments) dans le document
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dans l'ordre ou la combinaison la plus appropriée à vos besoins.

Vous pouvez sélectionner Paquetages dans différentes zones du modèle, les
organiser dans n'importe quel ordre et modifier ou supprimer les Paquetages ; le
document virtuel intègre automatiquement les modifications à chaque fois que vous
le générez.

Documents maîtres Word Comme alternative aux documents virtuels, vous pouvez lier un certain nombre de
rapports de documents en un seul document maître MS Word TM . Ceci est tout à fait
possible avec le générateur de rapports actuel, mais est plus utile avec le générateur
Rapport Legacy RTF d'origine.

En règle générale, vous créez un document maître Word, puis dans Enterprise
Architect vous générez des rapports que vous reliez aux sous-sections du document
maître et que vous actualisez selon les besoins pendant le développement du projet.
De cette manière, le document de projet devient un produit de travail facile à gérer
et riche en fonctionnalités.

Vous pouvez également remplir un document Word à partir de sections spécifiques
de rapports, en fonction de signets. Par exemple, un document Word peut comporter
une section pour une petite partie de votre modèle de composant ; à l'aide de
signets, vous pouvez générer un modèle de composant complet, puis créer un lien
vers une seule section du rapport.

De cette façon, vous pouvez gérer un document Word complexe à partir de parties
de rapports Enterprise Architect ; le générateur de documents effectue une passe
pour un gabarit , mais en utilisant un document maître Word et des signets
Enterprise Architect , vous pouvez incorporer du matériel provenant de plusieurs
documents avec différents formats basés sur différents gabarits .

En ajoutant tableaux de matières, tableaux figures, des sections et des en-têtes et
pieds de page, vous pouvez gérer un document complexe avec une relative facilité ;
mettez simplement à jour les rapports Enterprise Architect , puis actualisez les liens
dans Word.

Notes

Dans les éditions Corporate , Unified et Ultimate d' Enterprise Architect , si la sécurité est activée, vous devez·
disposer de l'autorisation « Générer des documents » pour générer des rapports de documents.

Vous pouvez ouvrir plusieurs rapports en même temps, sous forme d'onglets séparés dans la zone de vue centrale de·
la zone de travail Enterprise Architect ; vous pouvez également fermer les rapports individuellement ou tous
ensemble, laissant les vues d'autres types (comme diagrammes ou les éditeurs de code) toujours ouvertes
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Édition de documents et Gabarits

Dans Enterprise Architect vous pouvez créer divers documents à partir gabarits et créer gabarits personnalisés pour vous
aider à adapter les documents aux besoins et aux normes de votre organisation. Vous pouvez créer des documents liés,
Gabarits de documents liés et Gabarits de documents ( Rapport ), entre autres. Dans chaque cas, la sélection de créer ou
de modifier le document ouvre le ruban Document-Edit, qui offre un large éventail de fonctionnalités d'édition et de
formatage facilités que vous pouvez utiliser pour développer votre documentation. Cette section explique comment
effectuer diverses tâches d'édition à l'aide du ruban.

Chaque type de document peut également avoir son propre menu contextuel d'options supplémentaires, et la fenêtre
d'édition peut également avoir une barre d'outils d'options. Ces facilités sont décrites dans les rubriques spécifiques au
type de document.

Accéder

Ruban Créer ou modifier un document ou un fichier gabarit ; le ruban Document -
Modifier s'affiche automatiquement

Description des options

Les descriptions des options du ruban Document - Modifier sont regroupées en fonction des actions que vous effectuez.

Actions

Création et importation de documents

Configuration de l'affichage de la page de l'éditeur et des outils de formatage affichés

Parcourir, rechercher et sélectionner du texte

Formatage des caractères et des chaînes de texte

Formatage des paragraphes et des blocs de texte

Insertion de points de tabulation

Insertion de sections, de colonnes et de sauts de page, et repagination

Incorporation de feuilles de style, de textes spéciaux et Tableaux des matières

Gestion des styles de base dans le fichier gabarit de style Normal.rtf

Insertion et modification des en-têtes et pieds de page de page, ainsi que des notes de bas de page et de fin

Insérer tableaux

Insérer des hyperliens

Insertion d'images, d'objets OLE, de cadres et d'objets de dessin
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Configuration de l'imprimante et impression des documents

Vérification de l'orthographe et de l'utilisation des mots

Suivi, acceptation et rejet des modifications apportées au texte

Protéger le texte du document contre les modifications accidentelles

Créer et référencer les définitions des termes du glossaire dans le Glossaire du Projet (en utilisant l'option de menu
'Créer | Définition du glossaire')

Notes

Tout au long de l’édition de votre document :·
- Pour annuler une ou plusieurs modifications immédiatement précédentes, appuyez sur Ctrl+Z ou sélectionnez le
menu contextuel ' Annuler '
option; vous pouvez toujours annuler une modification même après l'avoir enregistrée
- Pour refaire une ou plusieurs modifications annulées immédiatement précédentes, appuyez sur Ctrl+Y ou
sélectionnez l'option "Rétablir".
option du menu contextuel
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Contrôle des fichiers

Le panneau « Fichier » du ruban « Modification du document » fournit un certain nombre d'options pour modifier et
enregistrer le contenu d'un fichier de rapport de document en tant que fichier complet, ainsi que pour définir les options
disposition des pages, telles que les marges, et pour imprimer le document.

Accéder

Ruban Document-Édition > Fichier > Fichier > [options]

Options de contrôle de fichiers

À Action

Importer un fichier Sélectionnez l'option « Document-Edit > Fichier > Fichier > Importer un fichier ».
Cela importe le contenu d'un document existant dans le fichier actuel. Le type de
fichier dans le dialogue fichier est par défaut .rtf, mais vous pouvez importer des
fichiers dans un certain nombre d'autres formats. Cliquez sur la flèche déroulante et
sélectionnez le type de fichier requis.

L'option 'Importer un fichier' est utile lors de la création de documents à partir de
documents existants externes à Enterprise Architect , tels que vos propres gabarits
de normes d'entreprise et, en conjonction avec l'option 'Nouveau', pour mettre à jour
le document à partir du fichier externe.

Exporter un fichier de
document

Sélectionnez l'option « Document-Edit > Fichier > Fichier > Enregistrer sous
(Exporter vers un fichier) ». Cela enregistre votre document dans un fichier de
document externe.

L'option 'Exporter' est utile pour enregistrer un gabarit ou un document spécifique à
importer dans un autre projet.

Effacer un fichier pour
refonte

Sélectionnez l'option 'Document-Edit > Fichier > Fichier > Nouveau ( Effacer
Document)'. Cela efface le contenu existant du document.

Si vous avez apporté des modifications non enregistrées au fichier, l'éditeur vous
prompts à les enregistrer. Si vous souhaitez protéger ces modifications, cliquez sur
le bouton Oui pour afficher un écran de navigateur et sélectionnez un chemin de
fichier et un nom de fichier dans lesquels enregistrer les modifications.

Il s'agit d'une méthode permettant d'effacer un document existant en vue d'une
refonte. Comme vous ne modifiez pas le nom, toutes les références à celui-ci
renvoient simplement au contenu modifié.

Annuler les modifications
vers la version précédente

Sélectionnez l'option 'Document-Edit > File > File > Reload from Référentiel ' pour
restaurer le contenu du fichier vers la version précédemment enregistrée.

Sauvegarder les
modifications

Sélectionnez l'icône « Document-Edit > File > Save » pour enregistrer le contenu
du fichier dans le fichier actuel.

Enregistrer Gabarit Applicable au Document Gabarit Designer et à l'éditeur gabarit Linked Document.
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La combinaison de touches Ctrl+Shift+S appelle la commande 'Enregistrer sous'
pour enregistrer le contenu d'un gabarit sous un nouveau nom, que vous êtes invité
à saisir. Cette commande n'est pas disponible lors de l'édition d'un document - voir '
Exporter un fichier de document '. plutôt.

Fermez le fichier et
l'éditeur

Cliquez sur la croix à droite de l'onglet du document ou dans le coin supérieur droit
de la fenêtre du document.

Options d'impression

Lorsque vous modifiez un document ou gabarit , vous pouvez gérer les travaux d'impression dans l'éditeur de documents.
Vous pouvez sélectionner parmi les options permettant de définir la disposition de la page, le texte à imprimer et le
nombre de copies, ainsi que de vérifier l'apparence de l'impression avant de soumettre réellement le travail d'impression.

À Action

Définir les marges de la
page pour afficher et
imprimer le document

Sélectionnez l'option 'Document-Edit > File > File > Page Disposition '.

La dialogue « Paramètres de page » s'affiche, dans laquelle vous pouvez définir les
marges de page gauche, droite, supérieure et inférieure en pouces.

Les marges « Haut » et « Bas » définissent l'espace réservé au texte d'en-tête et de
pied de page.

Dans les champs « Distance de l'en-tête par rapport au haut de la page » et
« Distance du pied de page par rapport au bas de la page », saisissez la séparation
entre le texte de l'en-tête et du pied de page du bord du papier.

Définir les paramètres de l'
exécuter d'impression

Sélectionnez l'option « Document-Edit > Fichier > Fichier > Configuration de
l'imprimante » ou appuyez sur Ctrl+Maj+P.

La boîte dialogue « Page de configuration » s'affiche pour l'imprimante par défaut,
que vous auriez sélectionnée dans le panneau « Contrôle » Windows .

Vous pouvez simplement confirmer ou resélectionner les paramètres principaux tels
que la taille de la page, la source de papier et l'orientation de la page, ou cliquer sur
le bouton Propriétés pour définir des paramètres plus avancés tels que l'utilisation
d'un filigrane, l'impression recto verso et la résolution d'impression.

Imprimez votre document Sélectionnez l'option 'Document-Edit > File > File > Aperçu Impression ' ou
appuyez sur Ctrl+P.

La dialogue « Imprimer » s'affiche, dans laquelle vous pouvez sélectionner les
pages à imprimer et le nombre de copies, et lancer la tâche d'impression.

Vous pouvez également choisir d'imprimer uniquement une partie sélectionnée du
fichier. Pour ce faire, mettez en surbrillance le texte requis avant de sélectionner
l'option « Imprimer ». Vous pouvez imprimer un bloc en surbrillance de :

Lignes, ou·
Personnages·

Aperçu du document avant
impression

Sélectionnez l'option 'Document-Edit > File > File > Aperçu Impression ' pour
afficher le document tel qu'il apparaîtrait une fois imprimé.

L'éditeur affiche soit une page, soit deux pages - basculez l'affichage en cliquant sur
le bouton Une page ou Deux pages. Faites défiler vers d'autres pages à l'aide de la
barre de défilement.

Par défaut, le rectangle d'aperçu est dimensionné pour s'adapter à la fenêtre
actuelle ; vous pouvez utiliser le champ « Ajusté » pour agrandir ou réduire la taille
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des pages affichées selon vos besoins.

Cliquez sur le bouton Imprimer pour afficher et utiliser la dialogue 'Imprimer'.

Pour revenir en mode édition, cliquez à nouveau sur le bouton Modifier, ou à
nouveau sur l'option de menu 'Document-Edition > Fichier > Fichier > Aperçu
Impression '.
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Options d'affichage de l'éditeur

Dans l'éditeur de documents, pour vous aider à éditer le contenu du document, vous pouvez configurer l'affichage de la
page et les outils de formatage visibles, en utilisant les options du menu ' Vue ' dans le panneau 'Fichier' du ruban
'Document-Edit'.

Accéder

Ruban Document-Édition > Fichier > Vue > [options]

Outils et options d'édition

Option de menu Action

Mode Disposition des
pages

Sélectionnez l'option 'Document-Edit > File > Vue > Page Disposition Mode'.
Bascule l'affichage du texte entre disposition de la page et disposition de la fenêtre
complète.

Mode sans bordure Sélectionnez l'option 'Document-Edit > File > Vue > Borderless Mode'. Bascule
l'affichage des bordures de page, permettant au document d'occuper toute la zone
d'affichage.

Règle horizontale Sélectionnez l'option 'Document-Edit > File > Vue > Horizontal Ruler'. Affiche ou
masque la règle en haut de la page.

La règle affiche les taquets de tabulation et les marques d'indentation de
paragraphe ; vous pouvez également l'utiliser pour créer ou supprimer des taquets
de tabulation.

Règle verticale Sélectionnez l'option 'Document-Edit > File > Vue > Vertical Ruler'. Affiche ou
masque la règle contre le bord gauche de la page.

La règle indique la profondeur des marges supérieure et inférieure de la page.

Ruban d'état Sélectionnez l'option 'Document-Edit > File > Vue > Status Ribbon'. Affiche ou
masque le ruban d'état en bas du panneau d'édition.

Le ruban d'état affiche le numéro de page actuel, le numéro de ligne et le numéro de
colonne ; il indique également le mode d'insertion/refrappe actuel (à l'extrémité
gauche du ruban).

Texte masqué Sélectionnez l'option 'Document-Edit > File > Vue > Status Ribbon'. Affiche ou
masque le texte « caché ».

Le texte formaté avec l'option « Masqué » est affiché avec un soulignement en
pointillé ; lorsque l'option « Texte caché » est désactivée, le texte masqué n'est pas
visible et le texte normal se réduit à un seul caractère ou à un interligne.

Noms des champs Sélectionnez l'option 'Document-Edit > File > Vue > Field Names'.

Applicable à toutes les éditions de documents :

Si vous avez inséré des champs de données et des valeurs, l'option « Noms de
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champs » bascule entre l'affichage des noms de champs dans le texte et l'affichage
des valeurs des champs.

Applicable au concepteur de documents Gabarit :

Au fur et à mesure que vous développez votre gabarit de document personnalisé,
vous cliquez-droit sur les sections pour insérer des marqueurs de champ et
sélectionnez l'option « Insérer des champs ». L'option « Noms de champs » rend
l'option « Insérer des champs » disponible.

Curseur de lien hypertexte Sélectionnez l'option 'Document-Edit > File > Vue > Hyperlink Cursor'.

Applicable au Document Gabarit Designer et à l'éditeur Linked Document Gabarit :

Bascule l'icône du curseur lorsque vous passez la souris sur un lien hypertexte,
entre votre image par défaut (généralement une ligne ou une flèche) et une « main
pointée ».

En-tête/pied de page Sélectionnez l'option 'Document-Edit > File > Vue > Page Header/Footer'. Affiche
ou masque le texte des en-têtes et pieds de page.

Pour modifier le texte de l'en-tête ou du pied de page, sélectionnez l'option «
Document-Modifier > Modifier > Modifier > En-tête/pied de page ».

Zoom Sélectionnez l'option 'Document-Edit > File > Zoom Fixe '. Un menu court
s'affiche, à partir duquel vous pouvez sélectionner parmi une plage (10 % à 200 %)
de pourcentages de taille normale permettant de réduire ou d'agrandir l'affichage du
contenu du document. Le menu dispose également d'une option « Personnalisé »
que vous pouvez sélectionner pour afficher la dialogue « Paramètres de zoom », sur
laquelle vous définissez le pourcentage dont vous avez besoin, entre 10 % et 500 %.
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Styles, texte spécial et Tableau des matières

À l’aide de l’éditeur de documents, vous pouvez définir des styles basés sur les caractères et des styles basés sur les
paragraphes.

Un style de caractère constitue un ensemble d'attributs de formatage de caractères et est appliqué à une string de·
caractères

Un style de paragraphe constitue à la fois un ensemble d'attributs de formatage de caractères et un ensemble·
d'attributs de formatage de paragraphe, et est appliqué à un ou plusieurs paragraphes.

Vous pouvez également inclure du texte spécial et structuré dans le document, tel que le numéro de page, la date et
l'heure, tableau des matières et les champs de saisie de texte.

Chaque gabarit ou document personnalisé que vous créez est automatiquement basé sur le fichier gabarit Normal.rtf.
Cela fournit des styles par défaut, une numérotation et d'autres formats de base, que vous pouvez modifier facilités à
l'aide de l'éditeur de documents et les enregistrer en tant que document spécifique, gabarit ou feuille de style de rapport
de document.

Accéder

Ruban Sélectionnez les options dans la barre de ruban « Modification du document ».

Modification des styles

À Action

Créer et modifier des styles Sélectionnez l'option 'Document-Edit > Edit > Edit > Edit Style'. La dialogue «
Modifier la feuille de style » s'affiche.

Sélectionnez le bouton radio approprié pour définir un style de paragraphe ou un
style de caractère.

Si vous souhaitez mettre à jour un style existant, sélectionnez ce style dans la zone
de liste. Si vous souhaitez créer un nouveau style, cochez la case « Créer un
nouveau style » et saisissez un nom dans le champ « Nom du style ». Les noms
courts sont préférables, mais vous pouvez saisir des noms longs si nécessaire.

Pour commencer à définir les propriétés du style, cliquez sur le bouton OK .

Vous pouvez utiliser les sélections de la règle, de la barre d'outils ou du menu
contextuel pour modifier les propriétés du style ; pour un élément de feuille de style
existant, ceux-ci reflètent également les propriétés actuellement sélectionnées.

Après avoir défini le style requis, vous le définissez soit en sélectionnant à nouveau
l'option de menu "Document-Edit > Edit > Edit > Edit Style", soit en cliquant
n'importe où dans le document :

Si vous avez modifié un élément de feuille de style existant, le document·
reflète automatiquement le style mis à jour

Si vous avez créé un nouvel élément de feuille de style, vous pouvez appliquer·
le style au texte en surbrillance en sélectionnant les options du ruban «
Document-Edit > Police > Police > Style » ou « Document-Edit > Paragraph >
Paragraph > Style ».

Mettre à jour les styles Cliquez-droit sur le document et sélectionnez 'Mettre à jour les styles >
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standards utilisés [sélectionner la feuille de style à mettre à jour]'

Réimportez les styles standards depuis Normal.rtf, dans le document actuel, ou·
Appliquer l'une des feuilles de style standard fournies par le système au·
document

Un sous-menu s'affiche dans lequel vous sélectionnez la source de style appropriée.

Ceci est utile pour maintenir la cohérence des styles dans tous vos documents, y
compris des éléments tels que les formats de numérotation.

Modifier le style du lien
hypertexte

Cette option fonctionne spécifiquement sur le style des hyperliens que vous
souhaitez créer.

Sélectionnez l'option 'Document-Edit > Police > Police > Hyperlink', puis
sélectionnez la police, la taille de la police et l'emphase (gras, italique) que vous
souhaitez appliquer. Vous ne pouvez pas supprimer le soulignement du lien
hypertexte ni modifier la couleur du bleu.

Sélectionnez à nouveau l'option « Document-Edit > Police > Police > Hyperlink »
pour définir le style.

Lorsque vous créez un lien hypertexte à partir de ce moment, le texte du lien sera
dans le style que vous avez défini. Les liens créés avant la modification du style
restent dans le style précédent.

Appliquer des styles de
caractères

Mettez en surbrillance le texte à styliser et sélectionnez l'option « Document-Edit >
Police > Police > Style » ; la dialogue « Sélectionner un style » s'affiche, à partir de
laquelle vous sélectionnez le style de caractère à appliquer.

Vous pouvez également sélectionner un style de caractère dans la liste déroulante
du panneau « Police » du ruban « Modification de document ».

Appliquer des styles de
paragraphe

Mettez en surbrillance le texte à styliser et sélectionnez l'option
« Document-Edit > Paragraphe > Paragraphe > Style » ; la dialogue « Sélectionner
un style » s'affiche, à partir de laquelle vous sélectionnez le style de paragraphe à
appliquer.

Vous pouvez également sélectionner un style de paragraphe dans la liste déroulante
du panneau « Police » du ruban « Modification du document ».

Effacer les listes inutilisées
du gabarit ou du document

Sélectionnez l'option « Document-Edit > Fichier > Gérer > Supprimer les listes
inutilisées ».

Le système vous prompts de confirmer la suppression des listes lorsque le fichier
est enregistré. Cliquez sur le bouton Oui.

Lorsque vous disposez de formats de liste, tels que des listes à puces ou des listes
numérotées, dans le fichier, et que vous les avez inversés ou que vous ne les avez
pas utilisés, les instructions de formatage permettant d'appliquer ces listes au texte
restent dans le fichier. Vous pouvez le voir lorsque vous configurez la liste, puis
activez et désactivez les puces ou la numérotation.

Si vous sélectionnez l'option « Supprimer les listes inutilisées », lorsque vous
enregistrez le fichier, les instructions de format inutilisées sont supprimées du
fichier, réduisant ainsi le nombre de formats de liste conservés dans le fichier et
réduisant la taille du fichier.

Insérer des champs de date
et d'heure

À l'endroit du texte où insérer le champ de date et/ou d'heure actuelle, sélectionnez
l'option « Document-Edit > Edit > Insert > Date and Time ».

La dialogue « Insérer la date/l'heure actuelle » s'affiche, à partir de laquelle vous
pouvez sélectionner le format de date et d'heure requis. Vous pouvez insérer les
champs de date ou d'heure séparément ou sous forme de champ combiné.

La date et l'heure sont automatiquement mises à jour chaque fois que le texte de la
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page est actualisé (c'est-à-dire cliqué dessus).

Insérer un tableau des
matières

Modifiez les styles de niveau « Tableau des matières » (TOC 1 à TOC 9) selon vos
besoins, en utilisant l'option « Document-Edit > Edit > Edit > Edit Style ». Ajoutez
au moins un style « Titre n » au document.

Déplacez le curseur jusqu'au point où insérer le Tableau des matières et
sélectionnez l'option « Document-Edit > Edit > Insert > Tableau of Contents ». Une
petite dialogue s'affiche dans laquelle vous spécifiez les niveaux de Tableau des
matières les plus élevés et les plus bas à appliquer dans le tableau de ce document ;
lorsque vous avez spécifié les niveaux, cliquez sur le bouton OK . S'il existe des
titres correspondants dans la plage spécifiée, le Tableau des matières s'affiche ;
sinon, la ligne reste vide.

Pour créer un titre du Tableau des matières qui s'affiche dans le document généré,
tapez le texte approprié au moins une ligne au-dessus de la liste insérée et
définissez le style si nécessaire - utilisez un style de titre pour inclure le titre
lui-même dans le Tableau des matières, sinon utilisez un style sans titre.

Le Tableau des matières est automatiquement généré et mis à jour à chaque
génération ou repagination.

Insérez vos propres champs
de données

Déplacez le curseur jusqu'au point auquel insérer le champ de données et
sélectionnez l'option de menu "Document-Edit > Edit > Insert > Data Field".

La dialogue « Paramètres du champ de données » s'affiche, dans laquelle vous
saisissez le nom du champ et la valeur des données. Où que vous insérez le champ
de données, les valeurs sont automatiquement mises à jour avec la valeur de
données la plus récente que vous saisissez.

Insérez votre propre champ
de saisie de texte

Vous insérez des champs de saisie de texte afin que toute personne utilisant le
document puisse saisir son propre texte en réponse soit à une phrase d'introduction,
soit au nom du champ lui-même.

Déplacez le curseur jusqu'au point où insérer le champ de saisie de texte et saisissez
le texte d'introduction que vous souhaitez utiliser. Sélectionnez ensuite l'option
'Document-Edit > Edit > Insert > Text Input Field'.

La dialogue « Paramètres du champ de saisie » s'affiche, dans laquelle vous
saisissez :

Le nom du champ·
La valeur initiale à afficher par défaut·
La longueur maximale du champ·
La police de texte dans laquelle afficher le texte·

Vous pouvez également préciser si le champ comporte ou non une bordure.

Par exemple :

Si vous insérez un champ de saisie de texte dans un gabarit , tout document généré
à partir du gabarit affiche l'entrée saisie sous forme de texte normal et non encadré.

Insérer une case à cocher
sélectionnable

Vous insérez des cases à cocher dans un document afin que les utilisateurs du
document puissent marquer l'élément représenté par la case. La case à cocher peut
être cochée et décochée dans un document, un gabarit et un document généré à
partir d'un gabarit .

Déplacez le curseur jusqu'au point où insérer la case à cocher et sélectionnez
l'option "Document-Edit > Edit > Insert > Checkbox Field".

La dialogue « Paramètres du champ de case à cocher » s'affiche, dans laquelle vous
saisissez :

Le nom du champ (qui ne s'affiche pas dans le texte)·
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Si la case à cocher est sélectionnée par défaut·
La taille de la case à cocher·

Cliquez sur le bouton OK .

Insérer un champ de
sélection (liste déroulante)

Vous insérez des champs de sélection dans un document afin que les utilisateurs du
document puissent sélectionner l'un des éléments présentés dans une liste
déroulante.

Déplacez le curseur jusqu'au point où insérer la case à cocher et sélectionnez
l'option « Document-Edit > Edit > Insert > Selection Field ».

La dialogue « Paramètres du champ de sélection » s'affiche, dans laquelle vous
saisissez :

Le nom du champ·
Les options à présenter dans la liste déroulante (séparées par le caractère |)·
La valeur de cette liste à afficher par défaut·

Cliquez sur le bouton OK .

Insérer un espace insécable Déplacez le curseur jusqu'au point où insérer l'espace insécable et sélectionnez
l'option 'Insérer | Option de menu Espace insécable.

Insérer un tiret insécable Déplacez le curseur jusqu'au point où insérer le tiret insécable et sélectionnez
l'option « Insérer | Option de menu Dash incassable.

Insérer un trait d'union
facultatif

Déplacez le curseur jusqu'au point où insérer le trait d'union et sélectionnez l'option
'Insérer | Option de menu Trait d'union facultative.

Insérer une constante de
projet

(Pour les gabarits Rapport de document.)

Vous pouvez créer des constantes de projet pour insérer une string de texte
spécifique partout où vous placez l'indicateur pour cette string . Vous pouvez donc
concevoir un rapport contenant de nombreuses instances de cette string , mais créer
et modifier la valeur réelle en un seul endroit - sur l'onglet 'Constantes du projet' de
la dialogue ' Générer Rapport '.

Cliquez-droit à l'endroit où vous souhaitez insérer la constante (drapeau), et
sélectionnez l'option 'Constantes du projet | <nom du drapeau>'. La constante
s'affiche à cet endroit dans le gabarit , et lorsque le rapport est généré le drapeau est
remplacé par sa valeur définie.

Vous pouvez insérer une constante de projet n'importe où dans le gabarit - dans le
corps du texte, les en-têtes de section, les en-têtes, les pieds de page, les notes de
fin ou de bas de page. Les constantes du projet sont disponibles pour n'importe quel
gabarit du modèle.

Définir la numérotation des
niveaux dans le document
généré

(Utilisé dans l'éditeur de documents Gabarit .)

Sélectionnez l'option "Document-Edit > Edit > Edit > Lists and Overrides".

Configurez la liste de numérotation et les remplacements de liste.

Appliquez la liste de numérotation aux titres définis pour Paquetages et les
éléments, en utilisant la numérotation des paragraphes.

Utiliser des caractères à
deux octets

Sélectionnez l'option "Document-Edit > Edit > Edit > Inline Ime".

Les caractères à deux octets sont, en général, des caractères complexes utilisés dans
des langues telles que le japonais, le chinois et le cyrillique.

Avec cette option de menu, vous pouvez utiliser à la fois des caractères à un octet et
des caractères à deux octets dans votre texte, sans avoir à passer à une application
IME (Input Method Editor) externe.
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Gérer le comptage de pages

Lorsque vous configurez la structure du document, en particulier si vous divisez le document en sections, vous pouvez
insérer le nombre de pages, insérer et réinitialiser les numéros de page, et repaginer le document pour mettre à jour le
numéro de page, le nombre de pages et Tableau des matières.

Accéder

Ruban Document-Edition > Edition > Insérer > Numéro de page

Document-Édition > Modifier > Insérer > Nombre de pages

Document-Modifier > Modifier > Modifier > Repaginer

Insérez le numéro de page

Positionnez le curseur à l'endroit où afficher le numéro de page et sélectionnez l'option « Document-Edit > Edit > Insert
> Page Number ».

Le numéro de page est affiché en gris.

Insérer le nombre de pages

Placez le curseur à l'endroit où afficher le nombre total de pages dans le document et sélectionnez l'option «
Document-Edit > Edit > Insert > Page Count ». Le nombre de pages est affiché en gris.

Repaginer le document

Sélectionnez l'option 'Document-Edit > Edit > Edit > Repaginate'.

Les champs « Numéro de page » et « Nombre de pages » ainsi que le Tableau des matières sont tous mis à jour.
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Le Gabarit de style Normal.rtf

Chaque gabarit ou document personnalisé que vous créez est automatiquement basé sur le fichier 'Normal.rtf gabarit '. Il
s'agit d'un fichier externe qui fournit des styles, une numérotation et d'autres formats de base par défaut, tels que la
numérotation de liste par défaut, MasterList. Vous pouvez modifier le fichier Normal.rtf pour appliquer vos propres
styles par défaut aux documents et gabarits que vous créez. Vous avez également les options de :

Modification des styles sélectionnés dans un gabarit , afin que les rapports ou documents créés à partir de ce gabarit·
aient toujours ces différents styles

Utiliser les feuilles de style standard ou créer des feuilles de style personnalisées, à appliquer éventuellement à tout·
rapport de document que vous générez indépendamment du gabarit que vous utilisez

Le gabarit Normal.rtf est stocké dans %APPDATA%\ Sparx Systems \EA\RTF Gabarits .

Modifier Normal.rtf

Étape Action

1 Ouvrez le Document Gabarit Designer et créez un nouveau gabarit appelé, par exemple, Normal.

2 Sélectionnez l'option de menu 'Document-Edit > File > File > Import File' pour importer le fichier
Normal.rtf dans le gabarit Normal.

3 Modifiez les définitions de style gabarit normal comme vous le souhaitez et supprimez tout texte avant
d'enregistrer le gabarit .

4 Exportez le gabarit modifié ("Document-Edit > File > File > Save As (Export to File))" dans le fichier
Normal.rtf du dossier RTF Gabarits . Les styles modifiés seront appliqués à tous les documents et gabarits
que vous créez à partir de maintenant .

Notes

Vous ne devez pas modifier le style SSbookmark ; cela définit les styles de section et doit être conservé·
Une fonctionnalité connexe dans l'éditeur de documents est l'option de menu contextuel « Mettre à jour les styles »,·
que vous sélectionnez pour mettre à jour un gabarit existant afin de refléter toute modification apportée à Normal.rtf,
ou pour appliquer une feuille de style standard au gabarit .
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Faire défiler, rechercher et sélectionner du texte

Dans l'éditeur de documents, vous pouvez déplacer le curseur dans le gabarit ou le document à l'aide du clavier ou de la
souris. Vous pouvez également déplacer le curseur vers une position dans le fichier en recherchant une string de texte.

Après avoir positionné le curseur sur le texte souhaité, vous pouvez ensuite le surligner et le manipuler avec diverses
options, en plus du standard « clic-glisser » avec la souris et « Ctrl+X », « Ctrl+C » et « Ctrl ». Touches +V'.

Positionnement du curseur

Faire défiler en utilisant Possibilités

Touches du clavier Presse:

Ctrl+Flèche gauche pour passer au mot précédent·
Ctrl+Flèche droite pour passer au mot suivant·
Ctrl+Flèche Haut pour passer à la première colonne de la ligne actuelle (si ce·
n'est déjà fait sur la première colonne) ou à la première colonne de la ligne
précédente

Ctrl+Flèche vers le bas pour passer à la première colonne de la ligne suivante·
F10 pour afficher la boîte dialogue 'Aller au numéro de ligne' ; tapez un·
numéro de ligne auquel accéder et cliquez sur le bouton OK

Souris Pour exécuter diverses fonctions de défilement, cliquez sur les barres de défilement
verticales ou horizontales. Ces fonctions sont disponibles lorsque les barres de
défilement ont été activées par les paramètres de démarrage.

Barre de défilement verticale : Pour faire défiler l'écran vers le haut ou vers le bas
d'une ligne, cliquez sur les flèches à chaque extrémité.

Pour faire défiler l'écran d'une page vers le haut, cliquez au-dessus de l'ascenseur
(le bloc dans la barre de défilement) ; de même, pour faire défiler l’écran d’une
page vers le bas, cliquez sous l’ascenseur.

Vous pouvez également faire défiler l'écran vers le haut ou vers le bas en faisant
glisser l'ascenseur dans la direction appropriée.

Barre de défilement horizontale : Pour faire défiler l'écran vers la gauche ou la
droite d'une colonne, cliquez sur la flèche à l'extrémité appropriée de la barre ; pour
faire défiler l'écran vers la gauche ou la droite d'un demi-écran, cliquez sur la barre
du côté approprié de l'ascenseur.

Vous pouvez également faire défiler l'écran vers la gauche ou la droite en faisant
glisser l'ascenseur le long de la barre dans la direction appropriée.

Recherche de texte

Lorsque vous recherchez une string de texte, le dialogue permettant de spécifier les détails de la recherche ne persiste pas
à l'écran, vous pouvez donc simplement utiliser les touches du clavier ou une option de menu pour continuer la recherche
sans masquer le texte derrière une dialogue .

À Action

Rechercher la première
instance d'une string de

Sélectionnez l'option « Document-Edit > Edit > Search > Search » ou appuyez sur
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texte F5.

La dialogue « Paramètres String de recherche » s'affiche. Spécifier:

Le terme à rechercher·
S'il faut rechercher depuis le début du fichier ou vers l'avant ou vers l'arrière à·
partir de la position actuelle du curseur, et

Si la recherche doit correspondre exactement à la casse du terme de recherche·
L'éditeur recherche la première instance de la string de caractères spécifiée telle que
définie par les paramètres.

Rechercher l'instance
suivante d'une string de
texte

Sélectionnez l'option "Document-Edit > Edit > Search > Search Forward" ou
appuyez sur Ctrl+F.

L'éditeur recherche dans le fichier l'instance suivante de la string de texte
précédemment spécifiée et la met en surbrillance.

Rechercher l'instance
précédente d'une string de
texte

Sélectionnez l'option « Document-Edit > Edit > Search > Search Backward » ou
appuyez sur Ctrl+Shift+F.

L'éditeur recherche en arrière dans le fichier l'instance suivante de la string de texte
précédemment spécifiée et la met en surbrillance.

Remplacer une string de
texte

Sélectionnez l'option "Document-Edit > Edit > Search > Remplacer" ou appuyez
sur F6.

La dialogue « Remplacer les paramètres String » s'affiche, dans laquelle vous
spécifiez :

La string de texte à localiser·
La string de texte par laquelle la remplacer·
Qu'il s'agisse de rechercher l'ensemble du document ou simplement un bloc de·
texte en surbrillance

S'il faut confirmer chaque remplacement avant d'effectuer le changement·
Si vous souhaitez confirmer le remplacement, une prompt s'affiche pour chaque
occurrence du terme recherché pour confirmer ou ignorer le remplacement de cette
occurrence.

Sélection de texte

À Action

Surligner un mot Double-cliquez sur le mot.

Mettre en surbrillance une
ligne

Déplacez le curseur sur la ligne et appuyez sur F8.

Supprimer une ligne Appuyez sur Shift+F9 pour supprimer la ligne actuelle ; les lignes restantes se
rapprochent.

Coller des objets spéciaux Sélectionnez l'option « Document-Edit > Edit > Edit > Paste Special » ; la dialogue
« Collage spécial » s'affiche, répertoriant les formats de types de données
appropriés pour insérer l' object copié.

Cliquez sur le bouton Coller pour intégrer les données dans votre application, ou
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cliquez sur le bouton Coller le lien pour créer un lien vers le fichier d'origine.

« Format Object natif » : s'il est disponible, il s'agit du premier format dans la·
zone de liste ; vous pouvez éditer les données dans ce format à l'aide de
l'application d'origine, en double-cliquant sur l' object

« Texte formaté » – Un format de texte ; cette option offre le format le plus·
approprié si les données sont collées à partir d'une autre application de sortie
de texte, car les attributs de police et de formatage sont reproduits avec
précision

'Texte non formaté' - Un autre format de texte ; cette option colle le texte sans·
conserver les informations de formatage

« Format d'image » : les données sont disponibles au format d'image ; vous·
pourrez ultérieurement modifier l' object , en double-cliquant dessus et en
appelant l'application Microsoft MS Draw
Ce format est préférable aux formats Bitmap et Device Independent Bitmap

Formats « Device Independent Bitmap » et « Regular Bitmap » - Les données·
sont disponibles au format bitmap ; vous pourrez ultérieurement modifier l'
object , en double-cliquant dessus et en appelant l'application Microsoft MS
Draw
L'éditeur convertit ces formats au format Image avant d'appeler l'application de
dessin
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Formater le texte

Lorsque vous créez un gabarit de document ou un document, les styles de caractères ou de texte par défaut sont déjà
définis, car ils sont directement dérivés du fichier gabarit de style Normal.rtf. Dans le document, vous pouvez modifier
n'importe lequel de ces styles de caractères ou appliquer une mise en forme individuelle aux chaînes de texte selon vos
besoins.

Lorsque vous modifiez le format d'un texte existant, tous les nouveaux caractères que vous tapez immédiatement après ce
texte adoptent automatiquement les caractéristiques de formatage que vous avez appliquées.

Accéder

Ruban Mettez en surbrillance le texte auquel appliquer le format, puis sélectionnez les
options dans le panneau « Police » de la barre de ruban « Document-Edit ».

Options de formatage du texte

À Action

Appliquer le format de
caractère

Mettez en surbrillance le texte auquel appliquer le format et utilisez une ou
plusieurs de ces options de menu ou combinaisons de touches.

Dans le panneau ' Police ' du ruban 'Document-Edit', choisissez :

 ou ' Police | Normal', ou appuyez sur Alt+0·

 ou ' Police | Gras', ou appuyez sur Ctrl+B·

 ou ' Police | Italique', ou appuyez sur Ctrl+I·

 ou ' Police | Souligner' ou appuyer sur Ctrl+U·

 | « Double soulignement » ou « Police | Double soulignement', ou·
appuyez sur Ctrl+D

 ou ' Police | Indice', ou appuyez sur Alt+5·

 ou ' Police | Exposant', ou appuyez sur Alt+4·

 ou ' Police | Strike', ou appuyez sur Alt+6 (place une ligne dans le texte)·

 | « Double Strike », ou « Police | Double frappe'·

 | minuscule·

 | MAJUSCULE·
Police | Toutes en majuscules·
Police | En minuscule·

Pour réinitialiser n'importe quel format de caractère, mettez en surbrillance le texte

et sélectionnez l'option  ou ' Police | Normal', ou appuyez sur Alt+0.

Modifier la police de Mettez en surbrillance le texte à modifier et sélectionnez la police requise dans la
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caractères et la taille en
points

liste déroulante « Police » du panneau « Police » de la barre de ruban «
Modification du document ». Sélectionnez la taille de point requise dans la liste
déroulante « Taille », à côté de la liste « Police ».

Vous pouvez également sélectionner l'option « Document-Edit > Police > Police >
Polices ». La dialogue « Sélection Police » s'affiche, à partir de laquelle vous
sélectionnez la police et la taille de points requises. Cliquez sur le bouton OK .

Changer le style de
caractère

Mettez en surbrillance le texte à modifier et sélectionnez le style de caractère requis
dans la liste déroulante "Style" du panneau " Police " de la barre de ruban "
Modification du document ".

Vous pouvez également sélectionner l'option « Document-Edit > Police > Police >
Style ».

La dialogue « Sélectionner un style » s'affiche, répertoriant les styles de caractères
actuellement définis dans la feuille de style gabarit . Sélectionnez le style souhaité
et cliquez sur le bouton OK .

Changer la couleur du
texte, de l'arrière-plan
(surbrillance permanente)
ou du soulignement

Mettez en surbrillance le texte à modifier et sélectionnez une ou plusieurs de ces
options, selon vos besoins :

Document-Édition > Police >·

Document-Édition > Police > ·

Document-Edit> Police >  > Couleur de soulignement·
Dans chaque cas, la dialogue « Couleur » s'affiche, à travers laquelle vous pouvez
sélectionner ou définir la couleur requise.

Lorsque vous avez sélectionné une couleur, cliquez sur le bouton OK .

Modifier l'espacement des
caractères

L'espacement normal des caractères (l'espace entre les caractères) est de 20 twips ;
si vous souhaitez modifier cela (ou y revenir), mettez en surbrillance le texte à
ajuster et sélectionnez l'option 'Document-Edit > Police > Police > Spacing'. La
boîte dialogue « Espacement des caractères » s'affiche.

Sélectionnez le bouton radio pour étendre ou compresser l'espacement, ou pour
revenir à l'espacement normal ; si vous passez d'un espacement normal, entrez le
nombre de points pour définir l'espacement.

Cliquez sur le bouton OK .

Modifier l'échelle
horizontale

Mettez en surbrillance le texte à modifier et sélectionnez l'option « Document-Edit
> Police > Police > Horizontal Scaling ».

La dialogue « Mise à l'échelle horizontale des caractères » s'affiche. Entrez une
valeur en pourcentage pour la quantité de mise à l'échelle requise (les valeurs
valides sont de 10 à 999 inclus), puis cliquez sur le bouton OK . Le texte (caractères
et espaces) est mis à l'échelle horizontalement, selon la quantité spécifiée.

Masquer le texte Le texte masqué n'est pas affiché à l'écran ou sur l'imprimante, mais reste dans le
document et n'est pas supprimé.

Mettez en surbrillance le texte à masquer et sélectionnez l'option « Document-Edit
> Police > Police > Hidden », ou appuyez sur Ctrl+H.

Le texte en surbrillance n'est pas affiché et le reste du texte se ferme.

Pour afficher le texte masqué, sélectionnez l'option « Document-Edit > File > Vue >
Hidden Text » ; vous pouvez ensuite rendre le texte à nouveau normal en le mettant
en surbrillance et en désélectionnant l'option « Document-Edit > Police > Police >
Hidden ».
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Créer un cadre autour du
texte

Mettez en surbrillance le texte dans la zone et sélectionnez « Police | Option de
menu encadré ; cela crée une bordure en ligne brisée autour du texte sélectionné.

Protéger le texte Mettez en surbrillance la ligne, le bloc ou la section de texte à protéger et
sélectionnez l'option « Document-Edit > Police > Police > Protect ».

Le texte sélectionné est affiché en police grise et ne peut pas être modifié.

Pour libérer le texte pour l'éditer, mettez-le en surbrillance et resélectionnez l'option
« Document-Edit > Police > Police > Protect ».

Vous pouvez sélectionner et libérer une partie du texte protégé ; le reste reste
protégé.

Note : Si l'option ruban n'est pas disponible ou si le texte n'est pas estompé, cela
signifie que vous n'avez pas supprimé le verrou de protection. (Voir Protéger le
contenu du document .)
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Créer Tableaux

Dans n'importe quel rapport de document, vous pouvez présenter des informations à l'aide tableaux simples comportant
un nombre illimité de lignes et de colonnes. Dans un gabarit de rapport, il est également possible de restituer une section
de modèle sous forme de tableau , défini avec n'importe quel nombre de colonnes mais avec seulement deux lignes. Vous
pouvez soit ajouter votre propre texte aux tableaux , soit remplir les cellules tableau avec des champs qui extraient des
informations de votre modèle.

Accéder

Ruban Document-Édition > Paragraphe > Tableau > [option]

Créer et formater un tableau

À Action

Insérer un tableau dans le
document

Positionnez le curseur sur le point du texte pour créer le tableau et sélectionnez
l'option 'Document-Edit > Paragraph > Tableau > Insérer Tableau '.

La dialogue « Nouveaux paramètres Tableau » s'affiche, dans laquelle vous
spécifiez le nombre de lignes et de colonnes tableau . Pour un tableau de sections de
modèle dans un gabarit de rapport, vous pouvez accepter les valeurs par défaut de
deux lignes et trois colonnes. Cliquez sur le bouton OK .

Votre tableau pourrait être invisible ; si tel est le cas, sélectionnez l'option
« Document-Edit > Paragraphe > Tableau > Afficher le quadrillage » pour révéler
les bordures du tableau et des cellules en lignes pointillées. Ces lignes servent à
guidage la création du document et ne s'affichent pas sur le document imprimé.
Vous pouvez ajouter des bordures imprimables à l'aide d'autres options du menu
contextuel.

L'éditeur crée initialement un tableau avec des cellules de largeur égale sur toute la
page ; vous pouvez modifier la largeur des cellules en faisant glisser les bordures
des cellules à l'aide de la souris ou en utilisant d'autres options du menu contextuel.

Insérer une nouvelle ligne
au-dessus de la ligne
actuelle

Cliquez sur une ligne puis sélectionnez l'option « Document-Edit > Paragraph >
Tableau > Insérer une ligne ».

Insérer une nouvelle
colonne à gauche de la
colonne actuelle

Cliquez sur une colonne puis sélectionnez l'option 'Document-Edit > Paragraph >
Tableau > Insérer une colonne'.

Fusionner des cellules Mettez en surbrillance les cellules à fusionner et sélectionnez l'option «
Document-Edit > Paragraph > Tableau > Fusionner les cellules ».

La largeur et/ou la hauteur de la cellule résultante est la somme des largeurs et/ou la
somme des hauteurs des cellules fusionnées.

Vous pouvez fusionner des cellules sur une ligne, dans une colonne et dans un bloc
s'étendant à la fois sur des lignes et des colonnes.
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Diviser une cellule Sélectionnez la cellule à diviser et sélectionnez l'option :

« Document-Edit > Paragraphe > Tableau > Diviser la cellule·
horizontalement » pour diviser la cellule sélectionnée en deux cellules de
largeur égale dans la colonne.

"Document-Edit > Paragraph > Tableau > Split Cell Vertically" pour diviser la·
cellule en deux cellules de hauteur égale, doublant ainsi la hauteur de la ligne
entière.

Tout texte de la cellule d'origine est affecté à la première cellule et la deuxième
cellule est créée vide.

Supprimer des cellules Sélectionnez les cellules à supprimer et sélectionnez l'option "Document-Edit >
Paragraph > Tableau > Supprimer les cellules".

La dialogue « Supprimer les cellules Tableau » s'affiche, dans laquelle vous
spécifiez si vous souhaitez supprimer :

Cellules - supprime les cellules en surbrillance ; réalignez la colonne et/ou la·
ligne après avoir fait cela

Colonnes - supprime la ou les colonnes contenant les cellules en surbrillance,·
ou

Lignes - supprime la ou les lignes contenant les cellules en surbrillance·
Si vous supprimez toutes les cellules d'un tableau , le tableau lui-même est
automatiquement supprimé.

Positionner le tableau sur la
page

Cliquez sur n'importe quelle partie du tableau et sélectionnez l'option «
Document-Edit > Paragraph > Tableau > Row Position ».

La dialogue « Alignement des lignes Tableau » s'affiche, dans laquelle vous
sélectionnez un bouton radio pour justifier à gauche, au centre ou à droite le tableau
sur la page.

Laissez la case à cocher « Toutes les lignes du Tableau » cochée.

Cette option de menu a plus d'effet si le tableau est plus étroit que la page ou la
colonne de texte.

Définir la hauteur d'une
ligne ou de toutes les lignes

Mettez en surbrillance les lignes à ajuster et sélectionnez l'option « Document-Edit
> Paragraph > Tableau > Row Height ».

La dialogue « Paramètres de hauteur de ligne » s'affiche ; vous pouvez choisir de :

Permettre la détermination automatique de la hauteur des rangs·
Définir une hauteur de ligne minimale, ou·
Définir une hauteur de ligne exacte·

Si vous définissez la hauteur, saisissez la valeur en twips.

Vous pouvez appliquer le paramètre aux lignes sélectionnées uniquement ou cocher
la case "Appliquer à toutes les lignes du tableau actuel" pour définir la hauteur de
toutes les lignes du tableau .

Ajouter une ligne d'en-tête Sélectionnez la ligne supérieure du tableau , puis sélectionnez l'option «
Document-Edit > Paragraph > Tableau > Header Row ». Appliquez le texte du titre,
les paramètres et le formatage à la ligne en surbrillance.

Dans le document ou le rapport compilé, la ligne de titre est répétée en haut des
colonnes chaque fois que le tableau passe à une nouvelle page. Dans un rapport, si
la ligne d'en-tête contient les valeurs des noms de champs, les lignes d'en-tête des
pages suivantes reflètent les valeurs de cette première ligne.

Cette option fonctionne sur la seule ligne en haut du tableau , et non sur plusieurs
lignes. Si vous modifiez le tableau et ajoutez une ligne en haut du tableau pour
servir de nouvel en-tête, la sélection de l'option de menu sur la nouvelle ligne efface
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le paramètre précédent.

Conservez le texte de la
ligne ensemble s'il continue
sur une page

Sélectionnez les lignes à protéger (de préférence toutes les lignes du tableau ) et
sélectionnez l'option "Document-Edit > Paragraph > Tableau > Keep Row
Together".

Si la ligne continue jusqu'à la fin de la page, la ligne entière est déplacée vers le
haut de la page suivante.

Définir le flux du texte
dans les lignes tableau

Sélectionnez les lignes et sélectionnez l'option « Document-Edit > Paragraph >
Tableau > Row Text Flow ».

La dialogue « Tableau Text Flow » s'affiche, dans laquelle vous sélectionnez un
bouton radio pour définir le flux de texte dans les lignes sur :

De gauche à droite·
De droite à gauche·
Défaut·

Vous pouvez appliquer le flux de texte uniquement aux lignes sélectionnées ou
cocher la case « Appliquer à toutes les lignes du tableau actuel » pour définir le flux
de texte pour toutes les lignes du tableau .

Cette option déplace également les lignes sélectionnées vers le côté approprié de la
page ou de la colonne.

Définir la largeur des
cellules sélectionnées

Sélectionnez les cellules sur lesquelles agir et sélectionnez l'option
« Document-Edit > Paragraphe > Tableau > Largeur de cellule ».

La dialogue « Définir la largeur des cellules » s'affiche, dans laquelle vous
définissez la largeur des cellules et la marge entre le texte et les côtés gauche et
droit de chaque cellule, toutes deux en twips. Vous pouvez appliquer les paramètres
à :

Toutes les cellules du tableau·
Les cellules sélectionnées uniquement·
La ou les colonnes complètes contenant les cellules sélectionnées, ou·
La ou les lignes complètes contenant les cellules sélectionnées·

Définir la largeur des
bordures des cellules

Sélectionnez les cellules sur lesquelles agir et sélectionnez l'option
« Document-Edit > Paragraphe > Tableau > Largeur de bordure de cellule ».

La dialogue « Définir la bordure de la cellule » s'affiche, dans laquelle vous
définissez la largeur des lignes en haut, en bas, à gauche et à droite des cellules
sélectionnées. Si vous souhaitez que la bordure entoure :

Les cellules sélectionnées sous forme de bloc, cochez la case "Dessiner une·
bordure de contour autour des cellules sélectionnées".

Chaque cellule sélectionnée séparément, laissez la case décochée·
Vous pouvez également définir la marge entre le texte de chaque cellule et les
bordures gauche et droite, en twips, et appliquer tous les paramètres à :

Toutes les cellules du tableau·
Les cellules sélectionnées uniquement·
La ou les colonnes complètes contenant les cellules sélectionnées, ou·
La ou les lignes complètes contenant les cellules sélectionnées·

Définir la couleur des
bordures des cellules

Sélectionnez les cellules sur lesquelles agir et sélectionnez l'option "Document-Edit
> Paragraph > Tableau > Cell Border Color".

La dialogue « Définir la couleur de la bordure de la cellule » s'affiche, dans laquelle
vous définissez la couleur de chacune des lignes en haut, en bas, à gauche et à

(c) Sparx Systems 2023 Page  28 de 177 Créé avec Enterprise Architect



Génération de documents 2023-11-23

droite d'une cellule, ou de toutes les bordures de cellule à la fois.

Vous pouvez appliquer les paramètres à :

Toutes les cellules du tableau·
Les cellules sélectionnées uniquement·
La ou les colonnes complètes contenant les cellules sélectionnées, ou·
La ou les lignes complètes contenant les cellules sélectionnées·

Définir le degré d'ombrage
sur la couleur de la cellule

Sélectionnez les cellules sur lesquelles agir et sélectionnez l'option "Document-Edit
> Paragraph > Tableau > Cell Shading".

La dialogue « Paramètres d'ombrage des cellules » s'affiche, dans laquelle vous
saisissez le pourcentage d'ombrage.

L'ombrage est l'intensité de la couleur d'arrière-plan des cellules, exprimée en
pourcentage, et est uniforme dans toutes les cellules sélectionnées. Si les cellules
n'ont pas de fond coloré, un ombrage de 0 % est blanc. Pour les fonds colorés, 0%
est la couleur initialement définie. Dans tous les cas, un ombrage de 100 %
correspond au noir.

Vous pouvez appliquer le paramètre à :

Toutes les cellules du tableau·
Les cellules sélectionnées uniquement·
La ou les colonnes complètes contenant les cellules sélectionnées, ou·
La ou les lignes complètes contenant les cellules sélectionnées·

Définir la couleur de fond
de la cellule

Sélectionnez les cellules sur lesquelles agir et sélectionnez l'option "Document-Edit
> Paragraph > Tableau > Cell Color".

La dialogue « Paramètres de couleur de cellule » s'affiche. Cliquez sur le bouton
Définir la couleur pour afficher la dialogue « Couleur », dans laquelle vous
sélectionnez une couleur de base ou définissez une couleur plus spécifique.

Lorsque vous avez sélectionné la couleur, cliquez sur le bouton OK .

Vous pouvez appliquer le paramètre à :

Toutes les cellules du tableau·
Les cellules sélectionnées uniquement·
La ou les colonnes complètes contenant les cellules sélectionnées, ou·
La ou les lignes complètes contenant les cellules sélectionnées·

Aligner verticalement le
texte dans les cellules

Sélectionnez les cellules sur lesquelles agir et sélectionnez l'option "Document-Edit
> Paragraph > Tableau > Cell Vertical Align".

La dialogue « Alignement vertical des cellules » s'affiche, dans laquelle vous
choisissez d'aligner le texte dans les cellules sélectionnées par le haut, le centre ou
le bas de la cellule ou par la ligne de base de la ligne supérieure la plus basse du
texte.

Le texte d'un tableau est par défaut aligné avec le haut de la cellule et, au fur et à
mesure que vous le saisissez, il défile vers le bas. Vous pouvez modifier cet
alignement vers le centre ou le bas de la cellule afin que le texte défile depuis le
centre ou vers le haut depuis le bas de la cellule.

Si vous disposez d'un formatage spécial - tel qu'un espacement "avant le
paragraphe" - vous pouvez aligner le texte sur la base de la première ligne la plus
basse (la ligne de base), de sorte que le texte d'une rangée de cellules soit aligné sur
le texte formaté spécial plutôt que sur la ligne de base. avec le haut ou le bas de la
cellule. Si la mise en forme spéciale est modifiée ou supprimée, le texte reste
aligné.

Vous pouvez appliquer le paramètre à :
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Toutes les cellules du tableau·
Les cellules sélectionnées uniquement·
La ou les colonnes complètes contenant les cellules sélectionnées, ou·
La ou les lignes complètes contenant les cellules sélectionnées·

Faire pivoter le texte d'une
cellule pour l'afficher
verticalement

Sélectionnez les cellules sur lesquelles agir et sélectionnez l'option "Document-Edit
> Paragraph > Tableau > Cell Rotate Text".

La dialogue « Rotation du texte de la cellule » s'affiche, dans laquelle vous
choisissez d'afficher le texte verticalement vers le haut de la cellule, verticalement
vers le bas de la cellule ou, si le texte est déjà vertical, horizontalement à travers la
cellule,

Par défaut, le texte d'un tableau s'étend horizontalement sur la cellule de gauche à
droite et défile vers le bas de la cellule de haut en bas. Vous pouvez modifier la
position du texte afin que le texte pivote de 90 degrés pour afficher :

De haut en bas, en faisant défiler la cellule de droite à gauche, ou·
De bas en haut, en faisant défiler la cellule de gauche à droite·

Si le texte s'affiche horizontalement, vous pouvez taper autant de texte que
nécessaire : la hauteur de la ligne augmente pour s'adapter au texte. Si le texte
s'affiche verticalement, vous ajustez manuellement la hauteur des lignes et la
largeur des colonnes pour s'adapter à votre texte.

Vous pouvez appliquer le paramètre à :

Toutes les cellules du tableau·
Les cellules sélectionnées uniquement·
La ou les colonnes complètes contenant les cellules sélectionnées, ou·
La ou les lignes complètes contenant les cellules sélectionnées·

Sélectionnez une colonne Cliquez sur une cellule et sélectionnez l'option « Document-Edit > Paragraph >
Tableau > Select Current Column ».

La colonne entière est mise en surbrillance et sélectionnée pour un formatage
ultérieur.

Afficher le quadrillage Afficher ou masquer les lignes de grille pour le tableau actuel. Note que, à des fins
d'impression, « Largeur de bordure » doit être défini sur une valeur non nulle.

Notes

Dans certaines circonstances, un tableau dans un rapport généré peut répéter la ligne d'en-tête plutôt que la ligne de·
sortie ; si cela se produit, créez une autre ligne dans le tableau entre la ligne d'en-tête et la ligne de sortie, et laissez
ce champ vide
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Formater les paragraphes

Lorsque vous créez un gabarit de document ou un document, les styles de paragraphe par défaut sont déjà définis, car ils
sont directement dérivés du fichier gabarit de style Normal.rtf. Dans le document, vous pouvez modifier n'importe lequel
de ces styles de paragraphe ou appliquer une mise en forme individuelle aux blocs de texte selon vos besoins.

Chaque option de formatage opère sur le paragraphe actuel ou sur un bloc de texte en surbrillance.

Accéder

Ruban Document-Edition > Paragraphe > Paragraphe > [options]

Il existe également une série d'icônes dans le panneau « Paragraphe » du ruban
« Modification du document », qui fournissent un accès direct aux options de
formatage de paragraphe couramment utilisées.

Options de formatage des paragraphes

À Action

Effacer la mise en forme de
tous les paragraphes

Sélectionnez le 'Paragraphe | Option de menu "Normal".

Toute mise en forme de paragraphe appliquée au paragraphe actuel ou au texte
sélectionné sera supprimée.

Texte central Sélectionnez le 'Paragraphe | Option de menu Centre', ou appuyez sur Alt+8.

Justifier le texte à droite Sélectionnez le 'Paragraphe | Option de menu Justifier à droite ou appuyez sur
Alt+9.

Justifiez les deux côtés du
texte

Sélectionnez le 'Paragraphe | Option de menu Justifier les deux.

Double espace Sélectionnez le 'Paragraphe | Option de menu Double Espace pour mettre un double
espace entre les paragraphes.

Retrait du paragraphe à
gauche

Sélectionnez l'option de menu "Paragraphe > Retrait à gauche" ou appuyez sur
Alt+L .

Sélectionnez à nouveau l’option pour augmenter le retrait.

Pour réduire ou annuler le retrait, cliquez sur l'icône ' Diminuer Retrait ' dans le
ruban.

Retrait du paragraphe à
droite

Sélectionnez le 'Paragraphe | Indenter l'option de menu à droite ou appuyez sur
Alt+R.

Sélectionnez à nouveau l’option pour augmenter le retrait.

Créer un retrait suspendu Sélectionnez le 'Paragraphe | Option de menu Suspendre le retrait ou appuyez sur
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Alt+T .

Sélectionnez à nouveau l'option pour augmenter le retrait de toutes les lignes
situées en dessous de la première.

Gardez les lignes de
paragraphe ensemble

Sélectionnez le 'Paragraphe | Option de menu Rester ensemble.

L'éditeur tente de conserver toutes les lignes du paragraphe sur la même page.

Gardez les paragraphes
ensemble

Sélectionnez le 'Paragraphe | Continuez avec l'option de menu Suivant.

L'éditeur tente de conserver la dernière ligne du paragraphe actuel et la première
ligne du paragraphe suivant sur la même page.

Empêcher les lignes «
veuve » et « orpheline »

Sélectionnez le 'Paragraphe | Option de menu Contrôle des veuves/orphelins.

L'éditeur tente d'éviter d'avoir :

la première ligne du paragraphe de la page précédente (ligne 'veuve')·
la dernière ligne du paragraphe de la page suivante (ligne 'orpheline')·

Démarrer le texte sur une
nouvelle page

Déplacez le curseur jusqu'au point auquel démarrer la nouvelle page et sélectionnez
le 'Paragraphe | Option de menu Saut de page avant.

Insérer une bordure et un
ombrage pour le bloc de
texte

Sélectionnez le 'Paragraphe | Option de menu Bordure et ombrage.

La boîte dialogue « Paramètres de la zone de paragraphe » s'affiche, dans laquelle
vous spécifiez :

Quels côtés de la boîte afficher (y compris une ligne entre les lignes de texte)·
Que les lignes soient épaisses ou doublées·
Le degré de grisé derrière le texte·
La couleur des lignes·

Définir l'espacement des
lignes

Sélectionnez le 'Paragraphe | Option de menu Espacement des paragraphes.

La dialogue « Paramètres d'espacement des paragraphes » s'affiche, dans laquelle
vous spécifiez l'espacement des lignes et l'espacement des points avant et après les
lignes.

Alternativement, pour simplement définir un double interligne, sélectionnez
« Paragraphe | Option de menu Double Espace.

Définir une couleur
d'arrière-plan pour l'espace
de texte

Sélectionnez le 'Paragraphe | Option de menu Couleur d'arrière-plan.

La dialogue « Couleur » s'affiche, dans laquelle vous sélectionnez la couleur
d'arrière-plan.

L'éditeur met en évidence toute la largeur de la page dans cette couleur, pour les
lignes sélectionnées.

Créer une liste à puces Sélectionnez le 'Paragraphe | Option de menu Puce.

L'éditeur formate les lignes dans une simple liste à puces.

Si vous souhaitez mettre davantage en retrait la liste (ou une partie de celle-ci),
sélectionnez l'option « Paragraphe | Option de menu Augmenter le niveau. Si vous
avez augmenté le retrait mais que vous souhaitez maintenant le diminuer,
sélectionnez l'option « Paragraphe | "Diminuer le niveau".

Créer une liste numérotée Mettez en surbrillance les lignes de texte requises et sélectionnez le « Paragraphe |
Option de menu Numérotation.

L'éditeur formate les lignes en une simple liste numérotée.
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Pour créer des listes numérotées à plusieurs niveaux, voir Définir les caractères de
la liste .

Appliquer la numérotation
aux paragraphes

(Utilisé dans l'éditeur de documents Gabarit .)

Configurez une liste de numérotation et des remplacements ('Document-Edit >1.
Edit > Edit > List and Overrides > Create List Item ' et 'Create List Override').

Appliquez les niveaux de numérotation aux sections gabarit ('Document-Edit >2.
Paragraph > Paragraph > List Numbering').

Appliquer un style de
paragraphe à partir de la
feuille de style gabarit

Sélectionnez le 'Paragraphe | Option de menu Style.

La dialogue « Sélectionner un style » s'affiche, répertoriant les styles de paragraphe
actuellement définis dans la feuille de style gabarit .

Sélectionnez le style souhaité et cliquez sur le bouton OK .

Définir le flux du texte
dans le document

Pour définir le flux de texte pour :

Un bloc de texte en surbrillance, sélectionnez l'option de ruban·
« Document-Edit > Paragraphe > Paragraphe > Flux de texte ; la dialogue
« Flux de texte du paragraphe » s'affiche

Pour l'ensemble du document, sélectionnez l'option de menu « Document-Edit·
> Edit > Document Text Flow » ; la dialogue « Flux de texte du document »
s'affiche

Dans les deux cas, sélectionnez la direction de flux de texte requise et cliquez sur le
bouton OK . Les options sont :

De gauche à droite·
De droite à gauche·
Défaut·

L'action « Par défaut » dépend du paramètre de langue du système ; par exemple, si
la langue du système est l'hébreu ou le chinois, le flux de texte par défaut est de
droite à gauche.

Marqueur de paragraphe Affiche ou masque les différents marqueurs d'espace dans le texte, tels que :

Le marqueur de paragraphe à la fin de chaque paragraphe·
Les indicateurs de tabulation entre les blocs de texte à onglets, et·
Le marqueur de caractère vide entre les mots·

Cette option est utile lorsque vous travaillez avec du texte formaté en page et
structuré à l'aide de définitions de style et de frappes au clavier.

Définir les caractères de la
liste

Lorsque vous avez configuré vos éléments de liste à puces ou numérotés, vous
pouvez basculer entre les options de caractères de liste à l'aide de l'icône de flèche
déroulante juste à gauche de l'icône de liste à puces dans la barre d'outils inférieure
de l'éditeur gabarit de document.

Lorsque vous cliquez sur cette icône, vous êtes invité à choisir entre un format de
liste à un seul niveau et un format de liste à plusieurs niveaux. Lorsque vous
sélectionnez l'une de ces options, vous effectuez ensuite une autre sélection entre :

Simple niveau : chiffres arabes, chiffres romains, lettres majuscules et lettres·
minuscules

Plusieurs niveaux : chiffres arabes, chiffres romains et symboles de puces·
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Définir des sections de document

À l'aide de l'éditeur de documents, vous pouvez diviser votre texte en sections distinctes, présenter le texte dans une
section au format en colonnes et définir différentes orientations de page et impression pour chaque section. Un document
à plusieurs sections est utile pour :

Changer la présentation et le format du texte pour différentes zones d'information·
Changement entre l'orientation portrait et paysage pour différentes parties du document·
Varier les marges des pages d'une page à l'autre·

Accéder

Ruban Document-Edition > Edition > Insérer > Insérer un saut > Saut de section

Créer une rubrique

Sélectionnez l'option 'Insérer | Insérer une pause | Option de menu Saut de section. Cela crée une nouvelle section sur une
nouvelle page.

Le saut de section est représenté par une ligne pointillée ; si cela n'est pas visible, cliquez sur l'icône  dans le panneau
'Paragraphe' du ruban 'Document-Edit'.

L'option de menu « Saut de section » n'est pas efficace lorsque « Modifier l'en-tête/pied de page » est actif, car le
contrôle d'édition passe aux bandes d'en-tête et de pied de page éloignées du corps du document.

Définir les propriétés de la section

Les propriétés de section s'appliquent à tout le contenu du document après le saut de section, jusqu'à la ligne de saut de
section suivante.

Sélectionnez l'option 'Document-Edit > Edit > Edit > Edit Section' pour afficher la dialogue 'Section Parameters'.
Remplissez chaque panneau pour configurer la section selon vos besoins.

À Action

Définir le nombre de
colonnes dans une section

Le champ « Nombre de colonnes » est par défaut « 1 », pour présenter le texte
comme une page de texte normale (en fait une seule colonne).

Pour structurer le texte en deux colonnes ou plus sur une page :

Dans le champ "Nombre de colonnes", saisissez le nombre de colonnes dans·
lesquelles diviser le texte sur la page.

Dans le champ "Espace entre les colonnes", saisissez la séparation des·
colonnes, en pouces

Si vous souhaitez séparer les colonnes par une ligne verticale, cochez la case·
"Ligne entre les colonnes".

Lorsque vous fermez le dialogue , le texte s'affiche dans le nombre sélectionné de
colonnes d'égale largeur, sur toute la page. Le texte s'enroule au bord de la colonne
et, lorsqu'il atteint le bas de la page, continue en haut de la colonne suivante.
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Démarrer la section sur une
nouvelle page

Si vous souhaitez insérer un saut de page avant la nouvelle section, cochez la case '
Démarrer la section sur une nouvelle page'.

Si vous souhaitez également ajuster la numérotation des pages afin que la nouvelle
section commence à une page spécifique, cochez la case « Redémarrer le numéro
de page à » et saisissez le numéro de page.

La page de début de section sera souvent 1, mais cette facilité est également utile
pour insérer un autre document d'un nombre constant de pages entre, par exemple,
une introduction et une section technique.

Définir la direction du texte Définissez la direction du flux de texte dans la section en sélectionnant le bouton
radio approprié.

Définir l'orientation de la
page

Définissez l’orientation de la page dans la section en sélectionnant le bouton radio
approprié.

Définir le format de papier
pour la section

Sélectionnez un format de papier standard pour les pages de la section.

Vous pouvez également faire défiler la liste et sélectionner l'option « Taille
personnalisée », puis définir la largeur et la hauteur de la page, en pouces.

Vous pouvez également définir des marges de page spéciales en sélectionnant
l'option 'Document-Edit > File > File > Page Disposition '.

Définir la source de papier Les sélections « Source de papier » sont toutes deux par défaut « Sélection
automatique », de sorte que les pages de la section s'impriment à partir de tous les
magasins papier disposant de papier.

Si vous imprimez sur du papier à partir d'un bac spécifique ou si vous introduisez
manuellement du papier dans l'imprimante pour cette section, sélectionnez l'option
appropriée. Vous pouvez sélectionner différentes options pour la première page de
la section et les pages suivantes de la section.

Supprimer un saut de section

Déplacez le curseur sur la ligne intitulée Saut de section et appuyez sur la touche Suppr.

Lorsque vous supprimez un saut de section, les propriétés de section de la section précédente s'appliquent maintenant au
contenu du document suivant la ligne supprimée.
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Définir les onglets

À l'aide de l'éditeur de documents, vous pouvez définir des points de tabulation gauche, droit, central et décimal pour
définir les positions des chaînes de texte et des colonnes sur la page. Un paragraphe ou un bloc de texte en surbrillance
peut comporter jusqu'à vingt points de tabulation, qui s'appliquent à chaque ligne du texte sélectionné.

Si vous ne définissez pas de points de tabulation, la touche Tab déplace le curseur vers les points de tabulation par défaut
à des intervalles de 0,5 pouce.

Accéder

Ruban Sélectionnez « Document-Edit > Paragraphe », puis choisissez l'un des :

Définir l'onglet·
Onglet Effacer·
Effacer tous les onglets,·

ou cliquez sur la règle en haut de la page.

Créer et Effacer des points d'onglet

Opération Détail

Utiliser la règle Si la règle n'est pas visible, sélectionnez l'option 'Document-Edit > File > Vue >
Horizontal Ruler'.

Créer un:

Onglet gauche, cliquez sur la position de tabulation requise sur la règle ; la·
languette de gauche est indiquée sur la règle par une forme de « L »

Onglet droit, cliquez-droit sur la position d'onglet souhaitée sur la règle ; la·
languette de droite est indiquée sur la règle par une forme de « L » inversé

Centrez l'onglet, appuyez sur Maj et cliquez sur la position de tabulation·
requise sur la règle ; la languette centrale est indiquée sur la règle par une
forme de « T » inversé

Tabulation décimale, appuyez sur Shift et cliquez-droit sur la position de·
tabulation souhaitée sur la règle ; la butée de tabulation décimale est indiquée
sur la règle par une forme de « T » inversé avec un point sur le côté droit
Cet onglet est destiné aux nombres avec un point décimal ; les nombres
défilent vers la gauche depuis l'onglet jusqu'à ce que vous tapiez le point, puis
les nombres défilent vers la droite.

Pour déplacer une position de tabulation, cliquez sur le symbole de tabulation sur la
règle et faites-le glisser vers la nouvelle position.

Utilisation de l'option de
menu Définir l'onglet

L'option de menu « Paragraphe > Définir l'onglet » affiche la dialogue « Définir une
position de tabulation », dans laquelle vous sélectionnez parmi un ensemble de
boutons radio pour spécifier le type d'onglet.

Le dialogue offre deux avantages par rapport au dirigeant ; tu peux:

Réglez la position de la tabulation avec plus de précision et avec une valeur·
claire (en pouces) que vous pouvez dupliquer
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Sélectionnez parmi un ensemble de boutons radio pour ajouter ou supprimer·
une ligne pointillée, brisée ou continue précédant le point de tabulation.

Cliquez sur le bouton OK pour enregistrer les paramètres.

Effacer un seul point de
tabulation

Mettez en surbrillance le bloc de texte et sélectionnez le « Paragraphe | Option de
menu de l'onglet Effacer .

La dialogue « Effacer une position de tabulation » s'affiche.

Sélectionnez l'onglet à effacer et cliquez sur le bouton OK .

Effacer tous les points de
tabulation d'un bloc de
texte

Sélectionnez le bloc de texte et sélectionnez le 'Paragraphe | Option de menu
Effacer Tous les onglets.

Notes

L'option « Document-Edit > File > Manage > Snap To Grid » affecte le mouvement des onglets (et des marqueurs·
d'indentation de paragraphe) sur la règle ; lorsque vous sélectionnez cette option, les mouvements des marqueurs de
tabulation sont verrouillés sur une grille invisible à intervalles de 1/16 de pouce (une demi-division de règle)
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Gérer les sauts de page

Lorsque vous configurez la structure du document, vous souhaiterez peut-être insérer un saut de page ou de colonne pour
forcer une partie spécifique du contenu du document à démarrer sur une nouvelle page ou colonne.

Accéder

Ruban Document-Édition > Édition > Insérer > Insérer un saut > Saut de page, ou

Document-Edition > Edition > Insérer > Insérer un saut > Saut de colonne

Raccourcis Clavier Ctrl+Entrée (saut de page)

Forcer un saut de page

Sélectionnez l'option "Document-Edit > Edit > Insert > Insert Break > Page Break" ou appuyez sur Ctrl+Entrée.

Le saut de page forcé est indiqué par une ligne continue étiquetée ; si celui-ci n'est pas visible, cliquez sur l'icône  ,
dans le panneau 'Paragraphe' du ruban 'Document-Edit'.

Créer un saut de colonne

Déplacez le curseur vers le point approprié dans le texte de la colonne et sélectionnez l'option « Document-Edit > Edit >
Insert > Insérer un saut > Un saut de colonne ». La rupture est indiquée par une ligne intitulée « points et tirets ».

Normalement, dans une section à plusieurs colonnes, le texte s'écoule de la fin d'une colonne vers le haut de la colonne
suivante ; un saut de colonne force le texte à passer à la colonne suivante avant que la colonne actuelle ne soit
complètement remplie.

Supprimer une pause

Un saut de page ou un saut de colonne est indiqué par une ligne étiquetée. Pour supprimer la pause, déplacez le curseur
sur cette ligne et appuyez sur la touche Suppr.
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Insérer des en-têtes, des pieds de page, des notes de bas
de page et des notes de fin

Lors de la création d'un rapport de document ou gabarit , vous pouvez inclure des en-têtes de page, des pieds de page, des
notes de fin et des notes de bas de page. Vous activez les options pour créer et modifier ces éléments, puis désactivez à
nouveau ces options pour protéger les entrées. Pendant que vous créez des en-têtes et des pieds de page, vous pouvez
également continuer à modifier le corps du document. Vous pouvez créer des en-têtes et des pieds de page :

À appliquer tout au long du document·
Séparément pour chaque section que vous pourriez créer dans votre document·
Séparément pour la première page du document et pour les pages suivantes (par exemple, pour ne laisser aucun texte·
d'en-tête et de pied de page sur la page de titre du document)

Séparément pour les pages de gauche et de droite·

Options d'en-tête et de pied de page

À Action

Créer l'en-tête et le pied de
page de la page

Sélectionnez l'option "Document-Edit > Edit > Edit > Page Header/Footer > Edit
Page Header/Footer".

Une ligne pointillée délimite la zone d'en-tête en haut de la page et la zone de pied
de page en bas de la page. Cette ligne pointillée se trouve à une position définie à
l'aide de la dialogue « Mise en page » (« Document-Edit > File > File > Page
Disposition »).

Dans chacune de ces deux zones, un marqueur de paragraphe s'affiche pour
indiquer où le texte sera placé par rapport aux bords supérieur et inférieur du
papier. Cette position est également définie dans la dialogue 'Mise en page'.

Vous pouvez saisir n'importe quel type de texte libre ou formaté et insérer des
icônes à votre guise. Vous travaillerez normalement dans les zones définies pour
l'en-tête et le pied de page, mais si le texte dépasse la zone, les lignes pointillées se
déplacent simplement pour s'adapter au texte.

Modifier ou supprimer le
texte de l'en-tête et du pied
de page de la page

Sélectionnez l'option "Document-Edit > Edit > Edit > Page Header/Footer > Edit
Page Header/Footer", déplacez le curseur sur le texte et apportez les modifications
nécessaires. Si nécessaire, supprimez complètement le texte.

Créer un en-tête et un pied
de page séparés pour la
page initiale du document

Sélectionnez l'option « Document-Edit > Edit > Edit > Page Header/Footer > Edit
Page Header/Footer » pour accéder aux espaces de texte d'en-tête et de pied de
page.

Sélectionnez l'option 'Document-Edit > Edit > Edit > Page Header/Footer > First
Page Header/Footer' et soit :

L'option « Créer un en-tête de première page », ou·
L'option « Créer un pied de page de première page »·

Un marqueur de paragraphe s'affiche en haut ou en bas de la première page du
document. Si vous souhaitez qu'un texte spécifique s'affiche sur la première page du
document, saisissez-le et formatez-le.

Vous pouvez également laisser les espaces vides afin que la première page ne
contienne aucun texte d'en-tête ou de pied de page.

Afficher l'en-tête et le pied Si vous avez créé un en-tête et/ou un pied de page de page initial distinct et que
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de page communs du
document sur la page
initiale

vous souhaitez maintenant afficher le même texte d'en-tête et de pied de page sur la
page initiale que celui affiché sur les pages suivantes du document, vous supprimez
spécifiquement l'affectation « en-tête/pied de page de première page ». .

Sélectionnez l'option « Document-Edit > Edit > Edit > Page Header/Footer > Edit
Page Header/Footer » pour accéder aux espaces de texte d'en-tête et de pied de
page.

Sélectionnez l'option 'Document-Edit > Edit > Edit > Page Header/Footer > First
Page Header/Footer' et soit :

L'option « Supprimer l'en-tête de la première page » ou·
L'option « Supprimer le pied de page de la première page »·

L'affectation et le texte de la « première page » sont supprimés des espaces d'en-tête
et/ou de pied de page de la première page.

Créer un en-tête et un pied
de page séparés pour les
pages de gauche

Sélectionnez l'option « Document-Edit > Edit > Edit > Page Header/Footer > Edit
Page Header/Footer » pour accéder aux espaces de texte d'en-tête et de pied de
page.

Sélectionnez l'option 'Document-Edit > Edit > Edit > Page Header/Footer > Left
Page Header/Footer' et soit :

L'option "Créer un en-tête de page gauche", ou·
L'option "Créer un pied de page gauche"·

Faites défiler jusqu'à la page de gauche la plus proche et, dans l'espace d'en-tête ou
de pied de page, saisissez tout type de texte libre ou formaté et insérez des icônes
selon vos besoins.

Ce texte s'affiche sur chaque page de gauche de la section ou, s'il n'y a pas de
sections, dans le document.

Formatez votre document pour placer les informations de la page de gauche sur les
pages avec des en-têtes et des pieds de page à gauche. Par exemple, dans les
documents en anglais, les pages paires sont généralement des pages de gauche.

Créer un en-tête et un pied
de page séparés pour les
pages de droite

Sélectionnez l'option « Document-Edit > Edit > Edit > Page Header/Footer > Edit
Page Header/Footer » pour accéder aux espaces de texte d'en-tête et de pied de
page.

Sélectionnez l'option 'Document-Edit > Edit > Edit > Page Header/Footer > Right
Page Header/Footer' et soit :

L'option "Créer un en-tête de page de droite", ou·
L'option « Créer un pied de page droit »·

Faites défiler jusqu'à la page de droite la plus proche et, dans l'espace d'en-tête ou
de pied de page, saisissez tout type de texte libre ou formaté et insérez des icônes
selon vos besoins.

Ce texte s'affiche sur chaque page de droite de la section ou, s'il n'y a pas de
sections, dans le document.

Formatez votre document pour placer les informations de la page de droite sur les
pages avec des en-têtes et des pieds de page à droite. Par exemple, dans les
documents en anglais, les pages impaires sont généralement des pages de droite, et
les sections telles que Titre, Introduction et Tableau des matières commencent sur
les pages de droite.

Supprimer les en-têtes et
pieds de page de gauche ou
de droite

Sélectionnez l'option « Document-Edit > Edit > Edit > Page Header/Footer > Edit
Page Header/Footer » pour accéder aux espaces de texte d'en-tête et de pied de
page.

Sélectionnez l'option 'Document-Edit > Edit > Edit > Page Header/Footer > <side>
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Page Header/Footer' (où <side> est soit à gauche soit à droite) et soit :

L'option 'Supprimer l'en-tête de page <side>', ou·
L'option « Supprimer le pied de page <side> »·

Vous êtes invité à confirmer la suppression ; cliquez sur le bouton Oui.

Les en-têtes ou pieds de page gauche et droit s’équilibrent. Si vous en créez un, le
système répond comme si l'autre existait mais est vide. Si vous en supprimez un, le
système répond comme si l'autre était l'en-tête/pied de page « commun » de la
section, et tous les en-têtes de page contiennent maintenant ce texte restant.

Fermer et protéger les
en-têtes et pieds de page

Sélectionnez l'option 'Document-Edit > Edit > Edit > Page Header/Footer > Edit
Page Header/Footer' pour accéder à nouveau aux espaces de texte d'en-tête et de
pied de page, et vérifiez que vous ne pouvez pas déplacer le curseur dans les
espaces d'en-tête et de pied de page.

Options de note de bas de page et de note de fin

À Action

Créer une note de bas de
page

Déplacez le curseur vers la position à laquelle insérer le marqueur de note de bas de
page et sélectionnez l'option « Document-Edit > Edit > Insert > Footnote/Endnote >
Footnote ».

La dialogue « Note de bas de page » s'affiche. Dans le:

Dans le champ « Marqueur de note de bas de page », saisissez le marqueur que·
vous souhaitez utiliser, tel qu'un chiffre, un astérisque, un dièse ou une lettre de
l'alphabet, ou toute string de texte pouvant contenir jusqu'à 10 caractères.

Champ « Texte de la note de bas de page », saisissez le texte de la note de bas·
de page

Dans le champ « Marqueur de note de bas de page en exposant », laissez la·
case cochée pour afficher le marqueur en exposant, ou décochez la case pour
afficher le marqueur dans le même format que le texte précédent.

Cliquez sur le bouton OK ; l'éditeur insère le marqueur de note de bas de page à
l'emplacement actuel du curseur et affiche le marqueur et le texte au bas de la page,
au-dessus de l'espace du pied de page.

Modifier le texte de la note
de bas de page

Sélectionnez l'option "Document-Edit > Edit > Edit > Edit Footnote/Endnote > Edit
Footnote text".

Le marqueur et le texte de chaque note de bas de page s'affichent dans le texte du
document à l'endroit où le marqueur a été initialement inséré, mis en évidence par
un soulignement brisé.

Localisez le texte et apportez les modifications requises. Ces changements sont
immédiatement reflétés dans le texte de la note de bas de page.

Lorsque vous avez fini de modifier le texte de la note de bas de page, cliquez à
nouveau sur l'option « Document-Modifier > Modifier > Modifier > Modifier la
note de bas de page/de fin > Modifier le texte de la note de bas de page » ; le texte
de la note de bas de page n'est plus affiché dans le texte du document.

Créer une note de fin Déplacez le curseur vers la position à laquelle insérer le marqueur de note de fin et
sélectionnez l'option « Document-Edit > Edit > Insert > Footnote/Endnote >
Endnote ».
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La dialogue « Paramètres de note de fin » s'affiche. Dans le:

Dans le champ « Marqueur de note de fin », saisissez le marqueur que vous·
souhaitez utiliser, tel qu'un chiffre ou une lettre de l'alphabet, ou toute string de
texte pouvant contenir jusqu'à 10 caractères.

Champ « Texte de la note de fin », saisissez le texte de la note de fin·
Dans le champ « Marqueur de note de fin en exposant », laissez la case cochée·
pour afficher le marqueur en exposant, ou décochez la case pour afficher le
marqueur dans le même format que le texte précédent.

Cliquez sur le bouton OK ; l'éditeur insère le marqueur de note de fin à
l'emplacement actuel du curseur et affiche le marqueur et le texte à la fin de la
section ou, s'il n'y a pas de sections, à la fin du document.

Modifier le texte de la note
de fin

Sélectionnez l'option « Document-Modifier > Modifier > Modifier > Modifier la
note de bas de page/note de fin | Modifier le texte de la note de fin.

Le marqueur et le texte de chaque note de fin s'affichent dans le texte du document
à l'endroit où le marqueur a été initialement inséré, mis en évidence par un
soulignement brisé.

Localisez le texte et apportez les modifications requises ; ces modifications sont
immédiatement reflétées dans les notes de fin de section ou de document.

Lorsque vous avez fini de modifier le texte de la note de fin, cliquez à nouveau sur
l'option « Document-Edit > Edit > Edit > Edit Footnote/Endnote | Modifier le texte
de la note de fin'; le texte de la note de fin n'est plus affiché dans le texte du
document.

Notes

Vous pouvez créer et modifier des en-têtes et des pieds de page, que l'option « Document-Edit > File > Vue > Page·
Disposition Mode » soit activée ou désactivée ; cette option ne fait aucune différence
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Insérer des hyperliens

Dans un document, vous pouvez insérer des hyperliens pour afficher des éléments contenus en dehors du document, tels
que des documents externes, des rubriques d'aide ou des pages Web.

Accéder

Ruban Document-Edition > Edition > Insérer > Lien hypertexte

Insérer des hyperliens

Pour insérer un hyperlien, cliquez-droit sur l'endroit du texte où le créer et sélectionnez l'option 'Document-Edit > Edit >
Insert > Hyperlink' ; la dialogue « Insérer un lien hypertexte » s'affiche.

Dans le champ « Texte du lien », saisissez le texte auquel créer un lien hypertexte et, dans le champ « Code du lien »,
saisissez ou collez :

URL de la page Web·
Nom du fichier de la rubrique d'aide ou·
Chemin et nom du fichier externe·

Pour capturer le nom et le chemin du fichier de la rubrique d'aide, cliquez-droit sur la rubrique affichée et copiez le nom
du fichier et le chemin à partir du champ d'adresse en haut de l'écran.

Cliquez sur le bouton OK ; le texte du lien hypertexte s'affiche dans le document. Modifiez la phrase pour l'adapter au
texte du lien.

Pour afficher la page Web, la page d'aide ou un document externe :

Lié dans un document, double-cliquez sur le lien·
Lié dans un gabarit de rapport, compilez le rapport et cliquez sur le lien hypertexte dans le rapport·

Dans un document Bibliothèque , vous pouvez également insérer des hyperliens vers des objets associés dans le modèle.
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Insérer des images, des objets et des cadres

Lors de la création de votre document ou gabarit , vous souhaiterez peut-être intégrer ou afficher des images et d'autres
objets dans le texte, insérer des informations externes et/ou structurer le texte et les graphiques sur une page. Vous
pourriez insérer par exemple :

Une image dans le texte ou comme arrière-plan du texte·
Un lien vers une image·
Un object Object Linking and Embedding (OLE), que vous créez et modifiez à l'aide d'une application externe.·
Un cadre : une bordure rectangulaire à l'intérieur du texte qui peut contenir du texte et des images séparés, et autour·
de laquelle le texte existant circule

Un object de dessin : un rectangle, une zone de texte ou une ligne pouvant s'asseoir sur le texte existant.·
Un autre fichier de documents·

Après avoir inséré un object , vous pouvez ensuite le déplacer, le modifier ou le supprimer.

Insérer des éléments

À Action

Insérer une image dans le
document

Vous pouvez insérer une image bitmap ou un métafichier Windows dans votre
document sous forme d'image intégrée ou de lien vers le fichier image externe.

Placez le curseur à l'endroit où insérer l'image et sélectionnez soit :

'Document-Edit > Edit > Insert > Incorporer l'image' (F8) ou·
'Document-Edition > Edition > Insérer > Lier une image'·

Une dialogue de navigateur s'affiche, à travers laquelle vous sélectionnez l'image à
insérer dans le document ; l'image s'affiche à l'emplacement actuel du curseur.

L'image intégrée est enregistrée dans le document ; seul le nom de fichier de
l'image liée est enregistré avec le document, ce qui constitue une meilleure option si
vous avez l'intention de modifier l'image au fil du temps.

Incorporer un object OLE
dans le texte

Positionnez le curseur à l'endroit où intégrer l' object et sélectionnez l'option de
menu 'Document-Edit > Edit > Insert > OLE Object '.

La dialogue 'Insérer Object ' s'affiche, répertoriant les applications disponibles pour
créer l' object .

Lorsque vous sélectionnez une application, l'éditeur la lance et vous créez l' object ;
lorsque vous enregistrez l'application, l'éditeur insère une icône ou une vue qui
représente l' object inséré.

Vous pouvez également utiliser l'option 'Document-Edit > Edit > Edit > Paste
Special' pour importer des objets OLE, à condition que l' object soit disponible dans
le presse-papiers.

Vous pourrez ultérieurement modifier l' object à l'aide de l'application, en
double-cliquant sur l' object ou en sélectionnant l'option 'Document-Edit > Edit >
Edit > Edit OLE Object '.

Modifier la taille et
l'alignement d'une image
intégrée

Cliquez sur l'image et sélectionnez l'option « Document-Edit > Edit > Edit > Edit
Picture » ; la dialogue « Modifier l'image actuelle » s'affiche, grâce à laquelle vous
pouvez modifier la hauteur et la largeur de l'image, en pouces.

Vous pouvez également aligner le haut, le milieu ou le bas de l'image avec la ligne
de base de n'importe quel texte sur la même ligne que l'image, ou décaler le bas de

(c) Sparx Systems 2023 Page  44 de 177 Créé avec Enterprise Architect



Génération de documents 2023-11-23

l'image par rapport à cette ligne de base d'un nombre quelconque de points.

Insérer une image
d'arrière-plan ou un
filigrane pour les pages du
document ( gabarits de
rapport de document)

Sélectionnez l'option « Document-Edit > Fichier > Gérer > Filigrane d'image » ;
une dialogue de navigateur s'affiche, à travers laquelle vous sélectionnez le fichier
graphique à insérer en filigrane. L'image occupe toute la zone de texte et s'affiche
sous forme d'image délavée. Si vous choisissez une image déjà délavée, aucun
filigrane ne s’affichera.

Pour supprimer l'image en filigrane, désélectionnez l'option "Document-Edit > File
> Manage > Watermark Picture".

Insérer un document
Fichier

Positionnez le curseur à l'endroit où insérer le fichier et sélectionnez l'option «
Document-Edit > Edit > Insert > Insérer un fichier RTF ».

Incorporer un cadre à la
position du curseur

Sélectionnez l'option 'Document-Edit > Edit > Insert > Frame'.

La bordure du cadre s'affiche, avec le curseur dans le coin supérieur gauche. Vous
pouvez modifier la taille du cadre en cliquant sur la bordure et en faisant glisser les
petites « poignées » noires.

Incorporer un object de
dessin à la position du
curseur

Sélectionnez l'option 'Document-Edit > Edit > Insert > Drawing Object '.

La dialogue « Sélectionner le Type Object de dessin » s'affiche, dans laquelle vous
sélectionnez le bouton radio pour :

Zone de texte·
Rectangulaire ou·
Doubler·

Cliquez sur le bouton OK ; l' object sélectionné s'affiche, superposé au contenu du
document existant. Si nécessaire, vous pouvez modifier la taille de l' object en
cliquant sur la bordure et en faisant glisser les petites « poignées » noires.

Vous pouvez également modifier l'apparence et la relation de l' object avec le texte
du document.

Déplacer le cadre ou object
de dessin

Cliquez sur le contour du cadre ou object de dessin, puis déplacez le curseur juste à
l'extérieur du contour afin que le curseur se transforme en forme plus.

Faites glisser la forme plus (et donc le contour) vers la nouvelle position.

Modifier la bordure,
l'arrière-plan et l'impact sur
le texte du document d'un
object de dessin

Sélectionnez l' object de dessin en cliquant sur son contour, puis sélectionnez
l'option 'Document-Edit > Edit > Edit > Edit Frame/Drawing Object > Edit
Drawing Object '.

La dialogue « Attributs de ligne et de remplissage » s'affiche.

Sélectionnez les options à définir :

S'il faut afficher une ligne de bordure et, si oui, votre épaisseur, type et couleur·
de bordure préférés

Si l' object est transparent ou rempli et, s'il est rempli, la couleur de·
remplissage

Le comportement d'habillage du texte en dehors de l' object :·
- 'Wrap Through' fait circuler le texte du document à travers le
object diagramme afin qu'ils se chevauchent
- 'No Wrap' fait que le texte du document saute sur l' object ,
pour que le texte reprenne en dessous de l' object
- 'Enrouler autour de l' Object ' fait circuler le texte du document
autour de l' object , en colonne d'un côté ou de l'autre de
l' object , ou des deux côtés ; si vous déplacez l' object sur le
page, l'éditeur a tendance à laisser une marge plus large avant de commencer
pour envelopper le texte à gauche de l' object
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L'ordre Z de l' object , de sorte que s'il y a un chevauchement, l' object se·
trouve soit devant le texte du document (ordre Z = 1), soit derrière le texte du
document (ordre Z = > 1).

Insérer du texte dans le
cadre, la zone de texte ou
le rectangle

Cliquez à l'intérieur du contour et tapez le texte à la position du curseur. Le texte
s'enroule sur le côté droit de la zone et, pour :

Cadre, prolonge la bordure inférieure de la boîte·
Zone de texte et rectangle, déborde du bas de la zone mais est toujours associé·
à la zone et non au texte 'normal' du document ; pour entourer toutes les lignes,
ajustez la hauteur manuellement pour entourer le texte

Si vous modifiez la largeur du contour, tout texte à l'intérieur du contour est
automatiquement renvoyé à la ligne pour s'ajuster à la nouvelle largeur.

Faites pivoter le texte pour
l'afficher verticalement
dans le cadre ou la zone de
texte

Sélectionnez l'option "Document-Edit > Edit > Edit > Edit Frame/Drawing Object
> Rotate Text". La dialogue « Rotation du texte » s'affiche ; sélectionnez le bouton
radio correspondant à la direction du texte que vous souhaitez appliquer :

« Horizontal » (par défaut) : le texte s'étend du coin supérieur gauche de la·
boîte sur toute la largeur de la boîte, s'enroule au niveau de la bordure droite et
défile vers le bas.

« De haut en bas » : les caractères pivotent de 90 degrés pour s'écouler du coin·
supérieur droit de la boîte vers le bas, s'ajustant au bord inférieur de la boîte et
défilant de droite à gauche.

« De bas en haut » : les caractères pivotent de 90 degrés pour s'écouler du coin·
inférieur gauche de la boîte vers le haut, en s'ajustant au bord supérieur de la
boîte et en défilant de gauche à droite.

Si le texte s'affiche horizontalement, vous pouvez taper autant de texte que
nécessaire : la hauteur de la zone augmente pour s'adapter au texte. Si le texte
s'étend verticalement et s'étend à l'extérieur de la zone, vous ajustez manuellement
la hauteur et la largeur de la zone pour s'adapter à votre texte.

Cliquez sur le bouton OK pour appliquer la modification.

Insérer une image dans une
zone de texte d'un cadre ou
d' object de dessin

Cliquez à l'intérieur du contour et insérez l'image comme expliqué précédemment,
ou copiez-la et collez-la à la position du curseur.

Si le cadre ou la zone de texte contient uniquement l'image, la taille de l'image est
automatiquement ajustée pour remplir le plus possible le contour sans déformer
l'image.

Si vous modifiez la largeur ou la hauteur de la boîte, l'image est ajustée pour
remplir complètement le contour ; vous continuez à ajuster manuellement le
contour pour réduire la distorsion de l’image.

Verrouiller un cadre ou
object de dessin à un point
de la page

Vous pouvez fixer la position du contour à un point spécifique afin que lorsque
vous saisissez et formatez le texte, le contour conserve sa position par rapport à ce
point.

La position par défaut est relative au premier caractère du paragraphe, auquel cas le
plan se déplace sur la page avec tout changement affectant la position du
paragraphe.

Vous pouvez également fixer la position par rapport à :

Bord supérieur de la page ou·
Marge supérieure de la page·

Dans ces cas, si le texte du document sur la page est ajusté, il dépasse le plan.

Cliquez sur le contour et sélectionnez l'option de menu "Document-Edit > Edit >
Edit > Edit Frame/Drawing Object > Vertical Base Position".

La dialogue « Position de Object » s'affiche. Sélectionnez le bouton radio
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correspondant au point de verrouillage que vous préférez :

'Haut de la page'·
'Marge supérieure'·
« Paragraphe actuel »·

Cliquez sur le bouton OK pour appliquer le verrouillage.

Supprimer un cadre ou
object de dessin

Cliquez sur le contour et appuyez sur la touche Suppr.

L'éditeur vous prompts de confirmer la suppression ; cliquez sur le bouton Oui.

Cette suppression est réversible - appuyez sur Ctrl+Z ou sélectionnez l'option
'Document-Edit > Edit > Edit > Annuler '.
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Vérification du texte

Lors du développement d'un document ou gabarit , vous souhaiterez probablement vérifier l'orthographe du texte que
vous avez saisi ; par exemple, pour s'assurer que le texte « passe-partout » est correct, car il sera utilisé plusieurs fois
dans de nombreux rapports. Dans l'éditeur de documents, vous pouvez soit corriger ponctuellement un mot à partir d'une
liste contextuelle, soit exécuter un correcteur orthographique sur l'ensemble du document. Vous pouvez également
vérifier l'utilisation d'un mot par rapport à un thésaurus en ligne, pour voir s'il existe un terme plus précis ou pour vérifier
le sens opposé du mot.

Accéder

Ruban Document-Modifier > Modifier > Vérification orthographique > [options]

Vérifier l'orthographe

À Action

Corriger un mot Sélectionnez l'option 'Document-Edit > Edit > Spell Check > Auto Vérification
Orthographique '.

Lorsque l'option 'Auto Vérification Orthographique ' est activée, l'éditeur de
documents vérifie automatiquement l'orthographe de tout le texte saisi ou collé dans
le document (mais pas les noms de champs ou le texte généré). Les mots
apparemment mal orthographiés sont soulignés en rouge.

Cliquez-droit sur un mot souligné ; une courte liste s'affiche, contenant
l'orthographe correcte du mot supposé et une sélection d'autres mots que ce mot
aurait pu être censé être. Cliquer sur:

Un des mots, pour l'utiliser à la place du mot mal orthographié·
L'option « Ignorer tout » pour utiliser le mot tel quel dans ce contexte·
L'option « Ajouter » pour ajouter le mot à la liste suggérée d'orthographe/autres·
mots

Vous utilisez peut-être une langue pour laquelle aucun dictionnaire orthographique
n'est installé, ou un texte contenant une forte proportion de nouveaux termes,
auquel cas vous ne souhaiterez peut-être pas que la fonction d'orthographe
automatique souligne tout le texte. Vous pouvez le désactiver en sélectionnant «
Autre | Option Auto Spell à nouveau.

Exécuter le correcteur
orthographique sur
l'ensemble du document

Sélectionnez l'option "Modification du document > Modifier > Vérification
orthographique > Vérification orthographique".

La dialogue « Vérifier l'orthographe » s'affiche, identifiant la première faute
d'orthographe apparente dans le document.

Vous souhaiterez peut-être modifier les éléments que le correcteur orthographique
identifie comme des erreurs ; cliquez sur le bouton Options pour personnaliser le
fonctionnement du vérificateur.

Après avoir adapté le correcteur orthographique, répondez à chacune des erreurs
possibles qu'il met en évidence dans votre document.

Lorsque vous avez réagi sur tous les mots présentés par le correcteur
orthographique (ou cliqué sur le bouton Annuler), un message d'état s'affiche
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identifiant le nombre de mots relevés et le nombre de mots que vous avez corrigés.
Cliquez sur le bouton OK .

Exécuter Thesaurus

À Action

Accéder au Thésaurus Sélectionnez un mot dans le texte, puis sélectionnez l'option "Document-Edit > Edit
> Spell Check > Thesaurus".

La dialogue « Thésaurus » s'affiche, montrant :

Mot sélectionné·
Catégories de mots auxquelles appartient le mot, dans le panneau·
« Catégories »

Liste des synonymes du mot de la première catégorie (mots ayant la même·
signification que le mot sélectionné) dans le panneau « Synonymes »

S'il existe plusieurs catégories, cliquez sur chacune d'elles pour afficher les
synonymes au sein de chaque catégorie.

Afficher les antonymes Si vous souhaitez afficher les antonymes du mot (les sens opposés du mot), cochez
la case Antonymes.

Le titre Antonymes s'affiche dans le panneau Catégories, avec les catégories de
mots correspondant à l'opposé du mot sélectionné répertoriées en dessous.

Cliquez sur le nom d'une catégorie pour répertorier les antonymes de cette
catégorie, dans le panneau Synonymes.

Rechercher des
homonymes

Un homonyme est un mot qui ressemble à un autre et peut être confondu avec
celui-ci. Par exemple, « Sympathie » peut être confondue avec « Empathie » ou «
Symphonie ».

Si vous souhaitez vérifier que vous n'avez pas choisi par erreur un mot à
consonance similaire, cliquez sur le bouton Suggérer.

La dialogue « Suggestions » s'affiche, répertoriant les mots possibles ayant une
consonance similaire. Si vous souhaitez utiliser l'un de ces mots ou en rechercher
un autre ayant la même signification, cliquez sur le bouton Rechercher.

La dialogue « Thésaurus » s'actualise avec le nouveau mot que vous avez
sélectionné.

Rechercher de nouveaux
termes

Si vous souhaitez examiner un mot totalement différent, dans le champ « Terme »,
saisissez le nouveau mot et cliquez sur le bouton Rechercher.

L'affichage change pour afficher les synonymes (et antonymes) du nouveau mot.

Remplacer par un
synonyme

Cliquez sur un synonyme (ou un antonyme, si nécessaire) dans la liste, puis cliquez
sur le bouton OK .

Le mot dans le texte change selon la sélection.
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Suivi des modifications

Dans un environnement d'équipe, deux personnes ou plus peuvent travailler à l'élaboration de documents et/ou gabarits .
Vous devrez peut-être donc révision le travail de chacun ou simplement voir les modifications qu'une autre personne a
apportées au fichier. Dans l'éditeur de documents, vous pouvez activer le suivi des modifications pour mettre en évidence
les modifications que vous apportez au texte.

Accéder

Ruban Document-Modifier > Modifier > Suivi > [options]

Options de suivi

À Action

Activer le suivi Sélectionnez l'option "Document-Edit > Edit > Tracking > Activer le suivi".

Toutes les modifications apportées après l'activation du suivi sont immédiatement
mises en évidence :

Texte inséré - imprimé dans une couleur différente·
Texte supprimé - barré d'une seule ligne colorée·
Modifications de formatage - indiquées par un soulignement en pointillés·
colorés

Une barre de modification est également insérée dans la marge de la page ou de la
colonne pour indiquer la ligne de la page sur laquelle la modification a été
effectuée.

Si vous passez la souris sur une modification en surbrillance, une info-bulle affiche
le type de modification, le nom de la personne qui a effectué la modification, ainsi
que la date et l'heure à laquelle la modification a été effectuée.

Désactiver le suivi Sélectionnez à nouveau l'option "Document-Edit > Edit > Tracking > Activer le
suivi".

Toutes les modifications apportées après l'activation du suivi restent mises en
surbrillance, mais les modifications apportées après la désactivation du suivi ne
sont pas mises en surbrillance.

Masquer les modifications Si vous souhaitez révision le document tel qu'il est, sans les modifications mises en
surbrillance, mais que vous ne voulez pas perdre les modifications ou la mise en
surbrillance, sélectionnez l'option « Document-Modifier > Modifier > Suivi >
Masquer les modifications ».

Les ajouts et suppressions en surbrillance sont masqués et le texte restant se ferme.
Les modifications de format ne sont pas masquées.

Pour exposer les modifications masquées, cliquez à nouveau sur l'option «
Document-Edit > Edit > Tracking > Hide Changes ».

Localiser les modifications Sélectionnez l'option « Document-Edit > Edit > Tracking > Find Next Change » ou
« Document-Edit > Edit > Tracking > Find Previous Change » pour rechercher le
texte et placer le curseur sur la modification suivante ou précédente effectuée,
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respectivement.

Répondre au changement Si vous souhaitez évaluer chaque changement et donner suite à votre décision,
sélectionnez l'option :

'Document-Edit > Edit > Tracking > Accept Change' pour confirmer la·
modification, ou

"Document-Edit > Edit > Tracking > Reject Change" pour annuler la·
modification apportée au texte ou au format d'origine

Dans les deux cas, les marques de suivi des modifications sont supprimées. Vous
pouvez apporter d'autres modifications si nécessaire.

Accepter toutes les
modifications

Si vous n'évaluez pas chaque modification, par exemple si vous souhaitez
simplement voir ce qu'un collègue a fait avant d'apporter vos propres modifications,
vous pouvez accepter toutes les modifications dans le document en une seule
action.

Sélectionnez l'option « Document-Modifier > Modifier > Suivi > Accepter toutes
les modifications ».

Rejeter toutes les
modifications

Si vous n'évaluez pas chaque modification, mais souhaitez simplement annuler
toutes les modifications dans le document en une seule action, sélectionnez l'option
« Modification du document > Modifier > Suivi > Rejeter toutes les
modifications ».

Une prompt s'affiche pour vous demander de confirmer l'action ; cliquez sur le
bouton Oui.

Vous pouvez le faire si, par exemple, vous ou un collègue avez modifié la mauvaise
version d'un document ou réagi à une modification technique qui a elle-même été
annulée.
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Protéger le contenu du document

Lorsque vous avez créé un document ou un texte important dans un document, vous souhaiterez peut-être le protéger
contre toute modification ou suppression afin qu'il soit à l'abri de toute modification accidentelle. L'éditeur de documents
utilise par défaut le verrouillage contre la protection. Vous devez donc d'abord désactiver le verrouillage, puis protéger
soit l'intégralité du document, soit un bloc de texte sélectionné. Une fois la protection définie, ni vous ni aucun autre
utilisateur ne pouvez modifier le texte sans supprimer spécifiquement la protection.

Accéder

Ruban Document-Édition > Fichier > Gérer > Verrouillage de la sélection de texte

Document-Edition > Police > Police > Protéger

Document-Modifier > Fichier > Gérer > Protéger le document

Protéger le texte

À Action

Activer la protection du
texte

Par défaut, le verrouillage de la sélection de texte est activé.

Sélectionnez l'option "Document-Edit > File > Manage > Text Selection Lock"
pour désactiver cette option.

Vous pouvez maintenant définir une protection sur votre texte.

Pour réactiver le verrouillage de protection et empêcher la protection d'autres
textes, sélectionnez à nouveau l'option « Modification de document > Fichier >
Gérer > Verrouillage de la sélection de texte ». Le texte que vous avez déjà protégé
reste cependant protégé et ne peut pas être modifié jusqu'à ce que vous ou un autre
utilisateur supprimiez spécifiquement la protection. Vous ne pouvez pas supprimer
la protection de ce texte tant que vous n'avez pas désactivé à nouveau le
verrouillage de protection.

Protéger le texte Mettez en surbrillance la ligne, le bloc ou la section de texte à protéger et
sélectionnez l'option « Document-Edit > Police > Police > Protect ».

Le texte sélectionné est affiché en police grise et ne peut pas être modifié.

Si l'option de menu n'est pas disponible ou si le texte n'est pas estompé, cela
signifie que vous n'avez pas supprimé le verrou de protection.

Pour libérer le texte pour l'éditer, mettez-le en surbrillance et resélectionnez l'option
« Document-Edit > Police > Police > Protect ». Vous pouvez sélectionner et libérer
une partie du texte protégé ; le reste reste protégé.

Protéger un document

Dans le document ou gabarit , sélectionnez l'option 'Document-Edit > File > Manage > Protect Document'.

L'ensemble du document est protégé.
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Une exception concerne la protection d'un gabarit dans Document Gabarit Designer. Lorsque vous cochez des cases dans
le panneau « Sections », les marqueurs de section sont toujours ajoutés au panneau « Contenu ». Vous ne pouvez
cependant pas ajouter de champs ou de texte entre les marqueurs.

Pour libérer à nouveau le document pour l'éditer, resélectionnez l'option « Document-Edit > Fichier > Gérer > Protéger le
document ».
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L'ancien générateur Rapport RTF

La création d'un document Rich Text Format (RTF) est un processus simple et flexible. Un document RTF est basé sur un
élément ou (plus généralement) un Paquetage de votre projet. Pour produire un document, vous sélectionnez le
Paquetage ou l'élément à signaler dans la fenêtre Navigateur , Paquetage Navigateur , Diagramme List ou Modèle
Search, puis appuyez sur F8 pour afficher la dialogue ' Générer Documentation'. Dans l'onglet « Options », cliquez sur le
bouton Switch Generator pour accéder à l'ancienne boîte dialogue « Rich Text Format Rapport ».

La dialogue «Rich Text Format Rapport » vous permet de définir le contenu exact ainsi que l'apparence de votre rapport.
Vous entrez le nom du fichier du rapport, un en-tête, notes supplémentaires, le nom gabarit (pour enregistrer la
configuration) et d'autres options. Vous pouvez également sélectionner le style du rapport ; soit simple, soit formel.

En option, vous pouvez configurer un filtre, les détails à inclure, les types d'éléments à exclure, s'il faut traiter
Paquetages enfants, s'il faut afficher diagrammes et le format du diagramme .

Vous pouvez revenir à la dialogue ' Générer Documentation' en cliquant sur le bouton Switch RTF Generator.

Notes

Le générateur hérité est disponible si vous avez créé gabarits RTF dans les versions d' Enterprise Architect·
antérieures à 4.1 et que vous préférez générer des rapports RTF à l'aide du générateur d'origine ; cependant, comme
vous pouvez générer des rapports à partir de ces gabarits à l'aide du générateur RTF post-Enterprise Architect 4.1, le
générateur hérité et les instructions pour son utilisation ne sont plus mis à jour.

Rapports produits à l'aide du générateur RTF hérité reflètent la fonctionnalité de formatage Notes dans tout texte·
associé aux éléments.

Les panneaux dialogue 'Rich Text Format Rapport ' sont décrits individuellement dans les rubriques suivantes de·
cette section (telles que répertoriées) ; le dialogue propose de nombreuses options - vous pouvez les utiliser de
manière sélective pour produire une sortie au niveau de détail adapté à votre projet
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Documenter un seul élément

La documentation RTF peut également être générée pour un seul élément.

Accéder

Sélectionnez l'élément pour lequel générer la documentation, puis ouvrez la dialogue ' Générer Documentation' en
utilisant l'une des méthodes décrites ici.

Ruban Publier > Rapports de Modèle > Générateur de Rapports > Générer Documentation
> Options : Générateur de commutateurs

Raccourcis Clavier F8 | Options | Générateur de commutateur
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Définir les principales Propriétés RTF

La section principale de la dialogue 'Rich Text Format Rapport ' vous permet de définir l'emplacement de sortie et
l'apparence du document RTF final.

Définir l'emplacement et l'apparence de la sortie

Étape Action

1 Ouvrez la dialogue « Rich Text Format Rapport ».

2 Fournissez un nom de fichier de sortie dans lequel enregistrer le rapport ; incluez toujours l’extension .rtf
dans le nom de fichier.

3 Dans le champ « Nom Gabarit », indiquez le nom du gabarit à partir duquel générer le rapport.

4 Sélectionnez un style de rapport : Formel ou Basique.

5 Type un titre pour votre rapport ; cela apparaît comme le premier élément de titre dans votre sortie.

6 Sélectionnez le style de titre et le retrait du niveau de titre initial requis dans les listes déroulantes.

Notes

Il est recommandé de saisir un chemin d'accès complet pour votre rapport ; les images de votre rapport sont·
enregistrées en externe dans un répertoire d'images, et fournir le chemin complet du répertoire évite toute confusion
sur l'emplacement de ces images

Si vous déplacez votre rapport, vous devez également déplacer le répertoire des images·
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Appliquer un filtre

Dans la dialogue 'Rich Text Format Rapport ', vous pouvez appliquer un filtre pour inclure ou exclure des éléments par
date de modification, phase ou statut. Cela permet de suivre les modifications et de diviser un document en plusieurs
phases de livraison.

Ouvrez la dialogue « Rich Text Format Rapport ».

Pour activer le filtre de date, cochez la case dans le champ « Date »·
Dans les deux premiers champs « Inclure uniquement les objets », cliquez sur les flèches déroulantes et sélectionnez·
les critères appropriés (Modifié/Créé, Avant/Après).

Le filtre de phase Paquetage s'applique au niveau Paquetage (et non au niveau de l'élément) et ignore la phase du·
Paquetage racine que vous documentez ; pour activer le filtre de phase, dans le champ 'Où Phase Paquetage ' cliquez
sur la flèche déroulante et sélectionnez un opérateur
Enterprise Architect filtre tous Paquetages qui ne répondent pas aux critères de sélection ; tous les éléments du
Paquetage sont ignorés, quelle que soit leur phase individuelle

Le filtre de statut d'élément vous permet de limiter la sortie par statut d'élément ; contrairement au filtre de phase·
Paquetage , ce filtre s'applique à chaque élément
Vous pouvez filtrer selon un statut similaire ou différent d'un critère, tel que « similaire à la proposition », ou selon
les opérateurs « dans » et « pas dans », tels que « dans approuvé », « pas dans validé » ; lorsque vous utilisez les
opérateurs « dans » et « pas dans », entrez une liste de types de statuts séparés par des virgules comme expression de
critères
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Exclure des éléments

À l'aide de la dialogue 'Rich Text Format Rapport ', vous pouvez exclure des éléments de tout type de votre sortie finale ;
ceci est utile lorsque vous souhaitez mettre en évidence des éléments particuliers et ne pas surcharger un rapport avec
trop de détails.

Pour faire ça:

Ouvrez la dialogue « Rich Text Format Rapport ».1.

Cliquez sur chaque élément à exclure, ou cliquez sur le bouton Tous pour exclure tous les éléments.2.

Cliquez sur le bouton Aucun pour effacer vos sélections.3.
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Format Diagramme RTF

Il est possible de générer diagrammes vers des fichiers Bitmap, des fichiers GIF ou des métafichiers Windows .

Pour faire ça:

Ouvrez la dialogue « Rich Text Format Rapport ».1.

Dans le panneau 'Format Diagramme ' (en bas au centre de le dialogue ) sélectionnez le format souhaité pour le2.
rapport.

Généralement, les deux options de métafichier (« EMF » et « WMF ») sont recommandées ; cependant, il y a des3.
moments où d’autres pourraient convenir.

(c) Sparx Systems 2023 Page  59 de 177 Créé avec Enterprise Architect



Génération de documents 2023-11-23

Inclure les éléments du modèle dans le rapport

Le panneau ' Modèle Include' de la dialogue 'Rich Text Format Rapport ' propose les options suivantes :

'Glossaire' pour inclure le Glossaire du Projet·
« Tâches » pour inclure les tâches du projet·
« Problèmes » pour inclure les problèmes du projet·

Cochez la case appropriée pour inclure les éléments dans la documentation RTF générée.
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Options Rapport RTF

Des options de rapport RTF supplémentaires que vous pouvez sélectionner dans le panneau « Options » de la boîte
dialogue « Rapport au format texte enrichi » sont affichées ici.

Vous pouvez choisir de documenter ou non de manière récursive Paquetages , d'afficher diagrammes ou d'ajouter un saut
de page avant chaque nouveau Paquetage . Sélectionnez le:

Case à cocher « Traiter tous les enfants » pour traiter de manière récursive tous Paquetages enfants dans le·
Paquetage principal

Case à cocher « Afficher Diagrammes » pour inclure diagrammes dans votre document ; effacer cet élément pour·
aucun diagrammes

Case à cocher 'Nouvelle page par paquetage ' pour forcer un saut de page sur chaque nouveau Paquetage (sauf·
Paquetages vides)

Case à cocher « Documenter tous les éléments » pour inclure tous les éléments inclus dans le projet·
Case à cocher 'Documenter Paquetages ' pour documenter le Paquetage en tant qu'élément en plus de la·
documentation qui serait normalement produite pour la documentation Paquetage

Case à cocher "Masquer les éléments sans notes" pour exclure de la documentation tous les éléments sans notes·
Case à cocher « Intégrer Diagrammes dans le document » pour garantir que les images diagramme sont contenues·
dans le document RTF plutôt que stockées dans un fichier externe lié.

Case à cocher 'Ignorer paquetage racine' pour exclure le Paquetage parent de la documentation et inclure uniquement·
les Paquetages enfants

Case à cocher « Document Linked Elements » pour inclure les détails object pour les éléments liés qui ne·
proviennent pas du Paquetage sélectionné.

La case « Utiliser les styles de titre pour les détails » pour garantir que les détails sont formatés en tant que styles de·
titre plutôt qu'en texte formaté ; cette option n'est disponible que lorsque le champ 'Style de titre' dans la section
'Principal' de la boîte de dialogue ' Rapport au format texte enrichi' est défini sur 'Max 9 niveaux - les éléments sont
Paquetage + 1'.
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Sélectionnez les sections du document

À l'aide de la section « Pour chaque Object inclus » de la dialogue « Rapport au format texte enrichi », vous pouvez
sélectionner les sections de documentation à inclure dans votre rapport.

Ce que vous incluez ou excluez détermine la simplicité ou le détail de votre rapport. Vous pouvez créer plusieurs rapports
à différents niveaux de détail pour différents publics. Expérimentez avec ces options pour voir quel effet l’inclusion ou
l’exclusion a. La plupart des éléments sont explicites.

Cocher la case en regard d'un élément de catégorie dans la liste sélectionne toutes les options contenues dans la
catégorie. Pour développer une catégorie, cliquez sur le symbole + à côté du nom de la catégorie. Pour exercer un
meilleur contrôle sur une catégorie d'options, développez l'élément de niveau supérieur, puis sélectionnez les éléments
individuels requis dans la liste.

Parfois, un élément s'applique uniquement à un certain type d'élément ; par exemple, ' Attributes ' ne s'applique qu'aux
éléments Class et à quelques autres types d'éléments. L'option ' Diagrammes enfants' affiche ou masque tous les
diagrammes attachés sous un élément de modèle ; par exemple, un cas d'utilisation peut être accompagné d'un
diagramme de scénario.

Notes

Utilisez cette fonctionnalité pour produire le bon niveau de détail pour votre public ; les lecteurs techniques·
pourraient vouloir tout voir, tandis que la direction pourrait n'exiger que les grandes lignes
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Paramètres de langue personnalisés

Si vous exportez des documents au format RTF depuis Enterprise Architect dans des langues autres que l'anglais, vous
pouvez personnaliser la page de codes, ID de langue par défaut et le jeu de caractères Enterprise Architect utilise lors de
la génération de RTF. Il est ainsi beaucoup plus facile de générer une documentation adaptée à votre pays ou à vos
paramètres régionaux.

Vous pouvez également configurer une liste de substitutions de mots. Par exemple, là où Enterprise Architect inclurait le
mot « Figure », vous pouvez spécifier un autre mot pour le remplacer, soit dans votre langue, soit plus significatif pour
vos lecteurs.

Configurer les remplacements

Étape Action

1 Ouvrez la dialogue « Rich Text Format Rapport ».

2 Dans le panneau 'Langue' (en bas à gauche de dialogue ), cliquez sur le bouton Ajuster.

La dialogue « Personnaliser le langage RTF » s'affiche.

3 Double-cliquez sur un élément pour définir ou effacer son mot de remplacement.

4 Lorsque vous avez terminé, cliquez sur le bouton OK .

Configurer la langue, la page de codes et le jeu de caractères

Étape Action

1 Dans les listes déroulantes des champs « Langue », « Page de code » et « Jeu de caractères », sélectionnez
la langue, la page de code et le jeu de caractères qui correspondent le mieux à votre emplacement.

2 Si nécessaire, modifiez les balises de remplacement en double-cliquant sur chacune d'elles et en
définissant manuellement la valeur (pour une utilisation avancée uniquement).

3 Pour effacer la liste de substitution, double-cliquez sur chaque élément tour à tour et supprimez la valeur
de substitution .

4 Lorsque vous avez terminé les réglages, cliquez sur le bouton OK pour les enregistrer.

Désormais, lorsque vous générez des documents RTF, les balises de remplacement sont utilisées dans la
sortie.

Notes

Si vous souhaitez générer des rapports dans une langue qui nécessite support d'Unicode, veuillez note que les·
fichiers .eap Enterprise Architect utilisent par défaut JET 3.5 comme moteur de base de données, qui ne prend pas
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support les jeux de caractères Unicode (voir la rubrique Démarrage ) ; pour fournir support Unicode dans votre
projet, effectuez une mise à niveau vers un référentiel SGBD ou définissez JET 4.0 comme moteur de base de
données et téléchargez une copie du modèle Jet 4.0 EABase à partir du site Web de Sparx Systems , puis effectuez
un transfert EAP vers EAP de votre modèle dans le fichier Jet 4.0

Vous pouvez transporter ces définitions de langage et de balises entre les modèles, à l'aide des options du ruban·
« Paramètres > Modèle > Transférer > Exporter les données de référence » et « Importer les données de référence ».
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Générer le Rapport

Une fois que vous avez configuré les propriétés du document comme requis, cliquez sur le bouton Générer pour générer
le rapport.

Lorsque vous avez généré le document, cliquez sur le bouton Vue pour ouvrir le rapport dans MS Word TM .
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Enregistrer en tant que document

La fonctionnalité Document permet de « mémoriser » une configuration de documentation particulière, reliant le gabarit
chargé dans la dialogue « Rapport » au Paquetage actuellement mis en surbrillance. Si un gabarit particulier est toujours
utilisé avec un Paquetage spécifique et que plusieurs cas de documentation existent pour être propagés, les enregistrer
sous Documents peut faciliter la génération de documents ultérieurement.

Créer et utiliser des documents

Étape Action

1 Ouvrez la dialogue « Rich Text Format Rapport ».

2 Cliquez sur le bouton Enregistrer en tant que document.

La dialogue « Enregistrer le document actuel en tant que définition de document » s'affiche.

3 Dans le champ « Entrer une valeur », saisissez un nom pour le document et cliquez sur le bouton OK . Le
document est ajouté à l'onglet « Ressources » de la fenêtre Navigateur pour un accès ultérieur facile.

4 Pour générer de la documentation à partir de l'onglet 'Ressources' de la fenêtre Navigateur , cliquez-droit
sur le document souhaité.

Le menu contextuel s'affiche.

5 Sélectionnez l’option de menu contextuel requise.

Ouvrir le document - Ouvre le fichier de document correspondant, comme spécifié par la propriété·
'Filename' gabarit

Générer Document - Ouvre la dialogue ' Rapport ', chargée avec le gabarit spécifié·
Auto Générer Document - Génère de la documentation, avec le document situé au chemin spécifié par·
la propriété 'Filename' du gabarit

Supprimer le document - Supprime le document spécifié·
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Utiliser Microsoft Word

Lorsque vous générez des rapports avec l'ancien Rapport Generator, vous pouvez utiliser Microsoft Word TM pour
incorporer facilement fonctionnalités supplémentaires dans les rapports. Tu peux:

Créez un document maître personnalisé combinant des rapports distincts, pour ajouter un tableau commun des·
contenus, tableau des figures, des en-têtes et des pieds de page.

Créez des documents avec des liens durables vers des « éléments » générés de la sortie Enterprise Architect ,·
pré-divisés à l'aide de signets et mis à jour automatiquement à l'ouverture du document.

Ouvrir un rapport dans Word·
Changer les images liées en images intégrées·

Notes

Avec le générateur Rapport de documents « amélioré » plus récent, de nombreuses facilités fournies par Word ont·
été incorporées dans le générateur ou rendues inutiles ; il est donc probable que vous n'aurez pas besoin d'utiliser
Word pour générer vos rapports - vous pouvez utiliser des documents virtuels, par exemple, au lieu de documents
maîtres Word et de signets.

Ces rubriques sur l'utilisation de Word sont donc incluses uniquement pour support les utilisateurs qui travaillent·
encore avec le générateur Rapport « hérité » ou qui utilisent Word pour leurs préférences personnelles.

Lorsque vous développez un rapport à l'aide de Word avec Enterprise Architect , laissez la définition des styles de·
section dans l'éditeur aux dernières étapes juste avant la génération du rapport ; Word tronque les signets de section,
car il utilise une longueur de champ plus petite pour les sections

Dans Word, vous pouvez révision et modifier les rapports générés par Enterprise Architect , mais vous ne pouvez pas·
les réimporter dans Enterprise Architect sans endommager la définition du style de section.
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Ouvrir un Rapport dans Microsoft Word

Si vous souhaitez utiliser Microsoft Word TM pour ouvrir un fichier de document généré dans Enterprise Architect ,
chargez simplement Word et ouvrez le fichier comme un document normal. Word convertit le fichier pour l'afficher.

Si Word est votre gestionnaire de fichiers de documents par défaut, vous pouvez également charger et afficher le rapport
de l'une des manières suivantes :

Double-cliquez sur le fichier de sortie, ou·
En cliquant sur le bouton Vue de la dialogue ' Générer Documentation'·
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Changer les images liées en images intégrées

L'une des options disponibles lors de la génération de rapports de document consiste à intégrer des images dans le
document, au lieu d'incorporer des liens vers les fichiers image. Vous intégrerez des images si vous souhaitez que le
document soit portable (séparé du répertoire contenant les fichiers image), mais utiliserez des liens vers les fichiers
image si vous souhaitez mettre à jour les images sans régénérer le document. Vous seriez plus susceptible d'établir des
liens vers des fichiers image lors du développement du modèle et de la documentation, et plus susceptible d'incorporer
des images lorsque le document serait prêt à être révision ou utilisé.

Si vous avez généré le rapport de document avec des images liées et importé le document dans Word TM et que vous
souhaitez distribuer ce document, vous pouvez convertir les liens de fichiers en images incorporées sans avoir à revenir à
Enterprise Architect pour régénérer le document avec des images incorporées. .

Rompre les liens d'images dans Word

Étape Action

1 Ouvrez le document requis dans Word.

2 Sélectionnez l'option 'Modifier | Option de menu Liens.

3 Mettez en surbrillance tous les liens dans la liste Liens.

4 Cochez la case « Enregistrer l'image dans le document ».

5 Cliquez sur le bouton Rompre le lien.

6 Lorsque vous y êtes invité, cliquez sur le bouton Oui pour rompre les liens.

Word rompt les liens et enregistre des copies des images à l'intérieur du document.
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Signets de documents

Si vous souhaitez créer un document complexe composé de sections d'un ou de plusieurs rapports de document, plutôt
que d'un rapport complet, vous pouvez créer un document maître dans Microsoft Word TM et y créer des liens vers les
sections du rapport à l'aide de leurs signets. Les signets sont des numéros basés sur GUID qui sont automatiquement
créés pour Paquetages , diagrammes et les éléments, et placés dans un document lors de sa génération. Chaque object est
marqué dans le document selon ces règles :

Tous les caractères alphabétiques et numériques restent les mêmes·
Tous les autres caractères (y compris les espaces) sont convertis en traits de soulignement·

Par exemple UC01 : Use Case Modèle devient UC01__Use_Case_Model. Un signet Paquetage s'applique du début à la
fin d'un Paquetage et inclut tous Paquetages enfants et les éléments situés en dessous. Vous pouvez également attribuer
manuellement des signets si vous souhaitez avoir des références à des subdivisions supplémentaires d'un modèle ou d'un
document. Si vous modifiez votre modèle et régénérez votre rapport de document, vous pouvez simplement actualiser les
liens dans le document maître dans Word pour mettre à jour automatiquement le document Word.

Lorsque vous utilisez des signets pour ajouter des sections d'un rapport généré à un document maître Word, vous
travaillez avec Word et la fenêtre Enterprise Architect Navigateur s'ouvre en même temps.

Ajouter une section marquée d'un signet d'un document RTF à un document Word

Étape Action

1 Dans le fichier Word, positionnez le curseur à l'endroit où insérer la section du document.

2 Sélectionnez le mot « Insérer | Option de menu Fichier.

La dialogue « Insérer un fichier » s'affiche.

3 Recherchez et sélectionnez le fichier de document à insérer, puis cliquez sur le bouton Plage.

4 Dans la fenêtre Enterprise Architect Navigateur , cliquez-droit sur le Paquetage , diagramme ou élément à
inclure dans la documentation.

Le menu contextuel s'affiche.

5 Pour coller le signet de object dans le presse-papiers, sélectionnez l'option de menu :

Copier/Coller | Copier la documentation·

6 Dans Word, dans la cellule « Plage » de la boîte dialogue « Insérer un fichier », appuyez sur Ctrl+V pour
coller les informations du presse-papiers.

7 Cliquez sur le bouton OK .

8 Cliquez sur la flèche déroulante à côté du bouton Insérer. Un petit menu s'affiche contenant deux options :

Insérer - intègre une copie permanente du texte·
Insérer en tant que lien - crée un lien qui peut être mis à jour si vous modifiez le document source·

Sélectionnez l'option « Insérer en tant que lien ».

9 Répétez les étapes 1 à 8 pour chaque section de chaque document que vous souhaitez inclure dans le
document Word.

dix Sélectionnez les « Outils Word | Option de menu Options et, dans la dialogue "Options", sélectionnez
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l'onglet "Général" et cochez la case "Mettre à jour les liens automatiques à l'ouverture".

Chaque fois que le document Word est ouvert, les liens vers les sections du document seront
automatiquement mis à jour avec toutes les modifications apportées aux documents générés.

Notes

Vous ne pouvez pas utiliser le Bookmarking dans les éléments Rapport Paquetage , qui remplacent efficacement le·
Bookmarking dans Word.
La création de signets nécessite que chaque signet soit unique ; lorsque vous générez un rapport avec un gabarit
standard (y compris dans un seul élément Modèle Document), chaque signet est unique et il existe une association
1:1 entre les détails de l'élément généré et les éléments du référentiel
Comme Rapport Paquetages sont destinés à contenir plusieurs sous-documents, l'association cesse d'être 1:1 ; il
n'existe pas de méthode simple permettant d'identifier de manière unique les données générées directement en
association avec l'élément d'origine
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Fonctionnalités de Word

Une fois que vous avez généré des rapports dans le générateur de rapports « hérité » Enterprise Architect , vous pouvez
les ouvrir dans Microsoft Word TM pour améliorer la sortie de la documentation de votre projet. Certaines des choses que
vous pourriez faire incluent :

Ajouter un tableau des matières·
Ajouter un tableau de chiffres·
Ajouter des en-têtes et des pieds de page·
Manipuler les tableaux du rapport·
Définir une option pour actualiser automatiquement les fichiers liés·
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Ajouter Tableau des matières

Parmi les fonctionnalités de Microsoft Word TM qui peuvent être incorporées dans les rapports de documents Enterprise
Architect générés figure un Tableau des matières, qui peut être utilisé pour faciliter la navigation dans la documentation
et en améliorer la lisibilité. Le Tableau des matières fournit des hyperliens vers les diagrammes dans la version
électronique de la documentation et des numéros de page dans les versions imprimée et électronique de la
documentation.

Inclure Tableau des matières dans le document

Étape Action

1 Dans Word, ouvrez le rapport auquel ajouter un Tableau des matières.

2 Sélectionnez l'option 'Insérer | Référence | Option de menu Index et Tableaux .

3 Cliquez sur l'onglet « Tableau des matières » pour définir les options disponibles pour la configuration du
Tableau des matières.

Notes

Le format du Tableau des matières dépend des niveaux de titres créés lors de la génération du document ; pour·
définir les styles de titre dans le document, consultez la rubrique Options Rapport RTF
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Ajouter Tableau de figures

Parmi les fonctionnalités de Microsoft Word TM qui peuvent être incorporées dans les rapports Enterprise Architect
générés figure un Tableau de figures, qui peut être utilisé pour faciliter la navigation dans la documentation et améliorer
la lisibilité. Le Tableau des figures fournit des hyperliens vers les diagrammes dans la version électronique de la
documentation et des numéros de page dans les versions imprimée et électronique de la documentation.

Inclure Tableau des figures dans le document

Étape Action

1 Dans Word, ouvrez le rapport auquel ajouter un tableau de chiffres.

2 Sélectionnez l'option 'Insérer | Référence | Option de menu Index et Tableaux .

3 Cliquez sur l'onglet ' Tableau des figures' pour paramétrer les options disponibles pour configurer le
tableau des figures.
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Ajouter des en-têtes et des pieds de page

Parmi les fonctionnalités de Microsoft Word TM qui peuvent être incorporées dans les rapports de documents Enterprise
Architect générés figurent les en-têtes et les pieds de page.

Inclure les en-têtes et les pieds de page dans le rapport du document

Étape Action

1 Dans Word, ouvrez le rapport auquel ajouter des en-têtes et des pieds de page.

2 Sélectionnez le ' Vue | Option de menu En-tête et pied de page et entrez les informations appropriées dans
la section d'en-tête et de pied de page du document.
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Manipuler Tableaux dans Word

Dans les rapports de documents générés à partir du générateur de rapports Legacy dans Enterprise Architect , tableaux
sont inclus lorsque des éléments tels que des attributs et des méthodes sont sélectionnés dans la section « Pour chaque
Object » de la dialogue « Rapport au format texte enrichi ». Microsoft Word TM offre plusieurs niveaux de
personnalisation des tableaux et peut être utilisé pour améliorer le formatage des tableaux dans les situations où les
marges du tableau dépassent les dimensions de la taille de page sélectionnée pour l'impression dans Word.

Redimensionner manuellement le tableau

Lorsque la quantité de détails d'un élément documenté, tel qu'un attribut ou une opération, dépasse les marges de la page
dans Word, vous pouvez redimensionner manuellement le tableau afin d'afficher tous les détails.

Étape Action

1 Sélectionnez le tableau qui dépasse la taille de la marge.

2 Passez la souris sur la bordure du tableau jusqu'à ce que le pointeur de la souris se transforme en icône «
glisser », comme indiqué.

3 Faites glisser le curseur vers la gauche pour réduire la largeur du tableau , puis sélectionnez l'option de
menu 'Document-Edit > File > File > Aperçu Impression ' pour confirmer que les bordures du tableau se
trouvent dans les marges de la page.

4 Redimensionnez tous les tableaux qui dépassent des marges de la page, en suivant les étapes 1 à 3.

Appliquer des styles aux tableaux

L'une des propriétés personnalisables de Word lorsque vous travaillez avec tableaux est la possibilité d'appliquer un style
à un tableau , afin que vous puissiez rapidement modifier l'apparence du tableau .

Étape Action

1 Dans Word, ouvrez le rapport dans lequel modifier les styles tableau .

2 Localisez et sélectionnez le tableau dont vous souhaitez ajuster l’apparence.

3 Sélectionnez le ' Tableau | Option de menu Format automatique Tableau .

La dialogue « Tableau Autoformat » s'affiche.
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À partir de là, vous pouvez spécifier un style tableau prédéfini dans la liste des styles Tableau ou créer un
nouveau style en cliquant sur le bouton Nouveau. Les styles tableau définis dans la dialogue « Tableau
Autoformat » ne s'appliquent qu'à un tableau à la fois, vous devez donc appliquer le style à chaque tableau
individuellement.
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Actualiser les liens

Si vous créez un lien vers des rapports générés dans Enterprise Architect , vous pouvez définir une option dans le
document maître Microsoft Word TM afin que chaque fois que le document est ouvert, les liens soient actualisés et - si les
rapports ont changé - le texte lié soit automatiquement mis à jour.

Accéder

MS Word Outils | Options > Général

Actualiser le texte du rapport lié

Étape Action

1 Cochez la case « Mettre à jour les liens automatiques à l'ouverture ».

2 Cliquez sur le bouton OK .
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Tout sur Gabarits de documents

Vous utilisez gabarits de rapport pour générer des rapports sur votre modèle qui présentent des informations spécifiques
dans un format particulier, et pour générer ces rapports de manière répétée et cohérente. Vous pouvez sélectionner parmi
une gamme de gabarits système sur le générateur de documents, pour générer immédiatement des rapports à partir de
votre modèle.

Un gabarit se compose de :

« Sections » qui identifient les composants du modèle sur lesquels faire rapport·
Champs qui identifient le type d'informations à extraire sur chaque composant·
Styles et instructions de formatage qui définissent la disposition du rapport·
Fragments Gabarit contenant des sous-modèles plus petits·

Le système fournit gabarits de documents plus spécialisés pour des pages de couverture, des feuilles de style et Tableaux
des matières distincts.

Vous pouvez également concevoir vos propres gabarits personnalisés, qui offrent l'avantage supplémentaire de pouvoir
générer des rapports adaptés à votre propre organisation et de mettre à jour certains aspects du rapport sans avoir à
redéfinir toutes les autres spécifications. Le générateur de rapports vous aide à gérer ces gabarits personnalisés ;
c'est-à-dire:

Révision des gabarits personnalisés mis à votre disposition pour générer des rapports·
Créer gabarits personnalisés supplémentaires·
Modifier gabarits personnalisés·
Importez gabarits enregistrés dans des fichiers XML, et·
Supprimez tous gabarits personnalisés qui ne sont plus nécessaires·

Accéder

Ruban Publier > Rapports de Modèle > Gabarits

Raccourcis Clavier F8 | Gabarits

Gérez vos Gabarits personnalisés

Champ/Bouton Description

Gabarits personnalisés Répertorie les Gabarits , Fragments, Feuilles de style, Pages de garde et Tableaux
des matières personnalisés actuellement disponibles pour générer des rapports via
l'onglet ' Générer '.

Vos gabarits personnalisés peuvent être regroupés dans ces dossiers standards (par
Type Gabarit ), ou dans un autre dossier que vous avez créé pour contenir gabarits
spécifiques.

Nouveau Pour créer un nouveau gabarit personnalisé, cliquez sur ce bouton. La dialogue
'Nouveau document Gabarit ' s'affiche.

Dans le champ 'Nouveau gabarit ', saisissez le nom gabarit .

Dans le champ ' Type Gabarit ', cliquez sur la flèche déroulante et sélectionnez le
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type de gabarit à créer.

Dans le champ 'Copier Gabarit ', cliquez sur la flèche déroulante et sélectionnez
soit :

'Aucun', pour créer un gabarit vide à développer à partir de zéro, ou·
Le nom d'un système existant, d'une technologie ou d' gabarit personnalisé·
pour servir de base ; cette liste est filtrée pour afficher gabarits du type que
vous avez spécifié dans le champ ' Type Gabarit '

Dans le champ 'Groupe Gabarit ' soit :

Sélectionnez un groupe existant ou·
Entrez le nom d'un nouveau groupe gabarit , ou·
Laissez ce champ vide, pour placer le gabarit dans le groupe de type standard·
approprié

Le 'Groupe Gabarit ' détermine l'organisation des gabarits des documents dans
l'onglet 'Ressources' de la fenêtre Navigateur . Vous ne pouvez pas créer un gabarit
d'un type spécifique et l'affecter au groupe standard d'un type différent. Par
exemple, vous ne pouvez pas spécifier un fragment et choisir de l'enregistrer dans le
dossier Page de couverture. Soit il est dirigé vers un groupe créé par l'utilisateur que
vous sélectionnez, soit il est automatiquement redirigé vers le dossier Fragment.

Cliquez sur le bouton OK ; le gabarit s'ouvre dans le 'Document Gabarit Designer'.

Modifier Pour apporter des modifications à un gabarit existant, cliquez sur le nom gabarit
puis cliquez sur ce bouton.

Le gabarit s'ouvre dans le 'Document Gabarit Designer'.

Importer à partir du fichier
de référence

Pour importer gabarits personnalisés préalablement enregistrés dans des fichiers
XML batch (c'est-à-dire via l'option « Exporter les données de référence »), cliquez
sur ce bouton. La dialogue « Importer des données de référence » s'affiche.

Cliquez sur le bouton Sélectionner un fichier, recherchez et sélectionnez le fichier
XML source requis.

Dans le panneau « Sélectionner les ensembles de données à importer », cliquez sur
les ensembles de données requis :

Gabarits de documents RTF·
Gabarits - Détail du style RTF·
Gabarits - Options de balises et de langues RTF·

Cliquez sur le bouton Importer pour importer les gabarits . Les noms des gabarits
importés sont ajoutés à la liste sur l'onglet ' Gabarits '.

Si le gabarit que vous souhaitez importer est un fichier externe unique (pas dans un
fichier batch), vous pouvez à la place ouvrir un gabarit et utiliser une option
différente pour importer le fichier dans ce gabarit .

Supprimer Pour supprimer un gabarit personnalisé, cliquez sur le nom gabarit et cliquez sur le
bouton Supprimer.

Une prompt s'affiche pour confirmer la suppression.

Vous pouvez sélectionner plusieurs gabarits personnalisés à supprimer ; appuyez
sur Ctrl ou Shift pendant que vous cliquez sur le nom de chaque gabarit .

Notes

Dans les éditions Corporate , Unified et Ultimate d' Enterprise Architect , si la sécurité est activée, vous avez besoin·
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de l'autorisation d'accès « Configurer les ressources » pour créer gabarits de document.

Quel que soit gabarit que vous sélectionnez initialement dans l'onglet ' Gabarit ' ou dans dialogue ' Nouveau·
document Gabarit ', quel que soit le type et/ou le groupe de gabarit , vous pouvez facilement passer à un gabarit et un
type gabarit différents dans l'' Éditeur de document Gabarit ' chaque fois que vous en avez besoin.
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Document Personnalisé de conception Gabarits
personnalisés

Si vous souhaitez enregistrer et documenter les détails de votre modèle, vous pouvez le faire à l'aide d'une gamme de
rapports de documents, chacun généré à l'aide d'un gabarit de document. Pour répondre à vos besoins spécifiques, il est
possible de personnaliser les rapports en développant vos propres gabarits ; au cours de ce processus, vous avez
également la possibilité de générer des rapports de test pour révision le résultat de votre conception au fur et à mesure
que vous la développez. Les gabarits personnalisés que vous pouvez développer incluent gabarits de documents complets
et des feuilles de style, des pages de couverture et Tableaux des matières indépendants.

Vous créez et modifiez gabarits de rapport à l'aide de Document Gabarit Designer pour définir :

Les composants du modèle sur lesquels faire rapport·
Les informations à extraire sur chaque composant et·
Les styles et disposition du rapport·

Il est possible de créer un gabarit à partir de zéro ou en copiant et en modifiant soit un autre gabarit personnalisé, soit un
gabarit système. Si vous souhaitez révision les gabarits du système, vous pouvez les lister et les afficher à l'aide du
Document Gabarit Designer, et établir quels gabarits existent déjà pour soit extraire les informations dont vous avez
besoin, soit servir de point de départ pour votre propre conception.

Accéder

Lorsque vous ouvrez un gabarit dans Document Gabarit Designer, le ruban Document - Modifier s'ouvre également
automatiquement.

Ruban Publier > Rapports de Modèle > Gabarits

Autre Onglet 'Ressources' de la fenêtre Navigateur | Publication de documents | Système
Gabarits | < groupe gabarit > : cliquez-droit sur un gabarit | Copie

Onglet 'Ressources' de la fenêtre Navigateur | Publication de documents | Gabarits
personnalisés | < groupe gabarit > : cliquez-droit sur un gabarit | Ouvrir

Le concepteur de documents Gabarit

Le Document Gabarit Designer se compose de :

Une barre d'outils, à travers laquelle vous créez ou sélectionnez un gabarit sur lequel travailler, enregistrez votre·
travail, générez et visualisez les rapports de test

Un panneau « Sections », sur lequel vous sélectionnez les composants du modèle sur lesquels créer un rapport·
Un panneau « Contenu », dans lequel vous développez le contenu et disposition du rapport, à l'aide d'une large·
gamme d'options de menu contextuel

Options barre d'outils

Icône Action
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Crée un nouveau gabarit .

Une prompt s'affiche pour vous demander de saisir le nom du nouveau gabarit et,
éventuellement, le nom d'un gabarit existant à utiliser comme base.

Enregistre les modifications apportées au gabarit actuel.

Enregistre le gabarit actuel en tant que nouveau gabarit .

Une prompt s'affiche pour le nouveau nom gabarit .

Affiche une gamme d'options de document que vous pouvez définir pour
s'appliquer à tous les rapports générés à l'aide du gabarit . Ces options filtrent et
organisent les informations présentées dans le rapport.

Ouvre l'onglet 'Ressources' de la fenêtre Navigateur et/ou du dossier contenant le
gabarit du document actuellement affiché et met en surbrillance le nom du gabarit .

Bascule la vue Générateur de documents entre l'affichage du panneau de hiérarchie
des sections et son masquage.

Affiche le nom du groupe Gabarit dans lequel localiser ou enregistrer le gabarit ; la
valeur par défaut est ' Modèle Gabarits '.

Cliquez sur la flèche déroulante et sélectionnez le nom du groupe Gabarit approprié
dans lequel effectuer la recherche. Cela filtre les options du champ suivant sur
gabarits de ce groupe uniquement. Par exemple, Pages de couverture ou « DavidG
Rapports ».

Affiche une liste des gabarits du groupe Gabarit que vous avez spécifié dans le
champ précédent. Pour afficher ou modifier un gabarit existant, cliquez sur la flèche
déroulante et sélectionnez le nom gabarit .

Les gabarits du système sont protégés ; lorsque vous en sélectionnez une,·
toutes les options d'édition sont grisées

gabarits personnalisés sont disponibles pour modification·

Affiche le chemin et le nom du fichier dans lequel générer le rapport de test à partir
du gabarit .

Si aucun chemin de fichier n'est affiché, vous pouvez soit en saisir un, soit utiliser

le bouton  .

Affiche la dialogue ' Navigateur ', dans laquelle vous pouvez localiser et
sélectionner le fichier pour contenir le rapport de test généré.

Génère et affiche le rapport de test basé sur le gabarit .

Pour générer un rapport de test, vous devez spécifier un fichier cible et sélectionner
un Paquetage , diagramme ou un élément dans la fenêtre Navigateur sur lequel
exécuter le rapport. Vous pouvez développer un Paquetage de test spécial à cet
effet.

Affiche le rapport contenu dans le fichier spécifié dans le champ Chemin du fichier.

Vous pouvez revenir plusieurs fois à un rapport généré pendant que vous révision
les effets des différentes sections du gabarit que vous modifiez.
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Les sections et les panneaux de contenu

Facilité Description

Panneau Sections Se compose d'une hiérarchie de composants de modèle et de leurs propriétés,
chacun avec une case à cocher. Pour inclure des informations sur un type de
composant dans le rapport, vous cochez la case correspondante.

Lorsque vous cochez des cases, les paires correspondantes de marqueurs
d'ouverture/fermeture s'affichent dans le panneau « Contenu » ; Par exemple:

Panneau Sections

Panneau de contenu

Panneau de contenu La zone d'édition, dans laquelle vous développez la structure et le contenu du
gabarit .

Au fur et à mesure que vous ajoutez des marqueurs de section au gabarit , du texte
contenant des astuces est automatiquement ajouté pour fournir guidage entre les
marqueurs, tels que :

Remplacez le texte de l'indice par une série de champs (qui extraient les
informations de votre modèle) et du texte statique saisi manuellement.

Modification du gabarit La plupart du travail que vous effectuez pour créer et mettre à jour un gabarit de
document est accompli en utilisant les facilités du ruban « Document - Modifier »,
qui s'affiche automatiquement lorsque vous ouvrez le Document Gabarit Designer.
Pour guidage sur l'utilisation de ces facilités , vous pouvez vous référer soit à :

Document - Ruban d'Éditer , qui décrit directement les facilités , ou·
Editing Documents and Gabarits , qui décrit les facilités d'édition de·
documents dans Enterprise Architect

Options de conception Gabarit personnalisées , qui identifient les tâches·
d'édition que vous souhaiterez peut-être effectuer et vous dirigent vers les
facilités d'exécution de ces tâches.

Menu Contexte du panneau
de contenu

Si vous cliquez-droit sur le texte du marqueur de champ ou sur l'arrière-plan du
panneau « Contenu », un menu contextuel s'affiche, offrant un certain nombre
d'options supplémentaires pour :

Insérez un champ sélectionné dans la liste affichée, où les entrées sont·
spécifiques au marqueur de section que vous avez sélectionné - vous devez
également supprimer l' prompt texte entre les marqueurs de section ; lorsque le
rapport est généré, les noms des champs sont remplacés par les valeurs
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correspondantes du modèle

Insérez une constante de projet sélectionnée parmi celles que vous avez·
définies dans l'onglet 'Constantes du projet' de la dialogue ' Générer
Documentation'

Insérez une constante Rapport sélectionnée dans la liste standard ; ces·
constantes dérivent des valeurs des propriétés d'élément et Paquetage

Mettez à jour la feuille de style utilisée dans le gabarit par l'une de celles·
répertoriées dans le sous-menu, fournie par le système ou personnalisée par
l'utilisateur ; Vous pouvez également passer d'une feuille de style personnalisée
à la feuille de style Normal.rtf standard.

Masquer ou afficher le panneau « Sections », soit en fournissant guidage sur les·
sections à ajouter, soit en donnant plus d'espace pour développer le contenu du
rapport.

Couper ou copier le texte sélectionné et coller le texte contenu dans le·
presse-papiers dans une nouvelle position

Annuler une modification - ou une série de modifications - que vous avez·
effectuée, dans l'ordre inverse, ou refaites les modifications annulées si
nécessaire.

Notes

Un fichier standard de styles de document globaux, appelé Normal.rtf, est automatiquement appliqué à tous les·
nouveaux gabarits que vous créez à partir de zéro ; il est possible d'éditer Normal.rtf pour adapter les styles à vos
besoins et de remplacer ces styles dans le gabarit

Vous pouvez également créer Tableaux des matières et des pages de couverture personnalisés spéciaux à utiliser en·
option sur n'importe quel rapport de document à la place des pages de couverture ou Tableaux des matières intégrés
aux gabarits du rapport, ainsi que des feuilles de style qui peuvent être choisies pour remplacer les styles Normal.rtf
ou tous les styles modifiés dans un gabarit de rapport

Vous pouvez transporter gabarits entre les modèles, en utilisant les options du ruban « Paramètres > Modèle >·
Transférer > Exporter les données de référence » et « Importer les données de référence ».
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Définition des sections pour Rapportage

Dans le cadre de la conception ou de l'édition d'un gabarit pour générer un rapport documentaire, vous définissez le
contenu à livrer dans votre rapport, notamment :

Sur quelles fonctionnalités du modèle rendre compte (telles que les éléments, les attributs, les documents liés et·
Valeur Étiquetés ), à l'aide du panneau « Sections » du Document Gabarit Designer

Quelles informations fournir sur les instances de chaque fonctionnalité (telles que le nom, le type, la phase, la·
priorité ou l'auteur), à l'aide du panneau 'Contenu' du Document Gabarit Designer

Les informations que vous définissez ici déterminent la structure du rapport, les sections qu'il contient et l'ordre de ces
sections.

Accéder

Ruban Publier > Rapports de Modèle > Gabarits > Sections

Publier > Rapports de Modèle > Gabarits > Contenu

Autre Onglet 'Ressources' de la fenêtre Navigateur | Publication de documents | Gabarits
personnalisés | < gabarit type> : cliquez-droit sur un gabarit | Ouvrir > Sections

Onglet 'Ressources' de la fenêtre Navigateur | Publication de documents | Gabarits
personnalisés | < gabarit type> : cliquez-droit sur un gabarit | Ouvrir > Contenu

Sélectionnez les composants du modèle à documenter dans le rapport

Étape Action

1 Développez une partie ou la totalité de la hiérarchie dans le panneau « Sections ».

2 Cochez la case à côté du nom de la fonctionnalité ; le nom de la fonctionnalité est ensuite affiché sous la
forme d'une paire de balises de section dans le panneau « Contenu » du Document Gabarit Designer.

élément >

< élément

Pour fonctionnalités des niveaux inférieurs de la hiérarchie, la sélection d'une fonctionnalité enfant
sélectionne automatiquement le(s) niveau(s) parent(s) et ajoute les balises parents au panneau
« Contenu ».

3 Si vous souhaitez modifier la séquence des sections, cliquez sur le nom fonctionnalité appropriée dans la

hiérarchie « Sections » et cliquez sur  ou  pour déplacer le nom fonctionnalité vers le haut ou vers
le bas.

La position du nom de la fonctionnalité dans la hiérarchie des « Sections » détermine la position de la
section documentant cette fonctionnalité dans le panneau « Contenu », et donc dans le rapport. Vous
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pouvez modifier la séquence avant ou après avoir coché les cases, cela ne fait aucune différence.

4 Pour chaque fonctionnalité sélectionnée, cliquez entre les balises de section dans le panneau 'Contenu' et
ajoutez du texte, ou cliquez-droit et sélectionnez l'option 'Insérer des champs' pour ajouter des champs.

Notes

guidage plus spécifique est fourni pour sélectionner ces fonctionnalités :·
- Objets enfants
- Éléments intégrés
- Matrices de relations profilées
- Contraintes et scénarios
- Documents liés et contenu d'artefacts de documents
- Éléments détenus dans Paquetages externes
- Valeur Étiquetés
- Sections formatées sous forme tableaux
- Utilisation de la section personnalisée pour les fragments Query personnalisés
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Objets enfants

Un object de votre modèle peut avoir des objets subordonnés : par exemple, les éléments ont diagrammes enfants et
d'autres éléments ; Paquetages contiennent d'autres Paquetages , éléments et diagrammes ; et diagrammes contiennent
des éléments et des connecteurs. Lorsque vous configurez gabarit de votre rapport de document pour créer un rapport sur
ces objets subordonnés, vous pouvez :

Générer uniquement les informations que vous spécifiez dans les champs sélectionnés, comme le nom object·
uniquement ; par exemple, les détails des éléments peuvent être extraits à plusieurs endroits - éléments Paquetage ,
éléments intégrés, éléments source et cible sur les connecteurs, éléments enfants - et vous n'aurez peut-être pas
besoin de tous les détails dans toutes les sections de votre rapport, vous devrez donc simplement définir un champ
pour le nom de l'élément dans certaines sections

Alternativement

Générer le même type d'informations que celui fourni pour les objets de niveau parent de ce type, en ne définissant·
aucun contenu (texte ou champs) entre les balises de section ; par exemple, vous pouvez générer une documentation
récursive des Paquetages enfants, obtenant le même niveau de détail que pour le Paquetage parent.

Accéder

Ruban Publier > Rapports de Modèle > Gabarits > Sections

Publier > Rapports de Modèle > Gabarits > Contenu

Autre Onglet 'Ressources' de la fenêtre Navigateur | Publication de documents | Gabarits
personnalisés | < gabarit type> : cliquez-droit sur un gabarit | Ouvrir > Sections

Onglet 'Ressources' de la fenêtre Navigateur | Publication de documents | Gabarits
personnalisés | < gabarit type> : cliquez-droit sur un gabarit | Ouvrir > Contenu

Exemples de rapports sur les objets enfants

Exemple Détail

Détails object spécifique Ce gabarit a un contenu valide (texte et champ 'Element.Name') entre les balises de
l'élément enfant. Par conséquent, dans le rapport généré, la section de l'élément
enfant affichera uniquement le nom de l'élément et aucun des détails affichés pour
l'élément parent.
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Par défaut, les détails au
niveau parent

Ce gabarit n'a pas de contenu valide entre les balises des éléments enfants. Par
conséquent, dans le rapport généré, la section de l'élément enfant affichera par
défaut les détails affichés pour l'élément parent.

Détails parent par défaut
pour les objets enfants

Paquetage > Élément > Élément enfant - Paquetage > Élément·
Paquetage > Elément > Diagramme - Paquetage > Diagramme·
Paquetage > Diagramme > Élément - Paquetage > Élément·
Paquetage > Diagramme > Connecteur - Paquetage > Elément > Connecteur·

Notes

En principe, il est préférable de laisser les sections enfants vides pour répliquer leurs sections parents.·

Les sections enfants ne contiennent pas les mêmes détails de sous-section que leurs parents ; Element::Child
Element ne contient pas de sous-sections telles que Scénario ou Attribut, donc là où les sections Child Element sont
remplies, ces sous-sections ne sont pas rendues

Une exception à cette règle concerne les cas où les sous-sections ne sont pas obligatoires, mais où un formatage
différent des champs de section est préféré.
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Rapport sur les éléments structurels

Dans le cadre de votre modèle, vous avez peut-être créé des éléments structurels sur un élément, tels que :

Paramètre d'activité·
Interface requise·
ActionPin·
Port·
Point d'accès·
Nœud d'expansion·
NœudObjet·
Interface fournie·
Point de sortie·
Partie·

Lorsque vous concevez un gabarit de rapport de document, vous pouvez ajouter une section pour identifier et rendre
compte spécifiquement de ces éléments structurels.

Accéder

Ruban Publier > Rapports de Modèle > Gabarits > Sections

Autre Onglet 'Ressources' de la fenêtre Navigateur | Publication de documents | Gabarits
personnalisés | < gabarit type> : cliquez-droit sur un gabarit | Ouvrir > Sections

Ajouter une section pour créer un rapport sur les éléments structurels d'un élément

Action Détail

Ajouter une rubrique Cochez la case « Paquetage > Élément > Éléments intégrés ». Les marqueurs de
section des éléments incorporés sont ajoutés au gabarit :

éléments incorporés >

<éléments intégrés

Lorsque le rapport est généré à partir du gabarit , tous les éléments structurels sont
répertoriés avec leur élément parent.

Notes

La section « Éléments intégrés » ne contient pas les mêmes sous-sections que la section parent « Élément », telles·
que Scénario ou Attribut ; si vous ne définissez pas de champs dans la section « Éléments intégrés », les mêmes
détails s'affichent par défaut que dans la section « Élément », tandis que si vous ajoutez des champs, seules les
valeurs de ces champs sont affichées.
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Matrices de relations profilées Rapportage

Lorsque vous utilisez la Matrice de relations, vous recherchez des combinaisons de Paquetages source et cible, de types
d'éléments, de type de connecteur et de direction du connecteur. Vous pouvez enregistrer vos combinaisons fréquemment
utilisées sous forme de profils et inclure les résultats de l'utilisation de ces profils dans votre rapport de document en
configurant une section dans le gabarit du rapport.

Si vous avez configuré des profils matriciels directement dans la Matrice de relation, vous ne spécifiez pas directement
un profil matriciel dans le rapport ; le générateur de documents renvoie la Matrice de relation pour tous les profils qui
incluent le Paquetage documenté comme Paquetage source ou cible.

Vous pouvez avoir un contrôle plus direct sur les profils matriciels présentés dans un rapport, en créant un élément
d'artefact Matrice Spécification qui définit un profil, puis en créant un rapport sur le Paquetage contenant cet artefact. Le
profil défini dans Artifact est indépendant du Paquetage qui contient l'élément Artifact et peut donc spécifier Paquetages
source et cible autres que le Paquetage parent. Le générateur de documents ne peut créer un rapport que sur un seul
artefact Matrice Spécification par Paquetage . Par conséquent, si vous souhaitez inclure plusieurs profils, placez chaque
élément d'artefact dans un sous-package distinct du Paquetage cible pour le rapport.

Accéder

Ruban Publier > Rapports de Modèle > Gabarits > Sections

Autre Onglet 'Ressources' de la fenêtre Navigateur | Publication de documents | Gabarits
personnalisés | < gabarit type> : cliquez-droit sur un gabarit | Ouvrir > Sections

Ajouter une section pour signaler le contenu Matrice de relations

Action Détail

Ajouter une rubrique Cochez la case « Paquetage > Matrice de relation » ; les marqueurs de section de la
matrice de relations sont ajoutés au gabarit .

Cliquez-droit entre les marqueurs et ajoutez le champ 'Image' pour renvoyer la
Matrice de Relation dans le rapport.

matrice de relation >

{ Matrice .Image}

< matrice de relation

Vous pouvez également insérer un certain nombre de champs pour identifier des
aspects spécifiques du profil, tels que le nom de la relation, la direction, le type,
l'élément cible et le type d'élément, ainsi que l'élément source et le type d'élément.

Notes

Vous pouvez visualiser la liste des profils créés directement dans la Matrice Relationnelle, dans le dossier Profils·
Matrice de l'onglet 'Ressources' de la fenêtre du Navigateur .

Si un Paquetage signalé contient un artefact Matrice Spécification et fait également partie d'un profil créé·
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directement dans la Matrice de relation, l'élément Artefact est prioritaire et le rapport n'inclut pas le profil Matrice de
relation directe.
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Rapport sur les contraintes et les scénarios

Dans Document Gabarit Designer, vous pouvez créer des sections pour inclure des informations de votre modèle sur :

Contraintes sur les éléments, les éléments, les connecteurs et Attributes Paquetage , et·
Scénarios pour les éléments et éléments Paquetage·

Vous pouvez définir des options supplémentaires dans les sections « Contraintes » et « Scénarios » pour définir les types
de contraintes ou de scénarios à inclure dans vos rapports.

Accéder

Ruban Publier > Rapports de Modèle > Gabarits > Sections

Autre Onglet 'Ressources' de la fenêtre Navigateur | Publication de documents | Gabarits
personnalisés | < gabarit type> : cliquez-droit sur un gabarit | Ouvrir > Sections

Définir des sections pour extraire les détails des contraintes et des scénarios

Object Détail

Contraintes Dans le panneau « Sections », vous pouvez cocher une ou plusieurs de ces cases
d'option de contrainte :

« Constraint-Pre » - pour inclure toutes les contraintes de type·
« pré-condition » dans cette section du rapport

'Constraint-Post' - pour inclure toutes les contraintes de type 'post-condition'·
dans cette section du rapport

« Contrainte » - pour inclure toutes les contraintes qui n'ont pas été générées·
dans les sections « Pré-contrainte » et « Post-contrainte » du rapport

Définissez tous les champs dont vous avez besoin, entre les marqueurs de section.

Scénarios Dans le panneau « Sections », vous pouvez cocher une ou plusieurs de ces cases
d'option de scénario :

« Élément > Scénario » - pour inclure tous les scénarios dans cette section du·
rapport ; si l'une des sections suivantes est également sélectionnée, le rapport
inclut tous les scénarios qui ne sont pas des chemins d'exception

'Élément > Scénario > Exception' - pour inclure toutes les exceptions pour·
chaque scénario

« Élément > Scénario > Scénarios structurés » - pour inclure toutes les étapes·
du scénario dans les sections de scénario du rapport

« Élément > Scénario > Scénarios structurés > Exception » - pour inclure les·
étapes pour chaque chemin d'exception dans les sections de scénario du rapport

Définissez tous les champs dont vous avez besoin, entre les marqueurs de section.
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Documents liés Rapportage

Si vous avez de grandes quantités d'informations à fournir sur un élément ou Paquetage , vous pouvez les joindre sous
forme de document formaté soit en tant que contenu d'un élément Document Artifact associé à votre élément sujet, soit
en joignant le fichier du document directement à l'élément (selon sur l'édition d' Enterprise Architect que vous utilisez).
Dans les deux cas, vous pouvez inclure le contenu du document lié dans votre rapport de document en cochant une ou
plusieurs des cases « Document lié » dans la définition gabarit du rapport.

Accéder

Ruban Publier > Rapports de Modèle > Gabarits > Sections

Autre Onglet 'Ressources' de la fenêtre Navigateur | Publication de documents | Gabarits
personnalisés | < gabarit type> : cliquez-droit sur un gabarit | Ouvrir > Sections

Ajouter des sections pour créer un rapport sur les documents liés

Action Détail

Ajouter des rubriques Cochez les cases correspondant aux niveaux de document lié que vous souhaitez
inclure dans le rapport :

' Paquetage > Élément Paquetage > Document lié »·
' Paquetage > Élément Paquetage > Exigences externes > Document lié'·
' Paquetage > Elément > Document lié' ou·
' Paquetage > Elément > Exigences Externes > Document Lié'·

Le document lié est rendu dans le rapport de document entre ces marqueurs :

document lié >

<document lié

Notes

Dans certains gabarits système que vous pourriez copier, la case à cocher 'Document lié' n'est disponible qu'en tant·
qu'enfant de la case à cocher ' Exigences externes'

Vous n'avez pas besoin d'ajouter de champs entre les marqueurs de section du document lié.·
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Éléments Rapport provenant de Paquetages externes

Les éléments peuvent être réutilisés dans différents diagrammes d'un modèle, ce qui peut souvent signifier qu'un
diagramme contient des éléments « externes » provenant de Paquetages autres que le Paquetage parent du diagramme . À
l'aide de Document Gabarit Designer, vous pouvez créer gabarits personnalisés pour générer des rapports montrant tous
les éléments utilisés dans un Paquetage avec des éléments « internes » et « externes » regroupés séparément, ou
uniquement les éléments réellement contenus dans un Paquetage . Vous pouvez également sélectionner des options pour
exposer les éléments externes de tous diagrammes d'un Paquetage , ou uniquement des diagrammes sélectionnés du
Paquetage .

La séparation des éléments « externes » et « internes » évite la duplication d'informations et identifie les éléments qui ont
un impact sur le Paquetage mais ne font pas partie de la structure Paquetage . Normalement, vous devez indiquer le
même niveau de détail pour chaque élément interne et externe, mais vous pouvez également définir un groupe de détails
plus restreint pour les éléments externes, y compris le nom du Paquetage parent.

Accéder

Ruban Publier > Rapports de Modèle > Gabarits > Sections

Autre Onglet 'Ressources' de la fenêtre Navigateur | Publication de documents | Gabarits
personnalisés : cliquez-droit sur un gabarit | Ouvrir > Sections

Ajouter des sections pour inclure des éléments dans diagrammes

Étape Action

1 Dans le panneau « Sections » sur le côté gauche de la fenêtre de l'éditeur, cochez la case « Paquetage >
Élément ».

Cocher la case ajoute cet ensemble de sections au panneau 'Contenu' du gabarit :

2 Supprimez les deux textes [clic droit pour...] et après :

package> marqueur de section, tapez ' Nom Paquetage :' puis cliquez-droit et sélectionnez 'Insérer un·
champ | Option Nom

element> marqueur de section, tapez 'Nom de l'élément :' puis cliquez-droit et sélectionnez l'option·
'Insérer un champ | Option Nom

Le gabarit maintenant ressemble à cette illustration :
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3 Dans le panneau 'Sections', cochez la case ' Paquetage > Diagramme > Elément'.

Cocher la case étend l'ensemble des sections dans le panneau 'Contenu' du gabarit :

4 Supprimez les deux textes [clic droit pour...] et après :

diagramme > marqueur de section tapez ' Diagramme :' puis cliquez-droit et sélectionnez l'option·
'Insérer un champ | Option Nom

Supprimez l’espace entre les marqueurs d’élément > de section. Le gabarit maintenant ressemble à cette
illustration :

La section ' Diagramme > Elément' ne contenant aucun champ, le type de contenu de cette section dans le
rapport généré est déterminé par la section ' Paquetage > Elément'.

Spécifier diagrammes et générer un rapport

Étape Action

1 Sélectionnez l'option appropriée :

Dans la dialogue ' Propriétés ' des diagrammes sélectionnés, la case à cocher 'Ajouter chaque élément·
contenu dans la documentation', pour identifier tous les éléments de ces diagrammes dans votre
rapport, ou

Dans la dialogue ' Générer Documentation', la case à cocher 'Inclure tous les éléments Diagramme·
dans Rapport ' pour inclure tous les éléments dans chaque diagramme vérifié par le rapport

2 Dans la fenêtre Navigateur , sélectionnez le Paquetage sur lequel créer un rapport et exécutez le rapport
via :

Le concepteur de documents Gabarit , ou·
Le dialogue ' Générer Documentation'·

3 Le rapport généré pour l'exemple ressemble à ce résultat :
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Le rapport montre que le Paquetage BlockFrame contient 8 éléments, mais comporte des liens vers trois
éléments d'autres Paquetages car ces trois éléments ont été utilisés dans le diagramme BlockFrame.

Notes

Les illustrations de cette description montrent la configuration la plus simple, pour obtenir le résultat d'identification·
d'éléments externes dans un rapport ; vous pouvez, si vous préférez, remplir le rapport avec d'autres sections et
champs, en laissant la section ' Diagramme > Elément' vide pour dupliquer la structure de la section ' Paquetage >
Elément'

Si vous ajoutez des champs à la section « Diagramme > Élément », la section aura sa propre structure et son propre·
format et pourra fournir différents détails sur les éléments ; par exemple, en sélectionnant « Insérer un champ |
L'option de menu Nom (Complet) ajoute le champ {Element.FullName}, qui identifie Paquetage parent de chaque
élément externe.

Si vous insérez la section ' Paquetage > Diagramme > Elément' mais pas la section ' Paquetage > Elément', le rapport·
suivant affichera uniquement les éléments utilisés dans chaque diagramme , sans faire de distinction entre les
éléments externes et internes.

Si vous insérez la section ' Paquetage > Element' mais pas la section ' Paquetage > Diagramme > Element', le rapport·
suivant affichera uniquement les éléments contenus dans le Paquetage
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Rapport sur Valeur Étiquetés

Valeur Étiquetés sont largement utilisées dans les objets de votre modèle, notamment :

Éléments Paquetage·
Éléments·
Connecteurs et leurs éléments source et cible·
Attributes·
Opérations ( Méthodes ) et·
Exigences extérieures·

Lors de la conception d'un gabarit pour rendre compte de ces objets, vous pouvez inclure des informations sur leur Valeur
Étiquetés soit :

En groupe, en utilisant la sous-section « Valeur Étiquetée » pour identifier toutes Valeur Étiquetés utilisées dans l'·
object , ou

Individuellement, en utilisant le champ 'valueOf()' pour extraire une valeur spécifique d'une balise spécifique·

Accéder

Ruban Publier > Rapports de Modèle > Gabarits > Sections

Autre Onglet 'Ressources' de la fenêtre Navigateur | Publication de documents | Gabarits
personnalisés | < gabarit type> : cliquez-droit sur un gabarit | Ouvrir > Sections

Extraire des informations sur Valeur Étiquetés

Action Détail

Insérer une section Valeur
Étiquetée

La section Valeur Étiquetée rapporte toutes Valeur Étiquetés de l' object .

Dans le panneau « Sections », cochez la case de chaque object sur lequel faire
rapport, ainsi que la sous-section Valeur Étiquetée de cet object . Par exemple:

Paquetage > Élément Paquetage > Valeur Étiquetée·
Paquetage > Connecteur > Source > Valeur Étiquetée·
Paquetage > Élément > Exigences Externes > Valeur Étiquetée , ou·
Paquetage > Élément > Méthode > Valeur Étiquetée·

Les marqueurs de section Valeur Étiquetée s'affichent dans le panneau « Contenu ».

Supprimez le texte [clic droit pour-...] , cliquez-droit dans l'espace et sélectionnez
l'option 'Insérer des champs' pour ajouter les champs ' Valeur Étiquetée Nom', '
Notes ' et/ou 'Valeur'.
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Insérer un champ valueOf() Pour tout object ayant une Valeur Étiquetée , vous pouvez ajouter un champ
'valueOf()' au gabarit de votre rapport pour extraire la valeur d'une balise
spécifique. Il doit s'agir de l'une des balises normalement associées à l' object ,
comme 'ConnectorAltName' pour un connecteur.

Obtenez le nom de la balise avant de démarrer cette procédure.

Pour insérer le champ, cliquez-droit entre les balises de section de l' object et
sélectionnez l'option 'Insérer un champ | valeurDe'option.

Le Document Gabarit Designer vous prompts de saisir le nom de la balise dont
extraire la valeur . Type le nom et cliquez sur le bouton OK . Le Document Gabarit
Designer ajoute le champ à la position du curseur, au format :

{Objecttype.valueOf(tagname)}

Par exemple:

{Connecteur.valueOf(ConnectorAltName)}

Le champ 'valueOf' extrait uniquement la valeur de la balise, donc pour plus de
clarté, vous pouvez saisir un texte d'introduction ou la signification de la balise,
immédiatement avant le champ valeur . Par exemple:

Nom alternatif : {Connector.valueOf(ConnectorAltName)}
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Créer des sections sous forme de Tableaux

Dans un gabarit de rapport de document , vous pouvez afficher une section de modèle sous forme de tableau , défini avec
n'importe quel nombre de colonnes mais avec seulement deux lignes :

La première ligne sert à décrire les titres des colonnes, que vous définissez et formatez vous-même·
La deuxième ligne définit la sortie, que vous spécifiez en cliquant avec le bouton droit dans chaque cellule et en·
sélectionnant le type de sortie dans la liste des champs ; la sortie est ensuite générée de manière itérative pour
chaque occurrence de la section en question

Par exemple, vous pouvez configurer la section Modèle > Glossaire > comme section tableau , en utilisant la définition
du tableau :

Cette définition tableau restitue la sortie du document :

Accéder

Ruban Document-Édition > Paragraphe > Tableau > Insérer Tableau

Créer et formater un tableau

À Action

Insérer un tableau dans le
document

Placez le curseur sur le point du texte pour créer le tableau et, dans la barre de
ruban « Modification du document », sélectionnez « Paragraphe > Tableau >
Insérer Tableau ». La dialogue 'Nouveau Tableau ' s'affiche, dans laquelle vous
spécifiez le nombre de lignes et de colonnes tableau . Pour un tableau de sections de
modèle dans un gabarit de rapport, vous pouvez accepter les valeurs par défaut de
deux lignes et trois colonnes. Cliquez sur le bouton OK .
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Votre tableau pourrait être invisible ; si tel est le cas, sélectionnez « Paragraphe >
Tableau > Afficher le quadrillage » dans la barre de ruban pour révéler les bordures
du tableau et des cellules en lignes pointillées. Ces lignes servent à guidage la
création du document et ne s'affichent pas sur le document imprimé. Vous pouvez
ajouter des bordures imprimables si vous préférez, en utilisant d'autres options de
menu.

L'éditeur crée initialement un tableau avec des cellules de largeur égale sur toute la
page ; vous pouvez modifier la largeur des cellules en faisant glisser les bordures
des cellules à l'aide de la souris ou en utilisant d'autres options du menu contextuel.

Ajouter une ligne d'en-tête Sélectionnez la ligne supérieure du tableau , puis sélectionnez « Paragraphe >
Tableau > Ligne d'en-tête » dans la barre du ruban. Appliquez le texte du titre, les
paramètres et le formatage à la ligne en surbrillance.

Dans le document ou le rapport compilé, la ligne de titre est répétée en haut des
colonnes chaque fois que le tableau passe à une nouvelle page. Dans un rapport, si
la ligne d'en-tête contient les valeurs des noms de champs, les lignes d'en-tête des
pages suivantes reflètent les valeurs de cette première ligne.

Cette option fonctionne sur la seule ligne en haut du tableau , et non sur plusieurs
lignes.

Remplir la ligne de
données avec des champs

Cliquez-droit sur la cellule tableau et sélectionnez l'option 'Insérer un champ |
Option <nom du champ>' pour ajouter un ou plusieurs champs à la cellule.

Lorsque le rapport est généré, les valeurs des champs sont extraites et affichées
dans le tableau pour chaque instance de l' object , comme un élément ou un attribut.

Notes

Dans un document rapport gabarit , si vous tapez un retour chariot entre la fin du tableau et la fin de la section, le·
tableau vous générez comporte un interligne entre les lignes ; Par exemple:

Cela génère le tableau :

Pour éviter cela, supprimez tout retour chariot entre la fin du tableau et la fin de la section, comme indiqué :
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Cela génère un tableau sans espace entre les lignes :
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Ajouter du contenu de section

Dans Document Gabarit Designer, lorsque vous cochez les cases dans le panneau « Sections » pour rendre compte des
différents objets et fonctionnalités du modèle, des paires de balises en surbrillance sont ajoutées au panneau « Contenu ».
Beaucoup de ces paires de balises sont reliées par une courte instruction, comme indiqué :

nom de la section >

[clic droit pour insérer-<nom de l'objet>-champs]

<nom de la section

Là où le message texte est affiché, vous pouvez le supprimer et utiliser l'espace entre les balises pour fournir le contenu
du rapport, en :

Taper ou coller le texte standard que vous souhaitez inclure dans vos rapports, et·
Insertion de champs qui extraient les valeurs de caractéristiques et propriétés spécifiques de l' object·

Accéder

Ruban Publier > Rapports de Modèle > Gabarits > Contenu

Autre Onglet 'Ressources' de la fenêtre Navigateur | Publication de documents | Gabarits
personnalisés | < gabarit type> : cliquez-droit sur un gabarit | Ouvrir > Contenu

Ajouter du contenu informatif au gabarit

Action Détail

Ajouter du texte Cliquez dans l'espace entre les balises (ou n'importe où ailleurs dans le gabarit ) et
tapez ou collez (Ctrl+V) le texte que vous souhaitez afficher dans le rapport.

Mettez en surbrillance et cliquez-droit sur le texte pour le formater, à l'aide des
commandes de l'éditeur de documents.

Insérer des champs Cliquez-droit dans la zone située entre les balises d'ouverture et de fermeture, et
sélectionnez l'option 'Insérer un champ' ; cela affiche une liste contextuelle de
champs à ajouter à cette section du gabarit .

Cliquez sur le nom du champ que vous souhaitez ajouter. L'éditeur Document
Gabarit affiche la balise de champ dans l'espace de texte. Par exemple:

{Élément.ParentPackage}

Lorsque vous générez un rapport à partir du gabarit , le générateur de rapport
remplace le nom du champ par la valeur réelle. Vous devrez peut-être saisir un texte
d'introduction et ajouter des espaces pour support le champ valeur , ou utiliser les
champs dans un tableau avec des en-têtes de lignes et de colonnes.

Vous pouvez insérer autant de champs que vous le souhaitez dans la liste ; vous
appliquez généralement chaque champ une fois, car le générateur de rapport
applique les instructions gabarit à chaque instance de l' object .
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Notes

Comme les balises model et Linked Document ne nécessitent pas de champs, vous ne pouvez pas afficher le menu·
contextuel de l'éditeur entre ces balises

Les balises élément enfant, élément incorporé et Paquetage enfant représentent des sections qui peuvent avoir des·
champs définis, mais ces champs empêchent les sections de répliquer la structure de leur élément parent et des
sections Paquetage ; comme il est préférable d'utiliser les structures parentes, ces balises ne vous prompt pas à
ajouter des champs avec le message [right-click-to-insert-<objectname>-fields] , bien que le message soit toujours
applicable

Si vous sélectionnez un champ avec un format de date court (tel que Pkg.DateCreatedShort, Diagramme·
.DateModifiedShort ou Element.DateCreatedShort), le format est en fait tiré des paramètres MS Windows ; pour
utiliser un autre format de date courte, cliquez sur l'icône Démarrer sur le bureau Windows et sélectionnez l'option
'Panneau de configuration | Options régionales et linguistiques | Option Personnaliser
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Appliquer la numérotation des sections définie par
l'utilisateur

Dans votre gabarit de rapport, vous souhaiterez peut-être numéroter les niveaux de section, avec un format de
numérotation de votre propre conception. Par exemple:

1. Paquetage niveau 1

1.1 Paquetage niveau 2 ( Paquetage enfant)

1.1.1 Élément niveau 1

1.1.1.1 Élément (élément enfant)

Pour définir le format de numérotation :

Créez d’abord une liste de numérotation, puis·
Créer un ensemble de remplacements de liste pour cette liste·

Dans les remplacements, vous modifiez le paramètre initial 1.0.0 en 1.1.1. Vous pouvez ensuite appliquer la liste de
numérotation aux rubriques définies pour Paquetages et les éléments, en utilisant la numérotation des paragraphes.

Accéder

Ruban Document-Edit > Edit > Edit > Liste et remplacements

Définir le format de numérotation

Étape Action

1 Pour créer la liste de numérotation, sélectionnez l'option de menu « Créer Item de liste ».

La dialogue 'Liste Propriétés ' affiche :

Dans le champ "Nom de la liste", saisissez un nom pour la liste·
Laissez la case à cocher « Liste à plusieurs niveaux » cochée·
Si vous avez ajouté des sections à votre document et souhaitez redémarrer la numérotation pour·
chaque nouvelle section, cochez la case « Redémarrer au saut de section ».

Cliquez sur le bouton OK pour fermer le dialogue·

2 Pour créer le remplacement de liste, sélectionnez l'option de menu « Créer un remplacement de liste ».

La boîte dialogue 'Liste Propriétés de remplacement' affiche :

Dans le champ 'Liste à remplacer', saisissez ou sélectionnez le nom de la liste que vous venez de créer·
Laissez la case « Remplacer les niveaux » cochée·
Cliquez sur le bouton OK pour fermer le dialogue·

3 Pour configurer les propriétés du niveau de liste pour un niveau, sélectionnez l'option de menu « Modifier
le niveau de liste ».

La dialogue « Propriétés du niveau de liste » s'affiche.

Sélectionnez le bouton radio « Élément de liste » et saisissez ou sélectionnez l'élément de liste que·
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vous venez de créer.

Définissez le champ « Niveau de liste » sur « 1 » (pour la section Paquetage ) et le champ « Texte·
numérique » sur « ~1~ ».

Cliquez sur le bouton OK pour enregistrer les valeurs et fermer le dialogue·

4 Sélectionnez à nouveau l'option de menu 'Modifier le niveau de liste' pour rouvrir le dialogue :

Sélectionnez le bouton radio « Élément de liste » et saisissez ou sélectionnez l'élément de liste que·
vous venez de créer.

Réglez « Niveau de liste » sur « 2 » (pour la « Section Élément » ou la « Section Paquetage enfant »,·
par exemple)

Réglez ' Démarrer à' sur '1' (pour garantir que la numérotation à ce niveau commence à 1,1 plutôt qu'à·
1,0)

Cliquez sur le bouton OK pour fermer le dialogue et enregistrer les modifications·

5 Répétez les étapes 3 et 4 pour chaque niveau de liste supplémentaire dont vous avez besoin, en
incrémentant le numéro du niveau de liste et en réinitialisant Démarrer à 1 à chaque fois.

Appliquer les niveaux de numérotation définis

Étape Action

1 Dans le panneau 'Contenu' de l'éditeur de documents, sélectionnez le premier élément de texte à numéroter
(par exemple, Paquetage ).

2 Définissez le style de texte sur l'un des styles de titre (titre 1 à titre 9), à l'aide du champ déroulant
« Style » dans la barre d'outils de l'éditeur de documents.

3 Cliquez-droit sur le texte et sélectionnez le 'Paragraphe | Option de menu Numérotation des listes.

La dialogue « Appliquer la numérotation des paragraphes à l'aide de listes » s'affiche.

Dans le panneau « Liste », sélectionnez la combinaison Liste et Remplacement requise.·
Réglez le champ 'Niveau' sur le niveau requis (1, pour le niveau supérieur)·
Cliquez sur le bouton OK pour fermer le dialogue et vérifiez que le niveau requis a été appliqué au·
texte sélectionné
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4 Répétez l'étape 3 pour le niveau suivant (Élément), mais remplacez le champ « Niveau » par 2.

5 Continuez à appliquer les remplacements pour chaque niveau de section inférieur si nécessaire, puis
générez votre document.

La sortie sera numérotée et formatée, comme illustré par l'exemple.

Exemple de niveau de numérotation
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Options de conception Gabarit personnalisées

Le Document Gabarit Designer, via le ruban 'Document-Edit', offre un large éventail d'options pour définir le format et
les styles des rapports de documents générés à partir de vos gabarits personnalisés. En plus de ces fonctions, vous pouvez
également accéder aux options depuis la barre d'outils en haut du panneau « Contenu » et depuis un menu contextuel
dans le texte.

Accéder

Lorsque vous ouvrez un gabarit dans Document Gabarit Designer, le ruban Document - Modifier s'ouvre également
automatiquement.

Ruban Publier > Rapports de Modèle > Gabarits

Autre Onglet 'Ressources' de la fenêtre Navigateur | Publication de documents | Système
Gabarits | < groupe gabarit > : cliquez-droit sur un gabarit | Copie

Onglet 'Ressources' de la fenêtre Navigateur | Publication de documents | Gabarits
personnalisés | < groupe gabarit > : cliquez-droit sur un gabarit | Ouvrir

Description des options

Les descriptions des options du ruban sont regroupées en fonction des actions que vous effectuez.

Actions

Création et importation gabarits

Configuration de l'affichage de la page de l'éditeur et des outils de formatage affichés

Incorporation de feuilles de style, de textes spéciaux et Tableaux des matières

Gestion des styles de base dans le fichier gabarit de style Normal.rtf

Parcourir, rechercher et sélectionner du texte

Formatage des caractères et des chaînes de texte

Formatage des paragraphes et des blocs de texte

Insertion de points de tabulation

Insertion de sections, de colonnes et de sauts de page, et repagination

Insertion et modification des en-têtes et pieds de page de page, ainsi que des notes de bas de page et de fin

Insérer tableaux

Configuration de la numérotation des sections définie par l'utilisateur
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Insérer des hyperliens

Insertion d'images, d'objets OLE, de cadres et d'objets de dessin

Vérifier l'orthographe du texte et l'utilisation des mots

Suivre les modifications et les intégrer ou les rejeter

Protéger le document et le texte gabarit contre toute modification accidentelle

Configuration de l'imprimante et impression des documents

Notes

Tout au long de votre édition gabarit :

Pour annuler une ou plusieurs modifications immédiatement précédentes, appuyez sur Ctrl+Z ou sélectionnez·
l'option de menu contextuel « Annuler » ; vous pouvez toujours annuler une modification même après l'avoir
enregistrée

Pour refaire une ou plusieurs modifications annulées immédiatement précédentes, appuyez sur Ctrl+Y ou·
sélectionnez l'option de menu contextuel « Rétablir »
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Utiliser des signets

Dans un gabarit de document, vous pouvez insérer un signet pour localiser des éléments à l'intérieur du document généré,
soit à partir du même document, soit à partir d'un document Word distinct.

Gérer les favoris

Au fur et à mesure que gabarit de votre rapport se développe, l'éditeur attribue automatiquement un signet unique au
début et à la fin de chaque section de modèle que vous sélectionnez dans le panneau « Sections ».

Vous pouvez également créer vos propres signets dans n'importe quel document, là où vous souhaitez faire référence à un
point spécifique, et les déplacer vers d'autres points du texte.

(Dans le gabarit du rapport, vous pouvez également déplacer les signets automatiques, mais si vous souhaitez les utiliser
comme points de référence pour accéder à un document Word, il est préférable de les laisser tels quels.)

Tâche Description

Insérer un signet Cliquez-droit sur le point du texte à marquer, et sélectionnez l'option de menu1.
'Signet' ; la boîte dialogue « Favoris » s'affiche.

Sélectionnez un signet existant dans la liste (pour le basculer vers2.
l'emplacement actuel) ou saisissez un nouveau nom de signet dans le champ
supérieur. N'utilisez pas d'espaces dans le signet ; cela empêchera l’insertion du
signet.

Cliquez sur le bouton Insérer.3.

Localiser le texte marqué
dans les favoris dans le
document

Sélectionnez l'option de menu « Favoris ».1.

Dans la dialogue « Favoris », cliquez sur le signet et sur le bouton Aller à.2.

L'éditeur affiche le point auquel le signet a été défini, dans le coin supérieur3.
gauche de l'écran.

Supprimer un signet
existant

Sélectionnez l'option de menu « Favoris ».

Dans la dialogue « Favoris », cliquez sur le signet et sur le bouton Supprimer.

Insérer une référence à un
signet

Déplacez le curseur jusqu'au point où insérer la référence et, si vous le1.
souhaitez, saisissez un texte d'introduction tel que « Aller à la page » ou « Voir
la page ».

Sélectionnez l'option de menu « Favoris ».2.

Dans la dialogue « Favoris », cliquez sur le signet et sur le bouton Définir la3.
référence de la page.

L'éditeur insère le numéro de la page contenant le signet, à l'emplacement du4.
curseur dans le texte ; pour un document, cela agit comme un lien hypertexte
vers la position du signet. Si vous définissez la référence dans un gabarit , le
lien est créé dans le document que vous générez à partir du gabarit .

Facilités de signets supplémentaires dans la génération de documents

Tous . Les signets Démarrer et .End qui entourent un champ étiqueté masqueront l'étiquette dans le rapport si le champ
n'a pas de contenu ; Par exemple:

Les signets Element.Keywords. Démarrer et Element.Keywords.End enferment le champ du rapport Mots-clés·
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{Element.Keywords} , mais si un élément n'a pas de mots-clés, le libellé Mots-clés dans le rapport généré est masqué
et l'espace fermé

Tous les signets de début et de fin contenant la string _LIST_ ajouteront une virgule à la section ci-jointe, de sorte que
toutes les valeurs extraites du modèle pour cette section seront présentées dans une liste séparée par des virgules ; Par
exemple:

Les signets Pkg_Element_Meth_MethParameter_LIST_Begin et Pkg_Element_Meth_MethParameter_LIST_End·
dans la section des paramètres définissent une virgule qui, dans le rapport, est insérée entre les multiples paires
nom/type de paramètre dans la section.

Tous les signets de début et de fin contenant la string _TITLE_ ajouteront un saut de ligne et un titre valeur au champ, et
présenteront les valeurs extraites du modèle sous forme de liste verticale sous le titre ; Par exemple:

Les marque-pages Pkg_Element_Meth_FeatTagVal_TITLE_Begin et Pkg_Element_Meth_FeatTagVal_TITLE_End·
dans la section Valeur Étiquetée insèrent un interligne et la rubrique ' Propriétés ', en dessous duquel est imprimé,
dans l'état, les noms et valeurs du paramètre Valeur Étiquetés

Notes

Lorsque vous forcez le traitement d'un champ SQL personnalisé dans le fragment en tant que notes formatées, vous·
devez avoir « .formatted » dans le nom du champ personnalisé ; Par exemple:
{FieldName.Formatted}

La même chose est requise dans les signets pour les fragments SQL ; Par exemple:·
{FieldName.Formatted. Démarrer } ou FieldName.Formatted.End}.
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Constantes Rapport

L'éditeur de documents (pour gabarits de rapport générés) fournit un ensemble de champs qui représentent des données
sur le rapport lui-même, telles que le nom du rapport, le titre, la date de génération, la version, l'auteur et le statut.
Lorsque le rapport est généré, chaque champ est remplacé par la valeur actuelle de la donnée élémentaire. C'est ce qu'on
appelle des constantes de rapport.

Vous pouvez insérer une constante de rapport n'importe où dans votre gabarit - dans le texte, dans les en-têtes ou pieds de
page, ou dans le matériel de la page de garde. Ils sont particulièrement adaptés aux pages de garde.

Constantes

Constante Remplacé par

Alias du rapport (Pour un rapport généré sur un Paquetage racine) L'Alias du Paquetage , issu des
propriétés du Paquetage .

(Pour un rapport généré sur un seul élément) L'Alias de l'élément, à partir des
propriétés de l'élément.

Sinon, la constante reste vide.

Auteur du rapport ID de connexion Enterprise Architect de l’utilisateur qui génère le rapport.

RapportPresse-papiers L'image actuellement conservée dans le presse-papiers.

RapportDateLong La date générée par le système au format long.

Date du rapportCourt La date générée par le système au format court.

Nom du fichier de rapport Le nom du fichier du rapport généré, tel qu'enregistré dans la dialogue ' Générer
Documentation'.

Nom de fichier de rapport
court

Le nom de fichier actuel du rapport généré. (Cela changera si le fichier est
renommé sur le disque.)

Mots-clés du rapport (Pour un rapport généré sur un Paquetage racine) Les Mots-clés du Paquetage ,
issus des propriétés du Paquetage .

(Pour un rapport généré sur un seul élément) Les Mots-clés de l'élément, à partir
des propriétés de l'élément.

Sinon, la constante reste vide.

Nom du rapport (Pour un rapport généré sur un Paquetage racine) Le nom du Paquetage , issu des
propriétés Paquetage .

(Pour un rapport généré sur un seul élément) Le nom de l'élément, issu des
propriétés de l'élément.

Sinon, la constante reste vide.

Source du rapport Le nom du Référentiel qui a été utilisé pour générer le document.

Pour les référentiels basés sur des fichiers, il s'agira du chemin d'accès et du nom du
fichier de projet.

Pour les SGBD, ce sera le nom de la base de données utilisée.
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État du rapport (Pour un rapport généré sur un Paquetage racine) Le statut du Paquetage , à partir
des propriétés Paquetage .

(Pour un rapport généré sur un seul élément) L'état de l'élément, à partir des
propriétés de l'élément.

Sinon, la constante reste vide.

Résumé du rapport Fournit le contenu de la Valeur Étiquetée 'ReportSummary' trouvée sur le Paquetage
racine ou sur un élément unique.

S'il n'y a pas de 'ReportSummary' Valeur Étiquetée , la constante reste vide.

Titre du rapport Le nom du gabarit utilisé pour générer le rapport, tel que sélectionné dans la
dialogue ' Générer Documentation'.

Version du rapport (Pour un rapport généré sur un Paquetage racine) La version du Paquetage , issue
des propriétés du Paquetage .

(Pour un rapport généré sur un seul élément) La version de l'élément, à partir des
propriétés de l'élément.

Sinon, la constante reste vide.

Insérer une constante Rapport

Cliquez-droit sur le point du gabarit pour insérer le champ de données et sélectionnez le ' Rapport Constantes | <nom du
champ>'.
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Notes sur la création de feuilles de style

Les feuilles de style définissent une gamme de paramètres de formatage qui contrôlent l'apparence et disposition d'un
rapport de document. Vous les créez pour fournir un ensemble de styles alternatif au fichier Normal.rtf et à tout style
spécial redéfini dans un gabarit de rapport de document. Un utilisateur peut choisir d'appliquer une feuille de style à
n'importe quel type de rapport de document qu'il génère, auquel cas les styles de la feuille de style remplacent les styles
dont les noms correspondent dans le gabarit ou Normal.rtf. Vous pouvez donc créer une feuille de style qui :

Redéfinit et remplace certains styles·
N'inclut pas d'autres styles nommés, donc l'utilisation de ces styles correspond par défaut à la définition du fichier·
gabarit ou Normal.rtf, et

Fournit des styles supplémentaires qui peuvent être appliqués en modifiant le rapport généré·
Chaque feuille de style personnalisée peut définir une disposition de page et des styles de document totalement différents
de ceux des autres feuilles de style et de la feuille de style Normal.rtf.

Le moyen le plus simple de créer une nouvelle feuille de style consiste à copier l'un des fichiers fournis par le système
(pour la sortie imprimée ou pour la sortie en ligne) ou une autre feuille de style personnalisée, puis à modifier les
définitions de style dans la copie. Cependant, vous pouvez créer une feuille de style à partir de zéro si vous préférez ;
celui-ci serait initialement dérivé du fichier Normal.rtf.

Accéder

Utilisez l'une des méthodes décrites ici pour afficher la dialogue « Nouveau document Gabarit ». Créez le nouveau
fichier de feuille de style, puis modifiez les styles dans le Document Gabarit Designer à l'aide des facilités « Styles, texte
spécial et Tableau des matières ».

Ruban
Publier > Rapports de Modèle > Gabarits :  ou

Démarrer > Toutes Windows > Conception > Explorer > Parcourir > Ressources >
Publication de documents > Gabarits personnalisés > cliquez-droit sur Feuilles de
style > Créer Gabarit

Démarrer > Toutes Windows > Conception > Explorer > Parcourir > Ressources >
Publication de documents > Gabarits personnalisés > Feuilles de style >
cliquez-droit sur <nom de la feuille de style> | Copie

Autre Dans l'onglet 'Ressources' de la fenêtre Navigateur , développez le dossier
Publication de documents , puis :

Développez le dossier Gabarits personnalisés | cliquez-droit sur les feuilles de·
style | Créez Gabarit , ou

Développez le dossier System Gabarits | Développez le dossier Feuilles de·
style | cliquez-droit sur <nom de la feuille de style> | Copie

Vous pouvez également créer des feuilles de style dans l'onglet ' Gabarits ' de la
dialogue ' Générer Documentation'.
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Notes sur la création Tableaux des matières

Un gabarit de Tableau des matières définit le style, les niveaux et les formats de numérotation d'un rapport de document
Tableau des matières qu'un utilisateur peut choisir d'appliquer à tout type de rapport de document qu'il génère, auquel cas
le gabarit du Tableau des matières remplace tout Tableau des matières. styles définis dans le fichier gabarit ou Normal.rtf.

Le moyen le plus simple de créer un nouveau Tableau des matières consiste à copier l'un des fichiers fournis par le
système (pour une sortie portrait ou paysage) ou un autre Tableaux des matières personnalisé, et à modifier les
définitions de style dans la copie. Cependant, vous pouvez créer un Tableau des matières à partir de zéro si vous
préférez ; celui-ci serait initialement dérivé du fichier Normal.rtf.

Accéder

Utilisez l'une des méthodes décrites ici pour afficher la dialogue 'Nouveau document Gabarit ' et créer le nouveau fichier
gabarit du Tableau des matières.

Après avoir créé le nouveau fichier gabarit , modifiez les styles dans le Document Gabarit Designer en utilisant les
facilités « Styles, Texte spécial et Tableau des matières ».

Ruban
Publier > Rapports de Modèle > Gabarits : 

Autre Dans l'onglet 'Ressources' de la fenêtre Navigateur , développez le dossier
Publication de documents , puis :

Développez le dossier Gabarits personnalisés | cliquez-droit sur Tableau des·
matières | Créez Gabarit , ou

Développez le dossier System Gabarits | Développez le dossier Tableau des·
matières | cliquez-droit sur <nom du tableau des matières> | Copie

Insérer un nouveau Tableau des matières

Pour insérer un nouveau Tableau des matières :

Ajouter au moins un caractère de texte au document·
Réglez-le sur un style « Titre n ». Par exemple « Titre 1 »·
Déplacez le curseur jusqu'au point où insérer le Tableau des matières et sélectionnez l'option :·
Document-Modifier > Modifier > Insérer > Tableau des matières.

Une petite dialogue s'affiche dans laquelle vous spécifiez les niveaux de Tableau des matières les plus élevés et les plus
bas à appliquer dans le tableau de ce document ; lorsque vous avez spécifié les niveaux, cliquez sur le bouton OK .

Note : S'il existe des titres correspondants dans la plage spécifiée, le Tableau des matières s'affiche ; sinon, la ligne reste
vide.
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Supprimez le texte de style de titre ajouté ci-dessus.·
Enregistrez le gabarit .·
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Importer un document Gabarit

De nombreuses organisations ont établi des formats et gabarits d'entreprise, ou peuvent concevoir gabarits en dehors
Enterprise Architect . Si vous souhaitez utiliser de tels gabarits « externes » de votre entreprise pour appliquer des
formats et des normes à vos rapports de documents, vous pouvez les importer dans votre bibliothèque gabarit de
documents.

Accéder

Ruban Document-Edition > Fichier > Fichier > Importer un fichier

Importer un gabarit depuis un répertoire externe

Étape Action

1 Enregistrez le gabarit externe en tant que document.

2 Dans Enterprise Architect , créez un nouveau gabarit vierge.

Soit:

Cliquez sur l'icône  dans Document Gabarit Designer, ou·
Cliquez-droit sur un dossier Utilisateur Gabarit dans l'onglet 'Ressources' de la fenêtre du Navigateur·
et sélectionnez 'Créer Gabarit '

La dialogue 'Nouveau document Gabarit ' s'affiche. Nommez le gabarit , mais ne spécifiez pas de gabarit
existant à partir duquel copier.

3 Une fois le nouveau gabarit vierge chargé dans Document Gabarit Designer, sélectionnez l'option
'Document-Edit > File > File > Import File'.

La dialogue « Fichier ouvert » s'affiche.

4 Localisez votre fichier gabarit et cliquez sur le bouton Ouvrir.

La dialogue « Ouvrir » se ferme et vous ramène au Document Gabarit Designer ; celui-ci contient
maintenant votre gabarit importé.

5 Sélectionnez l'option 'Document-Edit > File > Save'.

Si nécessaire, apportez des modifications au gabarit et sélectionnez à nouveau l'option 'Document-Edit >
File > Save'.

Notes

Les images graphiques standard (telles qu'un logo dans l'en-tête, le texte principal ou le pied de page) sont·
importées ; cependant, les graphiques de métafichier ne sont pas importés

Vous pouvez sélectionner le nouveau gabarit à utiliser pour générer un rapport de document, soit dans la dialogue '·
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Générer Documentation', soit dans un élément Modèle Document.

(c) Sparx Systems 2023 Page 119 de 177 Créé avec Enterprise Architect



Génération de documents 2023-11-23

Notes sur la création de pages de garde

Un gabarit de page de couverture définit le style, les champs et le format de la couverture d'un rapport de document qu'un
utilisateur peut choisir d'appliquer à tout type de rapport de document qu'il génère, auquel cas les styles de page de
couverture remplacent tous les styles du même nom définis dans le rapport gabarit ou le fichier Normal.rtf.

Le moyen le plus simple de créer une nouvelle page de garde consiste à copier l'un des fichiers fournis par le système
(pour une sortie portrait ou paysage) ou un autre contenu de page de garde personnalisé, puis à modifier les définitions de
style dans la copie. Cependant, vous pouvez créer une page de garde à partir de zéro si vous préférez ; celui-ci serait
initialement dérivé du fichier Normal.rtf.

Accéder

Utilisez l'une des méthodes décrites ici pour afficher la dialogue 'Nouveau document Gabarit ' et créer le nouveau fichier
gabarit de page de garde.

Après avoir créé le nouveau fichier gabarit , modifiez les styles dans le Document Gabarit Designer en utilisant les
facilités « Styles, Texte spécial et Tableau des matières ».

Ruban
Publier > Rapports de Modèle > Gabarits : 

Autre Dans l'onglet 'Ressources' de la fenêtre Navigateur , développez le dossier
Publication de documents , puis :

Développez le dossier Gabarits personnalisés | cliquez-droit sur les pages de·
couverture | Créez Gabarit , ou

Développez le dossier System Gabarits | Développez le dossier Pages de garde·
| cliquez-droit sur <nom de la page de garde> | Copie
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Fragments Gabarit

Dans un gabarit de document, vous pouvez inclure un ou plusieurs sous-modèles, ou fragments Gabarit . À l'aide de
Gabarit Fragments, vous pouvez inclure dans vos rapports de documents des informations extraites du modèle à l'aide de
requêtes SQL et Scripts Modèle , offrant ainsi un plus grand niveau de personnalisation de la sortie du document. Vous
pouvez également utiliser un Fragment de Sélecteur Gabarit pour appeler d'autres Fragments Gabarit en fonction du type
d'élément faisant l'objet du rapport. Il est possible de réutiliser le même Fragment Gabarit dans plusieurs gabarits
différents, vous pouvez ainsi développer une bibliothèque de Fragments Gabarit communs qui peuvent être utilisés pour
créer des rapports documentaires plus grands et plus complexes.

Un fragment Gabarit est créé selon le même processus qu'un gabarit document complet normal. Chaque fragment Gabarit
peut avoir ses propres options de document appliquées, telles que le filtrage et le tri.

Vous pouvez également utiliser, copier et modifier un certain nombre de fragments Gabarit fournis par le système,
auxquels vous pouvez accéder à partir du dossier Publication de documents > Gabarits système > Fragments dans
l'onglet « Ressources » de la fenêtre du Navigateur .

Fragments Gabarit – Présentation du processus

Étape Action

1 Créez les fragments Gabarit à inclure dans votre gabarit .

2 Créez un gabarit de document complet normal qui doit inclure vos fragments Gabarit .

3 Dans ce gabarit de document complet, ajoutez des références à vos fragments Gabarit aux emplacements
appropriés.

Notes

Vous ne pouvez pas générer de documentation directement à partir d'un fragment ; pour utiliser un Fragment, il doit·
être inclus dans un gabarit
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Créer un fragment Gabarit

Un fragment Gabarit peut renvoyer des données à partir d'une Query SQL ou Scripts Modèle . Le processus de définition
du contenu d'un fragment Gabarit dépend du type de données que vous souhaitez que votre fragment Gabarit renvoie ; les
choix étant :

Données du modèle Gabarit du document normal - le fragment Gabarit fonctionne de la même manière qu'un gabarit·
normal

Gabarit Selector - pour définir un gabarit qui appelle d'autres fragments Gabarit en fonction du type d'élément·
signalé

SQL personnalisé - pour faire référence aux données renvoyées par une Query SQL personnalisée·
Scripts personnalisés - pour faire référence aux données renvoyées par un script Modèle·
Document Script - pour identifier un Modèle Script à utiliser par votre Fragment Gabarit ; le script doit renvoyer soit·
une string vide, soit une string contenant du RTF brut

Script XML personnalisé - pour créer une requête pour rapporter les valeurs d'un fichier XML produit par un script·
généré précédemment, comme les données d'une simulation ; la requête fonctionne sur des données statiques qui ne
sont pas continuellement ou automatiquement mises à jour

Dans tous les cas, le processus est très similaire à la création d'un gabarit de document normal.

Accéder

Utilisez l'une des méthodes décrites ici pour ouvrir la dialogue « Nouveau document Gabarit ».

Ruban
Publier > Rapports de Modèle > Gabarits :  Nouvelle icône Gabarit

Raccourcis Clavier F8 > Gabarits : Nouveauté

Autre Dans l'onglet 'Ressources' de la fenêtre Navigateur , développez le dossier
Publication de documents , puis :

Développez le dossier Gabarits personnalisés | cliquez-droit sur le dossier·
Fragments | Créez Gabarit ou

Développez le dossier Gabarits personnalisés | développez le dossier·
Fragments | cliquez-droit sur <nom gabarit > | Copier ou

Développez le dossier Système Gabarits | développez le dossier Fragments |·
cliquez-droit sur <nom gabarit > | Copie

Créer un nouveau fragment Gabarit

Étape Action

1 En utilisant l'une de ces méthodes, affichez la dialogue 'Nouveau document Gabarit '.

2 Dans le champ « Nouveau Gabarit », saisissez le nom du fragment Gabarit .

3 Dans le champ « Type Gabarit », cliquez sur la flèche déroulante et sélectionnez l'option « Fragments ».
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4 Dans le champ 'Copier Gabarit ', cliquez sur la flèche déroulante et sélectionnez soit :

« Aucun », pour créer un fragment Gabarit vide à développer à partir de zéro, ou·
Le nom d'un Gabarit existant pour servir de base·

5 Dans le champ 'Groupe Gabarit ' soit :

Cliquez sur la flèche déroulante et sélectionnez un groupe existant dans la liste, ou·
Type un nom pour générer un nouveau groupe gabarit , ou·
Laissez ce champ vide, pour ne pas placer le Fragment Gabarit dans un groupe·

Le Groupe Gabarit détermine l'emplacement du Fragment Gabarit dans l'onglet 'Ressources' de la fenêtre
Navigateur .

6 Cliquez sur le bouton OK .

Le Document Gabarit Designer s'affiche dans le Diagramme Vue .

7 Définissez le contenu de votre fragment Gabarit ; les étapes réelles que vous suivez dépendent de la
source de données sur laquelle vous souhaitez que le fragment Gabarit agisse :

Données du modèle Gabarit du document normal·
Sélecteur Gabarit·
SQL personnalisé·
Scripts personnalisés·
Script de document·
Script XML personnalisé·

8 Une fois que vous avez créé le Fragment Gabarit , vous l'incorporez dans un gabarit normal (ou dans un
Fragment Gabarit existant, si vous préférez).

Notes

Les requêtes personnalisées et la section gabarit personnalisé ne peuvent être utilisées que dans les fragments·
Gabarit ; ils ne peuvent pas être utilisés dans gabarits normaux d'un document complet

Comme pour gabarits de documents normaux, les fragments Gabarit peuvent également être créés et ouverts via·
l'onglet "Ressources" de la fenêtre Navigateur .

Les fragments Gabarit dans l'onglet « Ressources » sont conservés dans un dossier Fragments dans chacun des·
dossiers Publication de documents > Gabarits système et Publication de documents > Gabarits personnalisés , et
sont indiqués par un symbole T.

Si vous disposez d'un gabarit existant que vous souhaitez utiliser comme fragment Gabarit , copiez le gabarit comme·
base d'un nouveau fragment.

Le filtrage fonctionne uniquement pour le gabarit dans lequel il est défini et ne se propage pas à travers les·
sous-modèles/fragments ; vous pouvez définir le filtrage pour chaque sous-modèle séparément, dans les options de
document du sous-modèle

Si vous intégrez un Fragment Gabarit dans un autre Fragment, la génération de rapport à partir du gabarit parent sera·
plus lente

Si vous avez une colonne ou un nœud portant le nom EABOOKMARK, cela insérera un signet de document autour·
de la section parent dans le panneau « Contenu »
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Comment définir un fragment de sélecteur Gabarit

Un sélecteur Gabarit est un fragment Gabarit qui appelle d'autres fragments Gabarit , en fonction du type d'élément
signalé. Les fragments Gabarit appelés peuvent être des fragments système ou des fragments existants définis par
l'utilisateur, comme indiqué dans l'onglet « Ressources » de la fenêtre Navigateur .

Accéder

Utilisez l'une des méthodes décrites ici pour afficher la page « Query personnalisée » de la dialogue « Options du
document ». Avant de sélectionner l'icône Options du document, cochez la case « Personnalisé » dans la liste « Sections
» pour activer les balises « personnalisé > <personnalisé ». Ceux-ci sont nécessaires au fonctionnement du fragment
Gabarit Selector.

Ruban Publier > Rapports de Modèle > Gabarits : <sélectionner un modèle de fragment>

:  (icône Options du document) > Query personnalisée

Raccourcis Clavier
F8 > Gabarits | Fragments | Double-cliquez sur <Fragment name>, puis sur
(icône Options du document) > Query personnalisée

Configurer le sélecteur Gabarit

Option Action

Sélecteur Gabarit Cliquez sur ce bouton radio pour définir les commandes de sélection gabarit .

Champ de données Sur des lignes séparées, tapez chaque type d'élément et le nom du fragment Gabarit
à utiliser pour ce type d'élément, au format :

ElementType : <stéréotype> : Nom du fragment

Par exemple (éléments non prolongés par un stéréotype) :

Action :: Comportementale

ActionPin :: Comportementale simple

CollaborationUse::Structural

et (élément prolongé par un stéréotype) :

Classe : tableau : Base de données Tableau

Pour identifier le fragment à utiliser si des éléments signalés n'ont pas été
spécifiquement identifiés, tapez :

par défaut :: Nom du fragment

Consultez également la section Notes de cette rubrique.

OK Cliquez sur ce bouton pour enregistrer les modifications que vous avez apportées et
fermer la dialogue « Options du document ».

Notes
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Autres conseils sur la fourniture d'une valeur pour le champ de données :

Dans une certaine mesure, vous pouvez adapter la ligne « étendu par stéréotype » en fonction du langage modélisation
alternatif que vous utilisez, de ce que vous souhaitez spécifiquement extraire dans le rapport et des éléments qui existent
sous le Paquetage ou l'élément sur lequel vous exécutez le rapport. Par exemple:

Extraire les éléments ArchiMate Métier Actor·
- A partir d'une structure contenant des éléments UML et ArchiMate - Classe : ArchiMate_Business
Actor:BusActFrag
- A partir d'une structure contenant uniquement des éléments ArchiMate - Class:BusinessActor:BusActFrag
- A partir d'une structure contenant uniquement des éléments ArchiMate Métier Actor - Class::BusActFrag

Extraire les éléments Métier Acteur·
- A partir d'une structure contenant des éléments UML et ArchiMate - Classe : Métier Acteur :BusActFrag
- A partir d'une structure contenant uniquement des éléments ArchiMate - Class:BusinessActor:BusActFrag
- A partir d'une structure contenant uniquement des éléments Métier Actor - Class::BusActFrag

Pour établir les détails du type et du stéréotype d'un élément représentatif sélectionné dans l'onglet 'Ressources' de la
fenêtre Navigateur , exécuter cette requête dans le bloc-notes SQL (utilisez l'option du ruban 'Explorer > Rechercher >

Modèle :  > SQL Scratch Pad') :

Sélectionnez t_object. nom , t_object. Object_Type , t_object. Stéréotype de t_object où t_object. Object_ID =·
#CurrentElementID#

Par exemple, sélectionner un DataObject BPMN dans la fenêtre Navigateur et exécuter ce SQL donne :

Nom - Liste des problèmes[Initial]

Object_Type - Artefact

Stéréotype - DataObject

Vous utiliseriez donc la combinaison Artifact:DataObject:<fragment name> dans le champ de données

Alternativement, ne pas utiliser de fragment de Sélecteur Gabarit et créer un gabarit simple pour opérer sur la section
'Élément' du rapport, pour extraire les éléments de Type - Classe et Stéréotype - Métier Acteur. Exécuter ceci sur le(s)
élément(s) spécifique(s).

Pour un exemple complet, faites une copie du sélecteur Gabarit fourni par le système dans Document Publishing |
Système Gabarits | Dossier Fragments de l'onglet 'Ressources' de la fenêtre du Navigateur et révision de l'onglet ' Query
personnalisée' de la dialogue dialogue 'Options du document'. (Pour faire une copie, cliquez-droit sur le nom gabarit et
sélectionnez l'option 'Copier'.)
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Comment définir un fragment SQL personnalisé

Vous pouvez créer un fragment Gabarit pour renvoyer les données d'une Query SQL. Pour ce faire, définissez une Query
SQL dans les « Options du document » du fragment Gabarit , puis ajoutez des champs dans la section « Personnalisé » de
votre fragment Gabarit qui font référence aux colonnes renvoyées par la Query SQL. La Query dépend du SGBD et peut
donc varier en fonction du SGBD que vous utilisez.

Créer un fragment Query SQL

Étape Action

1 Ouvrez ou créez un fragment Gabarit dans l'éditeur de document Gabarit .

2 Dans l'éditeur de documents Gabarit :

Cliquez sur l'icône Options du document  .·
La dialogue « Options du document » s'affiche.

Sélectionnez la page ' Query personnalisée'·
Dans le panneau « Gabarit Fragment type », sélectionnez le bouton radio Custom SQL .·

3 Dans le champ de texte principal de l'onglet, saisissez la Query SQL à exécuter sur votre modèle.

Pour plus de détails, consultez la rubrique d'aide Créer une Query SQL personnalisée .

4 Cliquez sur le bouton OK pour fermer la dialogue « Options du document ».

5 Dans l'éditeur 'Document Gabarit ', dans le panneau 'Sections', cochez la case 'Personnalisée' pour générer
la section 'Personnalisée'.

6 Dans la section « Personnalisé », cliquez-droit et sélectionnez l'option « Insérer un champ personnalisé ».
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Une prompt s'affiche pour le nom du champ à créer.

7 En réponse à l' prompt , tapez le nom de la colonne renvoyée par votre Query ; par exemple, Note
.Formaté.

Cliquez sur le bouton OK .

8 Répétez les étapes 6 et 7 pour chaque colonne que vous souhaitez inclure dans votre rapport.

Ajoutez tout autre formatage et contenu dont vous avez besoin au fragment Gabarit .

11 Enregistrez le fragment Gabarit et ajoutez-le à un gabarit de document normal.
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Créer une Query SQL personnalisée

Lorsque vous définissez votre propre instruction SQL pour un fragment gabarit , un certain nombre d'options sont
disponibles pour vous aider à fournir le format de rapport souhaité. La requête dépend du SGBD, la structure peut donc
varier en fonction du fichier de référentiel spécifique ou du type de SGBD que vous utilisez.

Options Query

Option Description

Sous-chaînes de macro Dans le champ de texte principal de l'onglet, saisissez la Query SQL à exécuter sur
votre modèle. Vous pouvez utiliser #<macro>#s comme substitutions string ,
comme pour les autres requêtes de recherche SQL.

La Query SQL peut référencer l' ID de l'élément, diagramme ou Paquetage en cours
de traitement par le document gabarit , à l'aide des macros :

#IDOBJET#·
#DIAGRAMIDE#·
#IDPAQUET#·

Par exemple:

SELECT Count ( Object_Type ) AS CountOfActors·
DE t_objet
OÙ Object_Type = "Acteur" et Package_ID = #PACKAGEID#

Il existe un certain nombre d'autres macros utiles telles que :

#Concat <valeur1>, <valeur2>, ...#·
#WC# Wildcard pour votre type de base de données spécifique.·

Pour plus de détails, consultez la rubrique d'aide Créer des définitions de recherche
.

Notes formatées (sauf .eap) Pour les champs notes , comme les Notes d'élément (t_object. note ), le formatage
est stocké sous forme de texte enrichi. Il est possible qu'un champ note soit traité à
partir de données brutes vers un texte riche lisible en fournissant une colonne dans
ce format :

{<nom du champ>.Formaté}

Ceci est défini dans la section Personnalisée du Gabarit . Par exemple :

personnalisé >·
{ Note .Formaté }
< personnalisé

Dans votre instruction Query SQL personnalisée, vous devez utiliser un alias
correspondant au nom du champ gabarit ; par exemple (sous MySQL) :

SÉLECTIONNER ea_guid AS CLASSGUID, Object_Type AS CLASSTYPE,·
Nom, Note comme " Note .Formatted"
DEPUIS t_objet
Où Object_ID=#OBJECTID#

Notes formatées pour les
référentiels .eap

Pour notes formatées utilisant des référentiels de fichiers .eap, le format nécessite :

{<nom du champ>.Formaté}

Par exemple:

personnalisé >·
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{ Note .Formaté}
< personnalisé

Dans votre instruction Query SQL personnalisée, formatez l'alias de champ comme
« [<fieldname>-Formatted] ». Par exemple:

SÉLECTIONNER ea_guid AS CLASSGUID, Object_Type AS CLASSTYPE,·
Nom, Note AS [Note-Formatted]
DEPUIS t_objet
Où Object_ID=#OBJECTID#

Liens hypertextes (hors
.eap)

Vous pouvez transformer des entrées de colonne en hyperliens faisant référence à
d'autres entrées dans le document généré. Le champ d'entête de colonne (dans le
texte gabarit , dans le panneau 'Personnalisé') doit utiliser le format :

<nom du champ>.Hyperlien

Par exemple:

personnalisé >·
{ Type .Hyperlien}
< personnalisé

Les entrées ou valeurs de la colonne SQL doivent avoir le format : { guid }<
LABEL>

Par exemple:

SELECT # Concaténer ea_guid , Nommer # comme " Type .Hyperlien"·
DE t_objet
OÙ ID_Objet = # IDOBJET # ;

Note : cela utilise le #Concat ...# pour concaténer la référence GUID et l'expression
extérieure du lien hypertexte.

Dans ce format, {guid} est le GUID de l'élément vers lequel créer un lien et
LABEL est le texte du lien hypertexte (tel que le nom de l'élément), soit inséré
manuellement, soit renvoyé par une autre commande. Par exemple:

{570CFDAB-00A4-48d9-AE87-9CD6920418C0}Classe2

Dans le rapport généré, cela s'affiche sous la forme d'un lien hypertexte « Class2 »,
qui renvoie à la description de Class2 dans le document.

Cet exemple renvoie le nom sous forme de lien hypertexte de chaque classe de base
(parente) de l'élément actuellement signalé :

SELECT # Concaténer t_object. ea_guid, t_object . Nom # AS "·
BaseClassName.Hyperlink"
DE t_object, t_connector
OÙ t_connector.Start_Object_ID = #OBJECTID#
AND t_object.Object_ID = t_connector.End_Object_ID
AND t_connector.Connector_Type = 'Généralisation'

Cette requête peut renvoyer plusieurs entrées, auquel cas les entrées sont signalées
une par ligne. Vous pouvez, si nécessaire, avoir plusieurs instructions de requête
Hyperlink, séparées par des virgules. Vous pouvez créer un lien hypertexte vers les
éléments, attributs, opérations, diagrammes et Paquetages signalés.

Liens hypertextes vers les
référentiels .eap

Le format de nom de champ Lien hypertexte pour les référentiels .EAP nécessite :

personnalisé >·
{<nom du champ> . Lien hypertexte}
< personnalisé

Et le SQL utilise : [<fieldname>-Hyperlink] :

SELECT #Concat t_object . ea_guid, t_object.Name# AS·
[BaseClassName-Hyperlink]
DE t_object, t_connector
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OÙ t_connecteur . Start_Object_ID = #OBJECTID#
AND t_object.Object_ID = t_connector.End_Object_ID
AND t_connector.Connector_Type = 'Généralisation'

Notes

Un élément Filtre ne s'appliquera pas à la section 'Personnalisée' dans un Fragment Gabarit·
Dans vos instructions SQL, vous pouvez référencer les détails du modèle en utilisant :·
- #OBJECTID# renvoie l' ID de l'élément en cours de traitement par le gabarit du document
- #PACKAGEID# et #Package# renvoient l' ID du Paquetage en cours
traité par le gabarit du document
- #Author# prend le nom d'utilisateur du champ 'Auteur' de la page 'Général' du
dialogue 'Préférences', pour que la recherche définie puisse être effectuée sur les objets créés
par cet utilisateur (cette valeur peut être réinitialisée manuellement dans la dialogue 'Préférences')

Vous pouvez tester votre Query SQL à l'aide de l'éditeur SQL dans la fenêtre Rechercher dans Projet·
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Comment définir un fragment de script personnalisé

Vous pouvez créer un Fragment Gabarit pour renvoyer les données d'un Script Modèle . Pour ce faire, créez un script qui
renvoie une string XML dans un format spécifique. Vous ajoutez une référence à ce script dans les « Options du
document du fragment Gabarit », puis ajoutez des champs dans la section « Personnalisé » de votre fragment Gabarit qui
font référence aux données renvoyées par le script.

Création d'un fragment de script

Étape Action

1 A l'aide de la fenêtre Scriptant , créez un Modèle Script qui renvoie une string au format XML.

Voir les exemples de :

Un script qui renvoie les données au format XML approprié ( exemple de script de fragment Gabarit )·
Le format XML que le script doit renvoyer pour qu'il puisse être utilisé par un fragment Gabarit (·
exemple de sortie d'un script de fragment Gabarit )

2 Ouvrez ou créez un fragment Gabarit dans l'éditeur de document Gabarit .

Cliquez-droit sur le fond Gabarit et cliquez sur l'icône  .

La dialogue « Options du document » s'affiche.

3 Sélectionnez l'onglet ' Query personnalisée' et, dans le panneau 'Type de fragment Gabarit ', sélectionnez
l'option 'Script personnalisé'.

Un champ vide s'affiche à droite des options.

4 Cliquez sur la flèche déroulante et sélectionnez votre script dans la liste.

5 Dans le champ de texte principal de l'onglet, saisissez le point d'entrée de votre script qui renvoie les
données XML.

Par exemple, si vous utilisiez l'exemple de script mentionné à l'étape 1, en JScript, le point d'entrée serait :

MesRtfData(#OBJECTID#);

Pour transmettre les informations Paquetage , vous pouvez remplacer #OBJECTID# par #PACKAGEID#.
(De plus, pour VBScript, omettez le point-virgule à la fin.)

Cela s'applique à l'instruction appelante (et non au script appelé), qui peut également faire référence à :

#Branch# - obtient les identifiants des Paquetages enfants du Paquetage actuel en cours de traitement,·
en travaillant de manière récursive jusqu'au niveau le plus bas du sous-paquet ; ceci n'est valable que
lors du traitement d'un Paquetage - les éléments renvoient une valeur 0

#Package# - (comme pour #PACKAGEID) obtient le package_ID du Paquetage actuellement·
sélectionné

6 Cliquez sur le bouton OK pour fermer la dialogue « Options du document ».

7 Dans l'éditeur Document Gabarit , dans le panneau 'Sections', cochez la case 'Personnalisée' pour générer
la section personnalisée.

8 Dans la section « Personnalisé », cliquez-droit et sélectionnez l'option « Insérer un champ personnalisé ».

Une prompt s'affiche pour le nom du champ à créer.
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9 En réponse à l' prompt , tapez le nom du champ de données renvoyé par votre script.

En vous référant à l'exemple de l'étape 1, vous ajouteriez DateGen.

Cliquez sur le bouton OK .

dix Répétez les étapes 8 et 9 pour chaque champ de données que vous souhaitez inclure dans votre rapport.

Ajoutez tout autre formatage et contenu dont vous avez besoin au fragment Gabarit .

11 Enregistrez le fragment Gabarit et ajoutez-le à un document Gabarit normal.

Notes

Scripts ont une limite de 60 secondes par appel avant que le contrôle ne soit rendu au générateur de documents.·
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Exemple de script de fragment Gabarit

Ce JScript renvoie une ligne de données au format XML. Les données XML peuvent être renvoyées dans un rapport de
document à l'aide d'un fragment Gabarit de script personnalisé.

Le script affichera également les données XML dans la fenêtre Sortie système, afin que vous puissiez facilement vérifier
la sortie sans exécuter de rapport de document.

!INC Scripts locaux .EAConstants-JScript

/*

* Nom du script : Propriétés du document

*Auteur : Tom O'Reilly

* Objectif : Afficher les propriétés d'un document

* Date : 02/02/2013

*/

fonction MyRtfData (objectID)

{

var je;

var xmlDOM = new ActiveXObject("MSXML2.DOMDocument.4.0");

xmlDOM.validateOnParse = false ;

xmlDOM.async = faux ;

var node = xmlDOM.createProcessingInstruction("xml", "version='1.0' encoding='ISO-8859-1' " );

xmlDOM.appendChild(nœud);

var xmlRoot = xmlDOM.createElement("EADATA");

xmlDOM.appendChild(xmlRoot);

var xmlDataSet = xmlDOM.createElement("Dataset_0");

xmlRoot.appendChild(xmlDataSet);

var xmlData = xmlDOM.createElement("Données");

xmlDataSet.appendChild(xmlData);

var xmlRow = xmlDOM.createElement("Row");

xmlData.appendChild(xmlRow);

var xmlName = xmlDOM.createElement("DateGen");

var aujourd'hui = new Date();

var jj = aujourd'hui.getDate();

var mm = aujourd'hui.getMonth()+1; //Janvier est 0 !

var aaaa = aujourd'hui.getFullYear();

if(dd<10){dd='0'+dd} if(mm<10){mm='0'+mm} aujourd'hui = mm+'/'+dd+'/'+aaaa ;

xmlName.text = aujourd'hui ;

xmlRow.appendChild(xmlName);

var xmlName = xmlDOM.createElement("TimeGen");

var heure actuelle = nouvelle date ()

var heures = currentTime.getHours()

var minutes = currentTime.getMinutes()
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si (minutes < 10)

{

minutes = "0" + minutes

}

xmlName.text = heures + " : " + minutes + " " ;

xmlRow.appendChild(xmlName);

var xmlName = xmlDOM.createElement("Auteur");

xmlName.text = Session.UserName ;

xmlRow.appendChild(xmlName);

var xmlName = xmlDOM.createElement("EA_REPOS");

xmlName.text = Référentiel . ConnectionString ;

xmlRow.appendChild(xmlName);

renvoyer xmlDOM.xml ;

} ;

Session.Output(MyRtfData(439));
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Exemple de sortie d'un script de fragment Gabarit

Vous pouvez créer un fragment Gabarit pour renvoyer les données d'un script Modèle dans un rapport de document. Le
script doit renvoyer une ou plusieurs lignes de données dans ce format XML :

<EADATA>

<Ensemble de données_0>

<Données>

<Ligne>

<DateGen>01/09/2013</DateGen>

<TimeGen>9h31 </TimeGen>

<Auteur>Jean</Auteur>

<EA_REPOS>C:\Users\John\Documents\Sample Modèle .eap</EA_REPOS>

</Rangée>

</Données>

</Ensemble de données_0>

</EADATA>

Chacun de ces champs de données dans le XML (tels que « DateGen », « TimeGen ») fait référence à des champs qui
peuvent être inclus dans la section « Personnalisé » d'un fragment Gabarit .

Notes

Si le texte est une Note formatée, ajoutez formatted="1" à la ligne du champ ; Par exemple:·
<Auteur formatted="1"><i>Jean</i></Auteur>
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Comment définir un fragment de script de document

Vous pouvez créer un fragment Gabarit pour renvoyer les données d'un script de document. Pour ce faire, créez un script
qui renvoie soit une string vide, soit une string contenant du RTF brut. Vous ajoutez une référence à ce script dans les «
Options du document Gabarit Fragment » et la string RTF renvoyée est ajoutée au document généré.

An Example Script

This is an example of a Document Script you might create:

!INC Local Scripts.EAConstants-JScript

function main()

{

     var reporting as EA.DocumentGenerator;

     reporting = CreateDocumentGenerator();

     if(reporting != null)

     {

          if(reporting.NewDocument(""))

          {

               if(!reporting.LoadDocument("<filename>"))

               {

                    Session.Output( "Error: " + reporting.GetLastError() );

               }

               return reporting.GetDocumentAsRTF();

          }

     }

}

Créer un fragment de script de document

Étape Action

1 Ouvrez ou créez un fragment Gabarit dans l'éditeur de document Gabarit .

2
Dans l'éditeur de documents Gabarit , cliquez-droit sur le fond Gabarit et cliquez sur l'icône  .

La dialogue « Options du document » s'affiche.

3 Sélectionnez la page ' Query personnalisée'.

4 Dans le panneau « Type de fragment Gabarit », sélectionnez le bouton radio « Script de document ».

5 Un champ s'affiche à droite du panneau de boutons radio ; cliquez sur la flèche déroulante et sélectionnez
le script Modèle à utiliser par votre fragment Gabarit .
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6 Dans le champ de texte principal de l'onglet, saisissez le point d'entrée de votre script qui renvoie le texte
RTF.

Par exemple, en JScript, l'appel à votre script serait sous la forme :

Principal(#OBJECTID#);

(Pour VBScript, omettez le point-virgule à la fin.)

7 Cliquez sur le bouton OK pour fermer la dialogue « Options du document ».

8 Dans l'éditeur 'Document Gabarit ', dans le panneau 'Sections', cochez la case 'Personnalisée' pour créer la
section 'Personnalisée'.

9 Enregistrez le fragment Gabarit et ajoutez-y un appel dans un gabarit de document normal.

Lorsque exécuter , cela renverra une string RTF qui est incorporée au document généré.

Notes

Les macros Modèle Search #..# peuvent être utilisées dans l'instruction call qui appelle la procédure, mais pas dans·
le code de la procédure ; dans votre relevé d'appel, vous pouvez référencer les détails du modèle en utilisant :
- #OBJECTID# pour retourner l' ID de l'élément en cours de traitement par le gabarit du document
- #PACKAGEID# et #Package# pour renvoyer l' ID du Paquetage en cours de traitement par le
gabarit de document
- #Branch# pour obtenir les identifiants des Paquetages enfants du Paquetage actuel en cours de traitement,
fonctionnant
récursivement jusqu'au niveau le plus bas du sous-package ; ceci n'est valable que lors du traitement d'un Paquetage ,
les éléments renvoient une valeur 0
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Comment définir un fragment de script XML personnalisé

Dans un fragment gabarit , vous pouvez créer une requête pour rapporter les valeurs d'un fichier XML produit par un
script généré précédemment ; par exemple, les données d'une simulation. La requête opère sur des données statiques qui
ne sont pas mises à jour lors de la génération du document.

Un exemple Query

Voici un exemple du format de requête :

Nom du fichier=<chemin du fichier>\<nom du fichier>.xml

XPath=/EADATA/Dataset_0/Data/Row

La première ligne est l'emplacement du fichier XML à traiter, et la deuxième ligne est la requête à effectuer sur ce
fichier, en supposant que le contenu du fichier est :

<EADATA>

<Ensemble de données_0>

<Données>

<Row Name="NameValue" Second="Value2"></Row>

<Nom de la ligne="NomValeur2"></Ligne>

</Données>

</Ensemble de données_0>

</EADATA>

Vous pouvez ensuite ajouter des champs dans la section « Personnalisé » de votre fragment Gabarit , pour faire référence
aux données renvoyées par la requête. Par exemple, vous pouvez modifier :

personnalisé >

[clic droit pour insérer des champs personnalisés]

< personnalisé

donner:

personnalisé >

Nom - Deuxième

< personnalisé

Création d'un fragment de script XML personnalisé

Étape Action

1 À l'aide de la fenêtre Scriptant , créez un script Modèle qui renvoie un fichier XML.

2 Ouvrez ou créez un fragment Gabarit dans l'éditeur de document Gabarit .
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Cliquez-droit sur le fond Gabarit et cliquez sur l'icône  .

La dialogue « Options du document » s'affiche.

3 Sélectionnez l'onglet ' Query personnalisée' et, dans le panneau 'Type de fragment Gabarit ', sélectionnez
l'option 'XML personnalisé'.

4 Dans le champ de texte principal de l'onglet, saisissez le point d'entrée de votre script qui renvoie les
données XML. Par exemple:

Nom du fichier=<chemin du fichier>\<nom du fichier>.xml

5 Cliquez sur le bouton OK pour fermer la dialogue « Options du document ».

6 Dans l'éditeur Document Gabarit , dans le panneau 'Sections', cochez la case 'Personnalisée' pour générer
la section personnalisée.

7 Dans la section « Personnalisé », cliquez-droit et sélectionnez l'option « Insérer un champ personnalisé ».

Une prompt s'affiche pour le nom du champ à créer.

8 En réponse à l' prompt , tapez le nom du champ de données renvoyé par votre script.

Cliquez sur le bouton OK .

9 Répétez les étapes 7 et 8 pour chaque champ de données que vous souhaitez inclure dans votre rapport.

Ajoutez tout autre formatage et contenu dont vous avez besoin au fragment Gabarit .

dix Enregistrez le fragment Gabarit et ajoutez-le à un document Gabarit normal.

Notes

L'instruction appelante (et non le script appelé) peut référencer l' ID de l'élément ou Paquetage en cours de·
traitement par le gabarit du document, à l'aide des macros #OBJECTID# ou #PACKAGEID# ; par exemple,
MyRtfData(#OBJECTID#) :
- #Branch# récupère les identifiants des Paquetages enfants du Paquetage en cours de traitement,
travailler de manière récursive jusqu'au niveau le plus bas du sous-package ; ceci n'est valable que lorsque
traitement d'un Paquetage - les éléments renvoient une valeur 0
- #Package# obtient le package_ID du Paquetage actuellement sélectionné
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Ajouter des fragments à un document Gabarit

Un fragment Gabarit est un gabarit qui peut être utilisé comme une sous-section plus petite d'un gabarit de document
normal. Vous ne générez pas de rapport à partir d'un fragment Gabarit seul ; à la place, vous utilisez un gabarit normal
qui inclut des références à un ou plusieurs fragments Gabarit .

Les fragments peuvent être appelés dans ces sections du gabarit :

Paquetage·
Élément·
Attribut·
Méthode·

Ils ne peuvent pas être appelés dans d’autres sections. Lors de la génération d'un rapport de document, lorsque le
générateur de rapport traite chaque section du gabarit , s'il rencontre une référence à un fragment Gabarit , il traitera ce
fragment, en insérant sa sortie à l'emplacement approprié du rapport généré.

Accéder

Ruban Publier > Rapports de Modèle > Gabarits

Raccourcis Clavier F8 > Gabarits

Incorporer des fragments Gabarit dans un document Gabarit

Étape Action

1 Créez le(s) fragment(s) Gabarit à inclure dans gabarit de votre document, ou identifiez les fragments
Gabarit du système à utiliser.

2 Créez un nouveau gabarit de document ou ouvrez un gabarit existant dans l'éditeur de documents.

3 Dans le panneau « Sections », cochez la case en regard de chaque section qui fera référence au(x)
fragment(s) Gabarit (« Paquetage », « Élément », « Attribut » ou « Méthode »).

4 Dans le panneau 'Contenu', à l'endroit approprié dans l'une de ces sections, cliquez-droit et sélectionnez
l'option 'Insérer Gabarit '.

La dialogue « Sélectionner Gabarit » s'affiche.

5 Cliquez sur la flèche déroulante et sélectionnez le fragment Gabarit à insérer.

6 Cliquez sur le bouton OK .

La balise { Gabarit - < nom gabarit >} est insérée à la position courante du curseur.

7 Répétez les étapes 4 à 6 pour chaque fragment que vous souhaitez insérer dans le gabarit du document.

Effectuez tout autre travail que vous devez effectuer sur le gabarit , puis enregistrez-le et utilisez-le pour
exécuter des rapports.
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Modification ou changement de fragments Gabarit

Cliquez-droit sur la balise Gabarit rouge > <option obligatoire>.

Option Action

Vue / Modifier un fragment Ouvre le fragment Gabarit sélectionné dans une autre instance de l'éditeur
Document Gabarit .

Si vous avez sélectionné un fragment système, vous pouvez afficher le fragment
mais pas le modifier. Si vous avez sélectionné un fragment Modèle (créé par
l'utilisateur), vous pouvez modifier le fragment.

Remplacer le fragment (Option disponible pour un fragment système sélectionné)

Ouvre une autre instance de l'éditeur Document Gabarit , où le fragment système
est dupliqué en tant que fragment Modèle (créé par l'utilisateur) portant le même
nom. Vous pouvez modifier ce fragment et l'enregistrer, et le gabarit original
appliquera ce nouveau fragment Modèle à la place.

Fragment de commutation Affiche la dialogue 'Sélectionner Gabarit ' ; cliquez sur la flèche déroulante et
sélectionnez un autre fragment Gabarit .

Notes

Vous pouvez également ajouter un fragment Gabarit à un gabarit de document en localisant le fragment dans le·
dossier Publication de documents dans l'onglet « Ressources » de la fenêtre du Navigateur et en faisant glisser le
fragment dans l'éditeur de documents ; Les fragments Gabarit sont conservés dans les dossiers Fragments des
dossiers System Gabarits et Custom Gabarit .

Pour supprimer un fragment Gabarit d'un Gabarit , faites glisser le curseur le long du nom inséré pour le mettre en·
surbrillance, puis appuyez sur la touche Suppr.

Il est possible d'incorporer un fragment Gabarit dans un autre fragment ; cependant, cela ralentira la génération de·
rapports
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Comment Générer des documents

Lorsque vous souhaitez générer un rapport de document sur une partie de votre modèle, vous disposez de plusieurs
options pour sélectionner l' object à documenter et pour définir la manière dont votre document doit être généré.

Un rapport de document décrit un élément ou, plus généralement, un Paquetage dans le modèle ; par conséquent, votre
première étape consiste à sélectionner le Paquetage ou l'élément pour lequel générer le document, parmi :

Fenêtre Navigateur·
Diagramme·
Navigateur Paquetage·
Gestionnaire de Spécification·
Liste Diagramme ou·
Recherche Modèle·

Pour un Paquetage , vous pouvez également définir la façon dont les diagrammes du Paquetage doivent être présentés
dans le document ; vous faites cela dans la dialogue ' Propriétés ' diagramme pour chaque diagramme . Lorsque vous
avez préparé et sélectionné votre Paquetage , vous ouvrez la dialogue ' Générer Documentation' et configurez les
paramètres de génération du document.

Un tutoriel permettant de créer rapidement un document de base à partir du modèle Exemple est fourni dans le deuxième
de ces deux tableaux . Répétez le didacticiel avec différentes sélections dans les champs déroulants pour voir ce que le
système peut générer automatiquement pour vous.

Accéder

Sélectionnez un Paquetage ou un élément pour lequel générer de la documentation, puis ouvrez la dialogue ' Générer
Documentation' en utilisant l'une de ces méthodes.

Ruban Publier > Rapports de Modèle > Générateur de Rapports > Générer Documentation

Barre d'outils de la fenêtre
Navigateur  | Documents | Générer la Documentation (RTF/PDF/DOCX)

Raccourcis Clavier F8

Générer des rapports

Option Détail

Manières alternatives
d'ouvrir le dialogue '
Générer Documentation'

Utilisez l'une de ces méthodes :

Dans le Gestionnaire de Spécification , cliquez sur l'option de ruban '·
Spécification - Spécifier > Elément > Documentation > Générer
Documentation (RTF/PDF/DOCX)'

Dans la Liste Diagramme , Paquetage Navigateur ou Modèle Recherche,·
sélectionnez un ou plusieurs éléments, cliquez-droit et sélectionnez soit
'Documentation | Générer une documentation pour chaque Item sélectionné ' ou
'Documentation | Générer de la documentation pour Items sélectionnés '

Générer un rapport sur des Lorsque vous choisissez de créer un rapport à partir des outils Diagramme List,
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éléments de Paquetage
Navigateur ou Modèle
Search

Paquetage Navigateur ou Modèle Search, vous pouvez générer un rapport au niveau
de l'élément plutôt qu'un rapport au niveau du package, et vous disposez d'une
flexibilité supplémentaire dans la sélection :

Le type d'élément à signaler·
Les éléments spécifiques à signaler, ensemble ou séparément, qu'ils soient dans·
un même Paquetage ou non

Par exemple, vous souhaiterez peut-être rechercher tous les éléments avec des cas
de test, dans le but de créer un rapport sur certains, voire tous, de ces éléments ;
avec la Liste Diagramme ou Paquetage Navigateur , vous identifierez vous-même
ces éléments dans la liste de tous les éléments d'un diagramme ou Paquetage
sélectionné, mais avec la Recherche Modèle , vous pouvez sélectionner
automatiquement les éléments dans une section du modèle ou dans l'ensemble du
modèle. , comme demandé.

Le filtrage de recherche peut concerner des cas de test spécifiques ; cependant, les
résultats sont par élément, donc s'il existe des cas de test en dehors de la plage dans
un élément comportant un test filtré, ces éléments sont également répertoriés.

Après avoir généré la liste des éléments, vous pouvez sélectionner des éléments
individuels, des blocs d'éléments ou tous les éléments, puis utiliser le menu
contextuel pour générer un rapport sur tous les éléments sélectionnés, ou un rapport
distinct sur chaque élément.

Générer et visualiser immédiatement un exemple de rapport

Étape Action

1 Ouvrez le projet EAExample.

2 Dans la fenêtre Navigateur , développez Tester Vue et cliquez sur Tester Paquetage .

3 Sélectionnez l'option de ruban 'Publier > Rapports de Modèle > Générateur de Rapports > Générer
Documentation'.

La dialogue ' Générer Documentation' s'affiche.

4
Dans le champ « Sortie vers un fichier », cliquez sur le bouton  et recherchez un emplacement de
fichier pratique dans lequel conserver le rapport généré. Incluez l'extension de fichier appropriée pour
définir le format de document (PDF, RTF, DOCX) du rapport généré.

5 Dans le champ ' Gabarit ', cliquez sur la flèche déroulante et sélectionnez ' Rapport de base'.

6 Dans le champ « Tableau des matières », cliquez sur la flèche déroulante et sélectionnez « TOC
(portrait) ».

7 Dans le champ « Feuille de style », cliquez sur la flèche déroulante et sélectionnez « Styles – Support
d'impression ».

8 Dans le champ « Page de couverture », cliquez sur la flèche déroulante et sélectionnez « Page de
couverture (portrait) ».

9 Cliquez sur le bouton Générer .
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dix Une fois le rapport généré, cliquez sur le bouton Vue et examinez le rapport.

Notes

Rapports peuvent être configurés pour inclure tous Paquetages au sein d'un Paquetage parent, ou uniquement le·
niveau supérieur.
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Génération de documents de base

Il est possible de spécifier un large éventail de paramètres pour contrôler la façon dont votre rapport de document est
généré et sorti. Vous pouvez spécifier, par exemple, où le fichier de document est écrit et dans quel format il est généré,
dans quelle langue il est généré et quels éléments sont inclus dans le document. Vous définissez ces options dans la
dialogue ' Générer Documentation', dans laquelle les options sont proposées sur plusieurs onglets.

Le premier onglet, par défaut, est l'onglet ' Générer ', sur lequel vous définissez comment et où le document est généré.
Après avoir défini les options sur l'un ou tous les autres onglets, vous revenez à l'onglet ' Générer ' et cliquez sur le
bouton Générer pour produire votre document.

Accéder

Sélectionnez un Paquetage ou un élément pour lequel générer de la documentation, puis ouvrez la dialogue ' Générer
Documentation' en utilisant l'une des méthodes décrites ici.

Ruban Publier > Rapports de Modèle > Générateur de Rapports > Générer Documentation
> Générer

Raccourcis Clavier F8 | Générer

Définir les options de génération Rapport

Option Action

Modèle de document

 Élément racine

 Paquetage de racines

Vérifiez le nom de l'élément sélectionné dans la fenêtre Navigateur , diagramme ,
Diagramme List, Gestionnaire de Spécification ou Modèle Search.

S'il s'agit de l'élément Modèle Document spécialement créé pour un document
virtuel, le champ est « Modèle Document ».

Sinon, ce champ identifie l'élément sélectionné de la hiérarchie sur lequel faire
l'objet d'un rapport ; c'est-à-dire l'élément Root ou Root Paquetage .

Sortie dans un fichier Type ou sélectionnez l'emplacement et le nom de fichier de la documentation
générée.

Cliquez sur le bouton  pour accéder à l'emplacement.

Entrez l'extension de fichier appropriée pour le format de document dans lequel
générer le rapport - PDF, RTF ou DOCX.

Gabarit Cliquez sur la flèche déroulante et sélectionnez le nom du gabarit à utiliser pour
votre rapport de document.

Vous pouvez sélectionner n'importe quel gabarit dans la liste déroulante, qui est
divisée en gabarits personnalisés (ou utilisateur) et gabarits système. Si vous avez
chargé une MDG Technologie contenant gabarits de documents, ceux-ci sont
également répertoriés sous le nom de la Technologie.

Vous pouvez également créer immédiatement un nouveau gabarit , en sélectionnant
l'option '<nouveau modèle>'.

Le système vérifie tous les dossiers gabarit pour le gabarit spécifié, dans l'ordre
Gabarits personnalisés > Gabarits technologiques > Gabarits système . S'il existe
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différents gabarits disponibles sous un même nom, le système utilise le premier
trouvé dans cette séquence.

Page de Couverture Cliquez sur la flèche déroulante et sélectionnez le nom de la définition de page de
garde à appliquer à votre rapport de document.

Vous pouvez sélectionner n'importe quelle définition dans la liste déroulante, qu'il
s'agisse d'un format standard ou d'une page conçue par l'utilisateur.

Utilisez la valeur par défaut <none> pour ne pas inclure de page de garde ou pour
utiliser une page de garde intégrée au gabarit défini par l'utilisateur sélectionné.

Tableau des matières Cliquez sur la flèche déroulante et sélectionnez le nom de la définition du Tableau
des matières à appliquer à votre rapport de document.

Vous pouvez sélectionner n'importe quelle définition dans la liste déroulante, qu'il
s'agisse d'un format de table des matières standard ou d'un format conçu par
l'utilisateur.

Utilisez la valeur par défaut <none> pour ne pas inclure de Tableau des matières ou
pour utiliser un tableau des matières intégré au gabarit défini par l'utilisateur
sélectionné.

Feuille de style Cliquez sur la flèche déroulante et sélectionnez le nom de la feuille de style à
appliquer au rapport de votre document.

Vous pouvez sélectionner n'importe quelle feuille de style dans la liste déroulante,
qu'il s'agisse d'une définition standard ou d'un ensemble de styles conçus par
l'utilisateur.

Utilisez la valeur par défaut ' <none> ' pour ne pas utiliser de feuille de style et
appliquez plutôt les styles définis dans le gabarit que vous avez sélectionné dans le
champ ' Gabarit '.

Thème Diagramme Cliquez sur la flèche déroulante et sélectionnez un thème Diagramme pour
appliquer la couleur, l'épaisseur de ligne et le style de police aux diagrammes
d'éléments du rapport, si ces éléments utilisent des valeurs par défaut.

Si un élément a une apparence personnalisée attribuée à l'aide, par exemple, de la
dialogue « Apparence par défaut », cette apparence remplace les paramètres du
thème.

L'option par défaut est le thème Diagramme que vous avez actuellement défini dans
vos options « Locales ». Vous pouvez toutefois sélectionner n’importe quel autre
thème uniquement pour ce rapport. Le paramètre du champ revient à votre thème
par défaut une fois le rapport généré.

Supprimer des sections Cliquez sur la flèche déroulante et sélectionnez dans une liste de profils de
suppression que vous ou d'autres utilisateurs du modèle avez créés dans l'onglet
'Supprimer la section' de la dialogue ' Générer Documentation'.

Chaque profil de suppression définit les sections du rapport qui peuvent être omises
lorsque vous générez le rapport actuel. Cela vous aide à adapter le rapport à un
public spécifique lors de la génération.

(Vous pouvez également omettre Paquetages enfants de tout rapport généré sur le
Paquetage parent ; voir la rubrique d'aide Exclure Paquetage du document et
Rapport HTML .)

Filigrane Type l'emplacement de l'image à utiliser comme filigrane sur le document, ou

cliquez sur le bouton  pour rechercher l'emplacement.

Laver l'image Si vous avez sélectionné une image en filigrane, cochez cette case pour appliquer
un lavis à l'image avant de l'appliquer au document. Cela rend l'image plus claire
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afin qu'elle ne nuise pas au contenu du rapport imprimé dessus.

Langue Cliquez sur la flèche déroulante et sélectionnez la langue dans laquelle générer le
document. La liste des langues disponibles est définie par l'Administrateur Modèle
sur la page 'Traductions' de la boîte dialogue 'Gérer les Options Modèle '
('Paramètres > Modèle > Options').

Lorsque le document est généré, le générateur inclut dans le document toutes Notes
, noms object et alias qui ont des traductions dans la langue sélectionnée. Si des
champs ne contiennent pas de traduction pour cette langue, le champ du document
correspondant reste vide.

Qualité d'image Cliquez sur la flèche déroulante et sélectionnez le niveau de mise à l'échelle requis
pour reproduire les images du diagramme dans le rapport. Cela détermine la qualité
visuelle de l’image.

Brouillon·
Standard (par défaut)·
Haute résolution·
Très haute résolution·

Quelle que soit la qualité de l'image, toutes les images sont reproduites à une taille
constante.

Document Vue à la fin Cochez cette case pour ouvrir le rapport de document dès qu'il a été généré.

Utiliser des substitutions
linguistiques

Cochez cette case pour activer les substitutions de mots de langue personnalisées.

Décochez la case pour désactiver les substitutions de mots de langue
personnalisées.

Termes du glossaire de
balisage

Cochez cette case pour appliquer, dans tout le rapport RTF généré, tous les styles
appliqués à tous les termes du glossaire via le texte Notes d'un élément.

Un style est appliqué à un terme du glossaire en fonction de son type de terme.

Utiliser la substitution de
glossaire

(Disponible si les termes du glossaire de balisage sont sélectionnés.)

Cliquez sur la flèche déroulante et sélectionnez un type de terme. Pour tous les
termes du glossaire de ce type, chaque fois qu'un terme apparaît dans le rapport, il
sera remplacé par sa signification.

Par exemple, si vous sélectionnez un terme de type « édition », dans le rapport, les
termes « Corp », « Uni » et « Ult » seront remplacés par les significations «
Corporate », « Unified » et « Ultimate », respectivement.

Lot Cliquez sur ce bouton pour afficher la dialogue 'Génération de documents par lots',
pour générer des rapports dans un processus par lots.

Utiliser la visionneuse
interne

Cochez cette case pour activer le bouton Vue afin de lancer le document généré
dans la visionneuse interne Enterprise Architect .

Décochez cette case pour activer le bouton Vue afin de lancer le document généré
dans la visionneuse de fichiers par défaut de MS Windows .

Inclure tous les éléments
Diagramme dans Rapport

Cochez cette case pour inclure dans le rapport des éléments provenant Paquetages
externes référencés à partir d'un diagramme , pour chaque diagramme recherché par
le rapport ; la case à cocher est par défaut sélectionnée.

Pour inclure les éléments externes dans le document, sélectionnez également le '
Paquetage . Cases à cocher Diagramme .Element' et ' Paquetage .Element' dans le
gabarit courant.
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Si les éléments externes doivent être inclus uniquement pour diagrammes
spécifiques, décochez cette case et - uniquement pour les diagrammes pour lesquels
vous souhaitez inclure des éléments externes dans le rapport - pour chaque
diagramme , cochez la case "Ajouter chaque élément contenu dans la
documentation" dans le diagramme . propriétés.

Lorsque les deux options sont désélectionnées, ou lorsqu'aucune des options '
Paquetage . Les cases Diagramme .Element' ou ' Paquetage .Element' sont cochées
dans le gabarit , seuls les éléments du Paquetage courant sont documentés.

Progrès Indiquez la progression de la génération du document avec des messages d'état et
une barre d'état de plus en plus remplie.

Document ressource Cliquez sur ce bouton pour enregistrer les options actuellement définies en tant que
définition de document.

Gabarit ouvert Cliquez sur ce bouton pour modifier le gabarit actuellement sélectionné à l'aide de
l'éditeur Document Gabarit .

Vous ne pouvez modifier gabarits définis par l'utilisateur, pas les gabarits standard
fournis avec le système. Si vous avez sélectionné un gabarit système, ce bouton est
grisé.

Générer Cliquez sur ce bouton pour générer le document (après avoir paramétré toutes les
options souhaitées, sur tous les onglets le dialogue ).

Vue Cliquez sur ce bouton pour lancer le document généré dans :

La visionneuse de fichiers par défaut de MS Windows , ou·
Le visualiseur interne Enterprise Architect , si vous avez coché la case·
« Utiliser le visualiseur interne »

Avorter Cliquez sur ce bouton pour annuler la génération du rapport ; une prompt s'affiche
pour confirmer l'annulation du rapport.

Notes

Pour une introduction à la génération de rapports de documents, consultez la rubrique d'aide de Document Rapports .·
Le deuxième onglet de la dialogue ' Générer Documentation', ' Gabarits ', permet de développer et de maintenir des·
fonctionnalités personnalisées :
- Gabarits
- Feuilles de style
- Tableaux des matières et
- Pages de couverture
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Sélection d'un Gabarit

Vous utilisez gabarits de rapport pour générer des rapports sur votre modèle qui présentent des informations spécifiques
dans un format particulier, et pour vous aider à générer ces rapports de manière répétée et cohérente. Vous pouvez
sélectionner parmi une gamme de gabarits système sur le générateur de documents pour générer immédiatement des
rapports à partir de votre modèle, ou vous pouvez sélectionner gabarits personnalisés conçus par les membres de votre
équipe de projet spécifiquement pour les besoins de votre projet.

Un gabarit définit principalement le type de contenu du rapport, de sorte que si vous générez un rapport, par exemple sur
un Paquetage , vous extrayez et présentez des informations sur un ensemble spécifique de structures telles que :

les éléments et leurs fonctionnalités et connectiques, ou·
les éléments au sommet de la hiérarchie Paquetage , ou·
tous les éléments du Paquetage , ou·
tous les éléments des diagrammes , qu'ils soient dans ce Paquetage ou dans d'autres Paquetages·

Un gabarit présente également les informations du rapport dans un format et un style spécifiques, initialement basés sur
un ensemble de styles standards. Vos concepteurs de rapports peuvent redéfinir les styles dans un gabarit personnalisé
selon leurs besoins, mais il est préférable de sélectionner les styles alternatifs dans une feuille de style afin que vous
puissiez choisir d'appliquer ou non cet ensemble de styles à un rapport, quel que soit gabarit . vous utilisez, selon vos
besoins.

La gamme initiale de gabarits système et de feuilles de style vous offre une grande flexibilité pour déterminer rapidement
et facilement le contenu et la présentation des rapports que vous souhaitez générer, et vous pouvez encore augmenter
cette flexibilité avec gabarits et des feuilles de style supplémentaires développés en interne et personnalisés. aux
exigences de votre organisation.
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Gabarits des documents système

Lorsque vous générez des rapports sur votre modèle, vous sélectionnez l'un des gabarits du rapport pour extraire des
informations sur des aspects clés spécifiques de votre modèle. Il existe plusieurs gabarits système disponibles, soit pour
générer un rapport immédiatement, soit pour le copier et le personnaliser en fonction de vos propres besoins. Chacun des
gabarits du système supporte un aspect spécifique de modélisation ou de la gestion de modèles.

Vous générez généralement des rapports sur Paquetages sélectionnés dans la fenêtre Navigateur ; ceux-ci peuvent être
utilisés pour produire d'excellents rapports hiérarchiques sur des parties de votre modèle, ou sur l'ensemble du modèle si
vous préférez. Il existe également gabarits système pour rapporter les diagrammes dans un Paquetage , que vous pouvez
utiliser pour créer un rapport sur les éléments renvoyés dans les résultats de recherche. Ces rapports ne sont pas
hiérarchiques, car ils extraient des informations spécifiques de différentes zones du modèle.

Accès - copier gabarits existants pour les modifier

Affichez la fenêtre de l'éditeur Document Gabarit , sélectionnez un gabarit , puis cliquez sur l'icône de la barre d'outils
'Enregistrer sous nouveau'.

Ruban Publier > Rapports de Modèle > Gabarits : sélectionner un gabarit particulier >

 (icône barre d'outils)

Accès - sélectionnez un gabarit pour la génération du rapport

Utilisez l'une des méthodes décrites ici pour afficher la dialogue ' Générer Documentation' dans l'onglet ' Générer ', puis
utilisez la liste déroulante du champ ' Gabarit ' pour sélectionner le gabarit à utiliser pour générer le rapport.

Ruban Publier > Rapports de Modèle > Générateur de Rapports > Générer Documentation
> sélectionner dans la liste déroulante ' Gabarit '.

Raccourcis Clavier F8 | sélectionnez dans la liste déroulante « Gabarit ».

Gabarits prédéfinis disponibles

Gabarit Description

Rapport d'audit - Détaillé Intègre les informations des dernières exécutions d’audit.

Rapport Modélisation des
données

Utilisé pour créer des rapports sur les modèles de bases de données physiques de
l'un des trois types : UML DDL, Information Engineering et IDEF1X.

Avec modélisation de données, une Classe représente un Tableau et ses attributs
représentent des champs Tableau . Dans le gabarit Modélisation des Données , les
noms de sections et de champs sont sélectionnés pour représenter les Tableaux , les
Colonnes (champs) et les attributs spécifiques des Colonnes.

Diagramme Rapport Extrait des informations sur les diagrammes d'un Paquetage . Il est principalement
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utilisé pour générer des graphiques et des titres diagramme .

Une utilisation courante de ce gabarit est l'actualisation diagrammes liés à un
document maître Word externe (où les documents virtuels ne sont pas utilisés). À
l'aide des signets générés avec les documents, vous pouvez actualiser les
diagrammes du document maître.

Glossaire Extrait les termes du Glossaire et leurs types, définis dans le Glossaire du Projet .

Ceci est couramment utilisé dans les documents virtuels pour ajouter le glossaire à
un document plus volumineux.

Rapport Maintenance Extrait les détails des modifications, des défauts, des documents et des problèmes
pour tous les éléments d'un Paquetage sélectionné. Il s'agit des informations
définies dans la fenêtre Maintenance.

Modèle Rapport Le gabarit le plus généralisé, qui comprend toutes les sections et champs
couramment utilisés. Il est plus approprié dans son utilisation des noms de champs
pour les classes UML .

Ce gabarit fournit un formatage tableau pour la plupart des sous-groupes de
l'élément, tels que les scénarios, les contraintes, Attributes et les opérations.

Problèmes de Projet Extrait des informations sur l'ensemble des problèmes enregistrés globalement dans
le référentiel.

Pour créer un rapport sur les problèmes non globaux spécifiques à un élément,
consultez la section Élément > Problème dans le Modèle Rapport gabarit .

Gestion de Projet Rapport Affiche les détails de l'allocation des ressources, de l'effort, de la métrique et du
risque pour chaque élément du Paquetage sélectionné.

Exigences Rapport -
Détails

Extrait des informations complètes sur les Exigences externes du Paquetage
sélectionné, y compris la structure de modèle dont chacune fait partie, ainsi que les
responsabilités internes, les scénarios, la gestion de projet et les enregistrements de
ressources qui pourraient exister pour support la gestion des exigences.

Exigences Rapport -
Sommaire

Fournit une brève description de chaque élément d'exigence dans le Paquetage
sélectionné.

Liste Gestionnaire de
Spécification

Répertorie les éléments et sous-packages, ainsi que leurs éléments subordonnés,
sous le Paquetage Spécification actuel dans le Gestionnaire de Spécification . Items
d'un niveau sont répertoriés par ordre alphabétique.

Rapport Test Extrait les détails Test pour tous les éléments d'un Paquetage sélectionné, tels que
définis dans la fenêtre Cas Test , ainsi que les données de test générées par les tests
xUnit et les tests de code Testpoint .

Détails du cas d'utilisation Extrait des informations sur les cas d'utilisation dans un Paquetage sélectionné, y
compris les détails de tous les scénarios. Ce gabarit exclut également les structures
enfants.

Si vous souhaitez inclure des cas d'utilisation de sous-éléments, sélectionnez la
section Élément > Éléments enfants.

Résumé du cas d'utilisation Extrait les informations de description des éléments de base sur les cas d'utilisation
dans un Paquetage sélectionné. Cela exclut les détails du scénario et les structures
enfants (pour filtrer les informations sur tous les diagrammes Séquence définis
comme diagrammes enfants des éléments du cas d'utilisation).
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Notes

La facilité d'utiliser la section ' Diagramme > Elément' pour signaler des éléments contenus dans un diagramme mais·
définis dans un autre Paquetage , est inactive dans gabarits du système
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Sélection d'une page de garde

Une page de couverture définit le texte, les styles, les graphiques et disposition de la première page d'un document.
Enterprise Architect fournit deux pages de garde standard, une pour les documents en mode portrait et une pour les
documents en mode paysage, que vous pouvez appliquer à vos rapports de documents indépendamment du gabarit du
rapport et de la feuille de style que vous utilisez. Vos concepteurs de rapports peuvent copier ces pages de garde standard
comme base pour des pages de garde personnalisées qui reflètent les styles, les logos et les conventions de dénomination
des documents de votre entreprise.

Les gabarits de la page de garde peuvent contenir des champs qui extraient et affichent automatiquement des données
telles que :

Le type de rapport·
Le Paquetage ou l'élément faisant l'objet d'un rapport·
La version du rapport·
L'état du rapport·
La date à laquelle le rapport a été généré·
Le nom de la personne qui a généré le rapport·
L'emplacement du fichier de rapport·
Tous les logos ou graphiques à afficher sur la première page·

En utilisant une page de garde, vous n'avez pas besoin de passer du temps à définir l'inclusion et l'affichage du titre et de
la provenance du rapport : celui-ci est déjà préparé pour vous. Vous pouvez accéder aux gabarits de la page de garde
depuis la liste déroulante 'Page de garde' de l'onglet ' Générer ' de la dialogue ' Générer Documentation'.

Notes

Si vous disposez gabarits de rapport personnalisés qui contiennent déjà les définitions de page de garde souhaitées,·
vous pouvez toujours les appliquer en définissant simplement le champ 'Page de garde' de l'onglet ' Générer ' sur '
<none> '
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Sélection d'un Tableau des matières

Une fonctionnalité très utile de toute documentation est l'inclusion d'un Tableau des matières. Cela peut cependant
s'avérer assez exigeant à créer, en particulier lorsque vous devez configurer un Tableau des matières pour des documents
individuels. Même la configuration de listes de contenu dans gabarits peut encore prendre beaucoup de temps, lorsque
vous avez un certain nombre de gabarits à gérer. Il est beaucoup plus rapide et plus facile d'appliquer un gabarit Tableau
des matières spécifique à vos rapports de documents, quel que soit le rapport que vous générez et gabarit de contenu sur
lequel vous basez le rapport.

Enterprise Architect fournit deux gabarits de table des matières - un pour les documents en mode paysage et un pour les
documents en portrait - dont les styles, le formatage et le système de numérotation appropriés sont déjà définis. Vous
pouvez accéder à ces gabarits via le champ ' Tableau des matières' de l'onglet 'Général' de la dialogue ' Générer
Documentation'.

Les développeurs de vos rapports peuvent copier les deux gabarits fournis par le système comme base pour Tableaux des
matières personnalisés, adaptés aux exigences de votre organisation. Ces gabarits personnalisés vous sont également
directement accessibles via la liste déroulante du champ « Tableau des matières ».

Notes

Si vous avez défini un Tableau des matières dans l'un de vos gabarits de rapport personnalisé et que vous souhaitez·
l'utiliser, définissez simplement le champ « Tableau des matières » de l'onglet « Général » sur « <none> »
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Sélection d'une feuille de style

L'utilisation de feuilles de style est une méthode efficace pour appliquer des normes de format et d'apparence cohérentes
aux catégories de documentation, indépendamment des gabarits ou des autres méthodes de définition du contenu du
document que vous utilisez. Les feuilles de style augmentent la flexibilité de la génération de votre documentation, dans
la mesure où vous pouvez :

Fournir une suite de documents générés à partir de différents gabarits avec les mêmes normes de style, en utilisant·
une seule feuille de style, et

Fournissez le même contenu de document dans différents styles pour différents publics de clients en appliquant·
différentes feuilles de style aux documents générés à partir d'un même gabarit .

Enterprise Architect fournit six feuilles de style standard : trois pour la documentation imprimée et trois pour la
documentation en ligne. Vos concepteurs de rapports peuvent les copier comme bases pour des feuilles de style
personnalisées, reflétant les normes d'entreprise de votre organisation. Chaque feuille de style personnalisée peut définir
une disposition de page et des styles de document totalement différents de ceux des autres feuilles de style et de la feuille
de style Normal.rtf. Vous pouvez accéder aux feuilles de style système et personnalisées à partir de la liste déroulante
'Feuille de style' de l'onglet 'Général' de la dialogue ' Générer Documentation'.

Hiérarchie des styles

Les feuilles de style constituent le niveau supérieur d’une hiérarchie de styles à travers le système.

Initialement, tous les documents et gabarits , qu'il s'agisse de documents liés ou de documents de rapport, reflètent·
les styles globaux définis dans le fichier Normal.rtf ; vous pouvez éditer ce fichier pour fournir de nouveaux styles
globaux pour tous les documents et gabarits créés après la mise à jour

Dans un document ou gabarit spécifique, vous pouvez modifier les styles de ce document ou de tous les documents·
générés à partir de ce gabarit ; ces styles modifiés remplacent ceux du même nom dans le fichier Normal.rtf, mais
tous les styles qui n'ont pas été modifiés reflètent toujours les définitions du fichier Normal.rtf

Vous pouvez utiliser une feuille de style pour appliquer un ensemble de définitions de style à un document généré,·
indépendamment du gabarit que vous utilisez ; ces styles remplacent tous les styles du même nom définis dans les
gabarits du document et/ou dans le fichier Normal.rtf

Notes

Si vous disposez gabarits personnalisés contenant toutes les définitions de style dont vous avez besoin, ou si vous·
souhaitez simplement utiliser les styles Normal.rtf, vous pouvez continuer à les appliquer simplement en définissant
le champ « Feuille de style » de l'onglet « Général » sur « <none> '
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Options de documents

Lors de la définition du contenu de votre document, vous pouvez définir un large éventail d'options pour sélectionner les
éléments signalés par type et propriété, et vous pouvez organiser les informations au sein de chaque type par ordre de
position dans la fenêtre Navigateur ou par date de création ou de modification. Ces options de document sont fournies de
deux manières différentes :

Sur la page 'Options' de la dialogue ' Générer Documentation', à paramétrer pour une instance spécifique d'un·
rapport ; les options sont réinitialisées lorsque vous quittez le dialogue ou sélectionnez un autre gabarit

Sur les panneaux de la dialogue 'Options du document', à configurer dans un gabarit comme paramètres par défaut à·
appliquer à chaque rapport généré à l'aide de ce gabarit ; ces paramètres peuvent être remplacés par les paramètres
'instance spécifique' de la dialogue ' Générer Documentation'

Les options répertoriées sont les mêmes pour les deux boîtes de dialogue, sauf que la dialogue 'Options du document' :

Inclut les pages 'Exclure les filtres', 'Filtres d'éléments' et 'Autres filtres' de la dialogue ' Générer Documentation'·
Inclut la page « Query personnalisée » (pour les « Fragments Gabarit »)·
Ne fournit pas ces options (telles que trouvées sur la page 'Options' de la dialogue ' Générer Documentation' ) :·
- Le bouton du générateur Switch
- L'option 'Désactiver support des fichiers OLE volumineux'
- L'option 'Insérer des sauts de page lors de la génération d'un document maître'
- L'option « Indenter les titres des documents liés »
- L'option 'Masquer les bordures diagramme '
- L'option 'Masquer les objets non imprimables'

Accès - dialogue ' Générer Documentation'

Affichez la dialogue ' Générer Documentation', puis sélectionnez la page 'Options'

Ruban Publier > Rapports de Modèle > Générateur de Rapports > Générer Documentation
> Options

Raccourcis Clavier F8 | Possibilités

Accès - dialogue « Options du document » de l'éditeur Gabarit

Affichez la fenêtre de l'éditeur Document Gabarit , sélectionnez un gabarit , puis affichez la dialogue 'Options du
document'.

Ruban
Publier > Rapports de Modèle > Gabarits : sélectionner un gabarit particulier >
(icône barre d'outils)

Possibilités

Champ Action

Cliquez sur la flèche déroulante dans le premier champ et choisissez d'organiser
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Paquetages par Paquetages dans la documentation générée par nom, ordre d'arborescence, date de
modification ou date de création.

Cliquez sur la flèche déroulante dans le deuxième champ et sélectionnez pour
répertorier les Paquetages par ordre croissant ou décroissant.

Éléments par Cliquez sur la flèche déroulante dans le premier champ et choisissez d'organiser les
éléments de la documentation générée par nom, ordre d'arborescence, date de
modification, date de création ou aucun.

Cliquez sur la flèche déroulante dans le deuxième champ et sélectionnez pour
répertorier les éléments par ordre croissant ou décroissant.

Diagrammes par Cliquez sur la flèche déroulante dans le premier champ et sélectionnez pour
organiser diagrammes dans la documentation générée par nom, ordre
d'arborescence, date de modification ou date de création.

Cliquez sur la flèche déroulante dans le deuxième champ et sélectionnez pour
répertorier les diagrammes par ordre croissant ou décroissant.

Masquer les éléments
« sans note »

Cochez cette case pour exclure tous les éléments sans notes de la documentation.

Propager les filtres
Paquetage

Sélectionnez cette option pour appliquer un filtre Paquetage de niveau supérieur à
tous gabarits et fragments enfants, en remplaçant tous les filtres définis sur ces
gabarits enfants.

Masquer les connecteurs «
sans note »

Cochez cette case pour exclure tous les connecteurs sans notes de la documentation.

Masquer les éléments
<Anonymes>

Cochez cette case pour masquer les éléments anonymes dans la documentation.

Désactiver support des
fichiers OLE volumineux

Cochez cette case pour désactiver support des fichiers OLE ( Object Linking and
Embedding) volumineux.

Utiliser le style défini dans
gabarit pour notes

Cochez cette case pour remplacer le formatage des caractères spécifié dans vos
champs « Notes » par le formatage défini pour le champ dans le gabarit .

Insérer des sauts de page
lors de la génération d'un
document maître

Cochez cette case pour insérer un saut de page après chaque Modèle de Document
dans un Rapport Paquetage .

Inclure les éléments enfants
même si l'élément parent
est filtré

Cochez cette case pour documenter tous les éléments enfants qui ne sont pas filtrés
par les restrictions, même si les éléments parents sont filtrés.

Indenter les titres des
documents liés

Cochez cette case pour ajuster les niveaux de titre de tout document lié inclus dans
le rapport afin qu'ils correspondent aux niveaux de titre du rapport. L'ajustement est
effectué en supposant que le premier niveau de titre du document lié commence à 1.

Masquer les bordures
Diagramme

Cochez cette case pour masquer le cadre diagramme sur tous diagrammes inclus
dans le document généré.

Lorsqu'elle est sélectionnée, cette option remplace la case à cocher 'Sur les images
enregistrées' de la page ' Démarrer > Application > Préférences > Diagrammes '.

Masquer les objets non La valeur par défaut est sélectionnée pour masquer tous les objets marqués comme
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imprimables non imprimables dans les diagrammes du rapport. Les objets sont marqués comme
non imprimables via le menu contextuel de l'élément sur un diagramme .

Pour afficher les objets non imprimables dans ce rapport, décochez la case.

Afficher les couleurs d'état Cochez cette case pour afficher les couleurs d'état de chaque object dans tous
diagrammes du rapport, quels que soient les paramètres de l'option 'Afficher les
couleurs d'état sur diagrammes ' sur la page 'Objets' de la dialogue 'Préférences'.

Convertir les hyperliens
d’élément en hyperliens
d’aide

Cochez cette case pour convertir les hyperliens dans l'élément Notes en hyperliens
entre les sections du document, lorsque le document est généré à l'aide du gabarit .

Aucun favori Cochez cette case pour empêcher l'insertion de signets de document dans le
document généré.

Ignorer paquetage racine Cochez cette case pour exclure le Paquetage parent de la documentation et inclure
uniquement les Paquetages enfants.

Format Diagramme Cliquez sur la flèche déroulante et sélectionnez le format diagramme pour les
images incluses dans la documentation ; soit un métafichier, soit un Bitmap.

Ajuster les niveaux de titre Cliquez sur la flèche déroulante et sélectionnez le niveau de titre le plus bas
pouvant être généré pour les sous-packages imbriqués dans le document.

Le générateur de documents reproduit les niveaux de titre jusqu'à la valeur que vous
avez définie ; par exemple, si vous disposez de quatre niveaux imbriqués de
sous-packages et que vous définissez ce champ sur :

Titre 2, tous les sous-packages du rapport sont documentés sous les titres de·
niveau 2

Rubrique 4, le premier niveau de sous-packages est documenté sous les·
rubriques de niveau 2, le niveau suivant sous les rubriques de niveau 3 et le
reste sous les rubriques de niveau 4.

Titre 6, le premier niveau de sous-packages est documenté sous les titres de·
niveau 2, le niveau suivant sous les titres de niveau 3, le suivant sous les titres
de niveau 4 et le suivant sous les titres de niveau 5 ; si vous ajoutiez d'autres
niveaux de sous-package, ils seraient tous documentés sous les en-têtes de
niveau 6

Le champ par défaut est Titre 9 pour tenir compte du nombre maximum de niveaux
de sous-packages imbriqués.

Générateur de
commutation

Cliquez sur ce bouton pour passer de cette dialogue ' Générer Documentation'
(Enhanced Gabarit Driven Generator) à la dialogue 'Rich Text Format Rapport '
(Legacy Generator).

Ce bouton n'est pas disponible si vous avez affiché le dialogue de la Liste
Diagramme , Paquetage Navigateur ou de la Recherche Modèle .

Inclure uniquement les
objets

Filtrez les éléments en fonction de la date à laquelle ils ont été créés ou modifiés
pour la dernière fois. Dans le:

Premier champ, cliquez sur la flèche déroulante et sélectionnez la valeur·
'Modifié' ou 'Créé'

Deuxième champ, cliquez sur la flèche déroulante et sélectionnez la valeur·
'Après' ou 'Avant'

Troisième champ, cochez la case, cliquez sur la flèche déroulante et·
sélectionnez la date appropriée
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Où Phase Paquetage Filtrer les éléments selon la valeur du champ Paquetage 'Phase'.

Dans le premier champ cliquez sur la flèche déroulante et sélectionnez le
qualificatif, et dans le deuxième champ saisissez la phase souhaitée (ou laissez la
valeur par défaut 'Tout').

Avec statut d'élément Filtrer les éléments selon leur statut.

Dans le premier champ, cliquez sur la flèche déroulante et sélectionnez le
qualificatif (« j'aime », « pas comme », « dans », « pas dans ») et dans le deuxième
champ saisissez la valeur à utiliser.

Les valeurs doivent être placées entre guillemets ; Par exemple:

"Proposé".

Si vous tapez plusieurs valeur , séparez-les par une virgule ; Par exemple:

"Proposé", "Mise en œuvre"

Direction du connecteur Cliquez sur la flèche déroulante et sélectionnez la direction du connecteur pour
inclure uniquement les connecteurs ayant cette direction.

Si vous sélectionnez « Les deux », le connecteur est documenté deux fois ; une fois
pour l'élément source et une fois pour la cible.

Pour les deux valeurs restantes, le connecteur est documenté uniquement pour
l'élément source ou cible, selon le cas.

Sauf lorsque Query exclut
Paquetage

Cette option exclut le Paquetage sélectionné ou un Paquetage enfant du rapport,
lorsque ce Paquetage est spécifiquement identifié par une Query SQL personnalisée
ou un script personnalisé.

Cliquez sur le bouton radio approprié au type de requête et :

Si vous avez sélectionné « SQL personnalisé », tapez la requête dans la fenêtre·
sous les boutons radio

Si vous avez sélectionné « Script personnalisé », un nouveau champ s'affiche ;·
cliquez sur la flèche déroulante et sélectionnez le script, puis tapez le point
d'entrée du script dans la fenêtre sous les boutons radio
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Exclure Query et le script Paquetage

Dans la dialogue « Options du document » (éditeur Gabarit ) ou dans l'onglet « Options » (générateur de documents),
vous pouvez saisir une Query SQL personnalisée ou sélectionner un script personnalisé pour personnaliser le rapport
d'une manière spécifique. Une possibilité consiste à exclure le Paquetage sélectionné ou un Paquetage enfant du rapport.
Vous pouvez baser votre Query ou votre script sur les exemples fournis ici.

Les deux paramètres que vous utilisez pour exclure un Paquetage sont :

#PACKAGEID# - le Package_ID de l'enregistrement actuel dans t_package en cours de traitement selon la condition·
d'exclusion

#OBJECTID# - l'Object_ID de l'enregistrement d'élément Paquetage actuel dans t_object en cours de traitement·
selon la condition d'exclusion

Query SQL personnalisée

Pour exclure le Paquetage du rapport à l'aide d'une Query SQL personnalisée, vous pouvez créer la Query basée sur les
colonnes t_package. Par exemple:

SELECT Package_ID AS ExcludePackage

DE t_package

OÙ Package_ID = #PACKAGEID#

AND Nom = ' Test '

Alternativement, vous pouvez créer la Query basée sur les colonnes object Paquetage dans le tableau t_object :

SELECT t_package.Package_ID AS ExcludePackage

DE t_package,t_object

OÙ t_package.Package_ID = #PACKAGEID#

AND t_object.Object_ID =#OBJECTID#

AND t_object.Stereotype = 'NoDoc'

Script personnalisé

Si vous avez sélectionné l'option « Script personnalisé » et souhaitez exclure le Paquetage du rapport, vous pouvez créer
un script et saisir un appel, tel que :

ExclurePackage(#PACKAGEID#)

Voici un exemple du XML renvoyé par le script :

<?xml version="1.0"?>

<EADATA version="1.0" exportateur=" Enterprise Architect ">

<Ensemble de données_0>

<Données>

<Ligne>

<ExclurePackage>

89

</ExcludePackage>

</Rangée>
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</Données>

</Ensemble de données_0>

</EADATA>

Ceci est un exemple de JScript pour exclure le Paquetage :

!INC Scripts locaux .EAConstants-JScript

/*

* Nom du script : Exemple de script RTF Exclure Paquetages

*/

fonction ExcludePackage (packageID)

{

var xmlDOM = new ActiveXObject("MSXML2.DOMDocument.4.0");

xmlDOM.validateOnParse = false ;

xmlDOM.async = faux ;

var node = xmlDOM.createProcessingInstruction("xml", "version='1.0' encoding='ISO-8859-1' " );

xmlDOM.appendChild(nœud);

var xmlRoot = xmlDOM.createElement("EADATA");

xmlDOM.appendChild(xmlRoot);

var xmlDataSet = xmlDOM.createElement("Dataset_0");

xmlRoot.appendChild(xmlDataSet);

var xmlData = xmlDOM.createElement("Données");

xmlDataSet.appendChild(xmlData);

var xmlRow = xmlDOM.createElement("Row");

xmlData.appendChild(xmlRow);

var paquetage comme EA. Paquetage ;

paquetage = Repository.GetPackageByID (packageID)

if( paquetage . StereotypeEx == "NoDoc")

{

var xmlName = xmlDOM.createElement("ExcludePackage");

xmlName.text = " " + paquetage .PackageID;

xmlRow.appendChild(xmlName);

}

renvoyer xmlDOM.xml ;

} ;
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Supprimer des sections

Un profil de suppression définit les sections du rapport qui peuvent être omises lorsque vous générez le rapport actuel.
Cela vous aide à adapter le rapport à un public spécifique lors de la génération. Vous pouvez définir des profils de
suppression dans l'onglet 'Supprimer les sections' de la dialogue ' Générer Documentation' ; vous pouvez également
utiliser l'onglet pour supprimer les profils que vous ou d'autres utilisateurs avez créés dans le modèle.

Accéder

Ruban Publier > Rapports de Modèle > Générateur de Rapports > Générer Documentation
> Supprimer les sections

Raccourcis Clavier F8 > Supprimer des sections

Créer un profil de suppression

Pour créer un profil de suppression, cochez la case en regard de chaque section à exclure du rapport.

Lorsque vous sélectionnez une section, toutes ses sections enfants seront également exclues par défaut. Par exemple, la
sélection de la section Diagramme exclura les sections enfants « Élément », « Connecteur », « Messages » et «
Historique d'audit ». Si vous souhaitez en exclure seulement certains, cochez directement les cases appropriées.

Après avoir sélectionné les sections à exclure, saisissez un nom de profil dans le champ déroulant à droite du bouton
Enregistrer, puis cliquez sur ce bouton.

Pour décocher les cases sélectionnées, cliquez sur le bouton Effacer . Pour effacer le nom du profil, cliquez sur la flèche
déroulante à la fin du champ du nom et sélectionnez l'entrée vide.

Supprimer un profil supprimé

Pour supprimer un profil Supprimer, cliquez sur la flèche déroulante à la fin du champ du nom du profil, cliquez sur le
nom du profil puis sur la touche Suppr.

Une prompt s'affiche pour confirmer la suppression. Cliquez sur le bouton Oui.

Effacer le champ du nom en cliquant sur la flèche déroulante et en sélectionnant l'entrée vide.
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Exclure les filtres

Lorsque vous spécifiez la sortie de votre rapport, vous souhaiterez peut-être exclure les objets d'un type spécifique. Vous
pouvez le faire en utilisant l'onglet « Exclure les filtres », à travers lequel vous pouvez choisir d'exclure de votre rapport
un ou plusieurs :

Types d'éléments·
Types de connecteur, et/ou·
Types de diagramme·

Vous pouvez sélectionner les objets de deux manières :

Cliquez sur le bouton Tous sous le panneau approprié pour exclure chaque type d'élément, connecteur ou diagramme·
, puis Ctrl+clic sur les types individuels que vous souhaitez inclure dans le rapport, ou

Cliquez sur le bouton Aucun sous le panneau approprié pour effacer toutes les sélections (qui incluent les objets de·
chaque type dans le rapport), puis Ctrl+clic sur chaque type d' object que vous ne souhaitez PAS afficher dans le
rapport.

Notes

Si vous souhaitez inclure ou exclure spécifiquement des éléments sur la base de leurs propriétés ou fonctionnalités·
spécifiques, plutôt que de leur type, utilisez les onglets "Filtres d'éléments" et "Autres filtres".

Les filtres définis dans un gabarit fonctionnent uniquement sur ce gabarit et ne fonctionnent pas sur les sous-modèles·
et les fragments gabarit insérés dans le gabarit ; pour filtrer les sous-modèles, définissez le filtre dans chacun d'eux
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Filtres d'éléments

Lorsque vous spécifiez la sortie de votre rapport, vous souhaiterez peut-être inclure uniquement les éléments dotés de
propriétés spécifiques, plutôt que tous les éléments rencontrés. À l'aide de l'onglet « Filtres d'éléments », vous pouvez
définir les propriétés d'élément sur lesquelles créer un rapport, ainsi que les champs et valeurs de champ. Vous pouvez
également supprimer les filtres d'éléments si vous ne souhaitez plus les appliquer.

L'onglet « Filtres d'éléments » est fourni de deux manières différentes, sous la forme d'un onglet :

La dialogue ' Générer Documentation', pour définir des filtres pour une instance spécifique d'un rapport ; les filtres·
sont réinitialisés lorsque vous quittez le dialogue ou sélectionnez un autre gabarit , ou

La dialogue 'Options du document', pour définir les filtres dans un gabarit comme paramètres par défaut à appliquer·
à chaque rapport généré à l'aide de ce gabarit ; ces paramètres peuvent être remplacés par les paramètres 'instance
spécifique' de la dialogue ' Générer Documentation'

Les options et le comportement sont les mêmes pour les deux boîtes de dialogue, sauf que la dialogue « Options du
document » permet d'importer facilité un ensemble de filtres de recherche Modèle préalablement défini depuis votre
modèle ou depuis un fichier externe (créé en exportant une recherche Modèle depuis un autre modèle).

Les facilités sont également fournies via la page 'Filtres d'éléments' de la dialogue ' Propriétés ' pour un élément de
graphique standard. Cette page ressemble le plus à l'onglet de la boîte dialogue « Options du document » dans l'éditeur
Document Gabarit .

Accès - dialogue ' Générer Documentation'

Affichez la dialogue ' Générer Documentation', puis sélectionnez la page 'Filtres d'éléments'.

Pour ouvrir la dialogue ' Générer Documentation', utilisez l'une des méthodes décrites ici.

Ruban Publier > Rapports de Modèle > Générateur de Rapports > Générer Documentation
> Filtres d'éléments

Raccourcis Clavier F8 | Filtres d'éléments

Accès - dialogue « Options du document » de l'éditeur Gabarit

Affichez la fenêtre de l'éditeur Document Gabarit , sélectionnez un gabarit , puis affichez la dialogue 'Options du
document' et enfin sélectionnez la page 'Filtres d'éléments' de cette dialogue .

Pour ouvrir la dialogue « Options du document », utilisez l'une des méthodes décrites ici.

Ruban
Publier > Rapports de Modèle > Gabarits : sélectionner un gabarit particulier >
(icône de la barre d'outils) > Filtres d'éléments

Filtres d'éléments Révision

Colonne/Bouton Action

Rechercher dans Affiche le type et le nom de chaque champ de propriété d'élément sur lequel
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effectuer la recherche.

Cochez la case en regard d'un champ de propriété pour l'inclure dans la recherche
actuelle.

Condition Affiche la condition du paramètre de recherche.

Les valeurs possibles sont Contains, Equal To, Not Equals et One Of.

Chercher Affiche le terme de recherche sur lequel effectuer la recherche conditionnelle.

Cette valeur est spécifique au champ sélectionné ; par exemple, la valeur peut être
une date pour 'DateCreated' ou un texte ou une valeur numérique pour d'autres
champs.

Le terme de recherche peut contenir plusieurs valeurs, séparées par des virgules.

Requis Indique que les résultats de la recherche doivent inclure des éléments avec le terme
de recherche dans ce champ ; ces cases à cocher sont définies dans la dialogue
« Ajouter des filtres ».

Lorsqu'aucune case « Obligatoire » n'est cochée, les champs répertoriés comme
filtres ont une relation OR ; autrement dit, si le terme de recherche est trouvé dans
l'un de ces champs, alors l'élément est affiché.

Tout champ dont la case « Obligatoire » est cochée remplace les champs pour
lesquels la case « Obligatoire » n'est pas cochée.

Fonctionnalités des
éléments

 - Facultatif

 - Requis

Préciser si fonctionnalités des éléments sont facultatives ou obligatoires ; ceux-ci
apparaissent comme une nouvelle branche sous le terme de l'élément racine dans la
colonne « Rechercher dans ».

Si vous faites défiler la colonne « Rechercher dans », vous verrez peut-être des
sous-branches telles que Attribut, Modification et Propriété personnalisée ; ce sont
les fonctionnalités des éléments. Vous pouvez ajouter ces fonctionnalités en
utilisant la dialogue 'Ajouter des filtres'.

Sélectionnez le:

Bouton radio « Facultatif » pour générer une liste d'éléments qui possèdent·
l'une des fonctionnalités de l'élément (Element Type = Object ) ou l'un des
filtres fonctionnalité (Attribute Name = Att1) ; par exemple, si votre recherche
est :
Nom de l'élément = Class11, Nom de l'attribut = m_Att1 ou Scope = Public
les résultats de la recherche répertorient tous les éléments qui portent le nom de
Class11 et tous les éléments qui ont un nom d'attribut de m_Att1 ou une portée
de public

Bouton radio obligatoire pour générer une liste d'éléments qui doivent avoir les·
fonctionnalités de l'élément ; par exemple, si votre recherche est :
Nom de l'élément = Classe, Nom de l'attribut = m_Att1 ou Portée = Public
vous obtiendriez des éléments qui doivent avoir le nom de Class AND avoir un
attribut avec un nom de m_att1 OR une portée publique

Importer la recherche Cliquez sur ce bouton et choisissez d'importer les filtres définis dans une recherche,
depuis :

Un fichier XML externe exporté depuis un autre projet, situé dans une dialogue·
du navigateur, ou

Une liste des recherches Modèle standard et personnalisées au sein de votre·
installation d' Enterprise Architect

Ajouter un filtre Cliquez sur ce bouton pour afficher la dialogue « Ajouter des filtres », pour ajouter
un nouvel ensemble de paramètres sur lesquels filtrer la recherche.
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Modifier le filtre Cliquez sur ce bouton pour afficher la dialogue 'Modifier les filtres', pour modifier
les paramètres de recherche.

Supprimer le filtre Cliquez sur ce bouton pour supprimer immédiatement le filtre sélectionné de la
recherche.

Notes

Vérifiez que les valeurs que vous fournissez pour les champs « Rechercher » correspondent exactement à celles·
contenues dans les champs de données d'élément à rechercher ; par exemple, les classes de tests d'unité,
d'intégration, de système, d'acceptation, de scénario et d'inspection sont représentées par les valeurs d'attribut 1 à 6,
et non par leurs noms d'onglets respectifs.

Les filtres définis dans un gabarit fonctionnent uniquement sur ce gabarit et ne fonctionnent pas sur les sous-modèles·
et les fragments gabarit insérés dans le gabarit ; pour filtrer les sous-modèles, définissez le filtre dans chacun d'eux
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Autres filtres

Lorsque vous spécifiez le résultat de votre rapport, vous souhaiterez peut-être inclure uniquement fonctionnalités
spécifiques d'éléments (composants de sous-éléments tels que des attributs, des responsabilités ou des contraintes). Si la
fonctionnalité ne possède pas les caractéristiques définies, elle n'est pas reportée pour l'élément. À l'aide de l'onglet «
Autres filtres », vous pouvez définir les fonctionnalités sur lesquelles créer un rapport, ainsi que les champs et valeurs de
champ. Vous pouvez également supprimer les filtres si vous ne souhaitez plus les appliquer.

L'onglet « Autres filtres » est fourni de deux manières différentes, sous la forme d'un onglet :

La dialogue ' Générer Documentation', pour définir des filtres pour une instance spécifique d'un rapport ; les filtres·
sont réinitialisés lorsque vous quittez le dialogue ou sélectionnez un autre gabarit

La dialogue 'Options du document', pour définir les filtres dans un gabarit comme paramètres par défaut à appliquer·
à chaque rapport généré à l'aide de ce gabarit ; ces paramètres peuvent être remplacés par les paramètres 'instance
spécifique' de la dialogue ' Générer Documentation'

Les options et le comportement sont les mêmes pour les deux boîtes de dialogue.

Accès - dialogue ' Générer Documentation'

Affichez la dialogue ' Générer Documentation', puis sélectionnez la page 'Autres filtres'.

Pour ouvrir la dialogue ' Générer Documentation', utilisez l'une des méthodes décrites ici.

Ruban Publier > Rapports de Modèle > Générateur de Rapports > Générer Documentation
> Autres filtres

Raccourcis Clavier F8 | Autres filtres

Accès - dialogue « Options du document » de l'éditeur Gabarit

Affichez la fenêtre de l'éditeur Document Gabarit , sélectionnez un gabarit , puis affichez la boîte dialogue 'Options du
document' et enfin sélectionnez l'onglet 'Autres filtres' de cette dialogue .

Pour ouvrir la dialogue « Options du document », utilisez l'une des méthodes décrites ici.

Ruban
Publier > Rapports de Modèle > Gabarits : sélectionner un gabarit particulier >
(icône barre d'outils) > Autres filtres

Gérer les autres filtres

Colonne/Bouton Action

Rechercher dans Affiche le type et le nom de chaque champ fonctionnalité d'élément sur lequel
effectuer la recherche.

Cochez la case en regard d'un champ pour l'inclure dans la recherche actuelle.

Condition Affiche la condition du paramètre de recherche.
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Les valeurs possibles sont Contains, Equal To, Not Equals et One Of.

Chercher Affiche le terme de recherche sur lequel effectuer la recherche conditionnelle.

Cette valeur est spécifique au champ sélectionné ; par exemple, la valeur peut être
une date pour « DateCreated » ou une valeur texte pour d'autres champs.

Le terme de recherche peut contenir plusieurs valeurs, séparées par des virgules.

Requis Indique que les résultats de la recherche doivent inclure des éléments
fonctionnalités avec le terme de recherche dans ce champ ; ces cases à cocher sont
définies dans la dialogue « Ajouter des filtres ».

Lorsqu'aucune case « Obligatoire » n'est cochée, les champs répertoriés comme
filtres ont une relation OR ; autrement dit, si le terme de recherche est trouvé dans
l'un de ces champs, alors l'élément est affiché.

Tout champ dont la case « Obligatoire » est cochée remplace les champs pour
lesquels la case « Obligatoire » n'est pas cochée.

Ajouter un filtre Cliquez sur ce bouton pour afficher la dialogue « Ajouter des filtres », pour ajouter
un nouvel ensemble de paramètres sur lesquels filtrer la recherche.

Modifier le filtre Cliquez sur ce bouton pour afficher la dialogue 'Modifier les filtres', pour modifier
les paramètres de recherche.

Supprimer le filtre Cliquez sur ce bouton pour supprimer le filtre sélectionné de la recherche.

Notes

Les filtres définis dans un gabarit fonctionnent uniquement sur ce gabarit et ne fonctionnent pas sur les sous-modèles·
et les fragments gabarit insérés dans le gabarit ; pour filtrer les sous-modèles, définissez le filtre dans chacun d'eux
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Constantes du projet

Au fur et à mesure que vous développez votre rapport, vous pouvez incorporer des indicateurs qui représentent les termes
et valeurs à l'échelle du projet. Les indicateurs - ou constantes du projet - sont remplacés par le texte réel lors de la
compilation du document. Grâce à cette facilité , vous pouvez utiliser largement une string de texte ou un numéro
particulier dans la documentation de votre projet, tout en conservant la valeur à un seul emplacement. Vous définissez les
constantes du projet dans la dialogue ' Générer Documentation' ; ils sont ensuite disponibles pour être insérés dans tous
gabarits de rapport de document personnalisés dans le texte, les en-têtes de section, les notes de fin, les en-têtes de page
ou les pieds de page, à l'aide du menu contextuel « Document Gabarit Designer ».

Accéder

Ruban Publier > Rapports de Modèle > Générateur de Rapports > Générer Documentation
> Constantes du projet

Raccourcis Clavier F8 | Constantes du projet

Gérer les constantes du projet

Champ/Bouton Action

Ajouter Cliquez sur ce bouton pour ajouter une nouvelle constante de projet à la liste.

Une prompt s'affiche pour le nom et valeur ; saisissez-les et cliquez sur le bouton
OK .

Supprimer Cliquez sur ce bouton pour supprimer la constante de projet sélectionnée de la liste.

Une prompt s'affiche pour confirmer la suppression ; cliquez sur le bouton OK pour
terminer la tâche.

Importer Cliquez sur ce bouton pour importer un ensemble de champs depuis un fichier
XML externe.

Un navigateur s'affiche pour sélectionner le fichier source et l'emplacement.

Exporter Cliquez sur ce bouton pour exporter tous les champs vers un fichier XML externe.

Un navigateur s'affiche pour spécifier le fichier cible et l'emplacement.
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Substitution de mots

En générant des rapports de documents, vous utiliserez de nombreux termes techniques anglais utilisés dans tout le
système, en particulier les noms de champs. Il est possible de remplacer ces noms de champs dans vos documents
générés par d'autres termes qui pourraient être plus significatifs pour les lecteurs, comme une traduction de chaque terme
dans votre propre langue.

Accéder

Ruban Publier > Rapports de Modèle > Générateur de Rapports > Générer Documentation
> Substitution de mots

Raccourcis Clavier F8 | Substitution de mots

Ajouter une traduction pour un terme

Étape Action

1 Double-cliquez sur le terme dans la colonne « Anglais » ; le champ « Entrer une valeur » s'affiche.

2 Type le texte de remplacement dans le champ « Entrer la valeur » et cliquez sur le bouton OK .

Le texte s'affiche dans la colonne « Substitut », à côté du terme anglais. Ce substitut s'affichera dans vos
rapports générés à la place du terme anglais.

Notes

Pour mettre en œuvre les substitutions de mots dans un rapport généré, cochez la case 'Substitution de langue' dans·
l'onglet ' Générer '
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Substitution linguistique

Si vous souhaitez générer et exporter des rapports de documents à partir d' Enterprise Architect dans des langues ou des
dialectes autres que l'anglais américain, vous pouvez personnaliser la page de codes, ID de langue par défaut et le jeu de
caractères que le système utilise lors de la génération de la documentation. Cela facilite grandement la génération de la
documentation appropriée à votre pays ou emplacement.

Accéder

Ruban Publier > Rapports de Modèle > Générateur de Rapports > Générer Documentation
> Codepage

Raccourcis Clavier F8 | Page de codes

Notes

Si vous souhaitez générer des rapports dans une langue qui nécessite support d'Unicode, veuillez note que les·
fichiers .eap Enterprise Architect utilisent par défaut JET 3.5 comme moteur de base de données, qui ne prend pas
support les jeux de caractères Unicode (voir la rubrique Démarrage ) ; pour fournir support Unicode dans votre
projet, effectuez une mise à niveau vers un référentiel SGBD ou définissez JET 4.0 comme moteur de base de
données, téléchargez une copie du modèle Jet 4.0 EABase à partir du site Web de Sparx Systems et effectuez un
transfert EAP vers EAP de votre modèle dans le Fichier Jet 4.0

Les codes que vous sélectionnez restent définis pour tous les rapports que vous générez, jusqu'à ce que vous les·
modifiiez à nouveau spécifiquement.

Vous pouvez transporter ces définitions de balises de langue entre les modèles, à l'aide des options du ruban·
« Paramètres > Modèle > Transférer > Exporter les données de référence » et « Importer les données de référence ».

Définir la langue Rapportage

Champ/Bouton Action

Langue Cliquez sur la flèche déroulante et sélectionnez le code de langue approprié à la
langue dans laquelle vous souhaitez générer des rapports.

Page de codes Cliquez sur la flèche déroulante et sélectionnez la page de codes appropriée à la
langue dans laquelle vous souhaitez générer des rapports.

Jeu de caractères Cliquez sur la flèche déroulante et sélectionnez le jeu de caractères approprié à la
langue dans laquelle vous souhaitez générer des rapports.

Étiquette anglaise Répertorie les balises de code de langue anglais américain par défaut dans
Enterprise Architect .

Balise de remplacement (Pour une utilisation avancée uniquement.) Si vous souhaitez appliquer une balise
de code de langue différente à la place d'une balise en anglais américain,
double-cliquez sur la ligne de l'article. Une prompt s'affiche pour le code de balise
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de remplacement ; tapez le code et cliquez sur le bouton OK .

Pour effacer une balise de substitution, double-cliquez sur l'élément et supprimez le
code valeur .

Lorsque vous générez vos rapports de documents, les balises de remplacement sont
utilisées dans la sortie.
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Options de Diagramme

Lors de la génération de rapports sur un Paquetage comprenant diagrammes , vous pouvez définir des options dans
dialogue « Propriétés » de chaque diagramme pour définir si ce diagramme doit être inclus dans le rapport et, si oui,
comment il doit être représenté.

Accéder

Ruban Conception > Diagramme > Gérer > Propriétés > Diagramme

Menu Contexte Cliquez-droit sur fond diagramme | Propriétés > Diagramme

Options de documents

Option Action

Exclure l'image des
documents RTF

Cochez cette case pour exclure l'image de ce diagramme de tout rapport de
document.

Documenter chaque
élément contenu en RTF

Cochez cette case pour inclure, dans le rapport, les détails de tous les éléments qui
appartiennent à d'autres Paquetages (externes) mais qui font partie de ce diagramme
au sein du Paquetage faisant l'objet du rapport ; le rapport inclut des éléments
externes dans chaque diagramme sur lequel vous avez coché la case.

Dans la dialogue ' Générer Documentation', la case 'Inclure tous les éléments
Diagramme dans Rapport ' est cochée par défaut pour inclure les éléments externes
pour chaque diagramme vérifié par le rapport ; par conséquent, pour inclure des
éléments externes uniquement pour diagrammes spécifiques, décochez cette case.

Dans les deux cas, vous devez activer le Paquetage . Sections Diagramme .Element
et Paquetage .Element dans vos gabarits de génération de document (personnalisés)
afin d'inclure ces informations sur les éléments externes dans le rapport.

Diviser Diagramme en
plusieurs pages

Si le diagramme est grand, cochez cette case pour diviser le diagramme en pages
distinctes dans le rapport du document.

Cette option n'est efficace que lorsque l'option « Impression à l'échelle » de la
dialogue « Impression avancée » est définie sur « Aucune ».

Faire pivoter les images Cochez cette case pour faire pivoter chaque image diagramme de 90 degrés dans le
rapport du document ; ceci n'est valable que pour les images bitmap (.bmp).
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Recette Enregistrer sous document

Lorsque vous définissez les paramètres de la dialogue « Générer Documentation » pour définir un document de sortie
selon vos besoins, vous souhaiterez peut-être réutiliser cette configuration pour obtenir une vue cohérente des
modifications apportées à votre modèle au fil du temps. Vous pouvez capturer la configuration en tant que document de
ressource, qui enregistre :

Nom Paquetage·
Destination et extension du fichier de sortie (qui détermine le format de sortie)·
Gabarit·
Paramètres de la page d'options·
Exclure les filtres·
Filtres d'éléments et·
Autres filtres·

Le document est enregistré dans le dossier Publication de documents > Rapport Bibliothèque de l'onglet « Ressources »
de la fenêtre Navigateur . L'enregistrement de vos configurations de rapports souvent utilisées en tant que documents de
ressources peut simplifier la génération future de documents, à la fois dans la production de documents spécifiques et
dans la génération par lots de tous les documents ou d'une sélection de documents.

Accéder

Pour enregistrer les paramètres actuels en tant que document de ressource :

Ruban Publier > Rapports de Modèle > Générateur de Rapports > Générer Documentation
> Générer : Resource Document

Raccourcis Clavier F8 > Générer : Document ressource

Accéder

Pour charger un document ressource et utiliser les paramètres qu'il a enregistrés ;

Ruban Démarrer > Toutes Windows > Conception > Général > Parcourir > Ressources >
Publication de documents > Rapport Bibliothèque > Cliquez-droit sur un document
> Générer un document

Raccourcis Clavier Alt+6 | Publication de documents | Rapport Bibliothèque | Cliquez-droit sur un
document | Générer un document

Gérer les documents de ressources

Tâche Action

Créer un document Dans la dialogue ' Générer Documentation', cliquez sur le bouton Document
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ressource ressource et, dans le champ 'Entrer une valeur', saisissez un nom pour le document.

Cliquez sur le bouton OK . Le document est ajouté au dossier Publication de
documents > Rapport Bibliothèque dans l'onglet « Ressources » de la fenêtre du
Navigateur pour un accès ultérieur facile.

Ouvrir, Générer ou
Supprimer des Documents

Dans l'onglet 'Ressources' de la fenêtre du Navigateur , développez le dossier
Publication de documents > Rapport Bibliothèque (et, si nécessaire, le sous-dossier
Groupe de documents approprié) et cliquez-droit sur le document souhaité.

Sélectionnez l'option de menu contextuel appropriée :

« Modifier le nom » - Ouvrez la dialogue « Modifier Item » et saisissez le nom·
actuel pour le corriger ou le modifier ; cliquez sur le bouton OK pour
enregistrer la modification

'Ouvrir le document' - Ouvrir le fichier .document correspondant, comme·
spécifié par la propriété 'Filename' du gabarit du document

' Générer Document' - Ouvre la dialogue ' Générer Documentation', chargée·
avec le gabarit spécifié

'Auto Générer Document' - Générer la documentation, avec le document situé·
au chemin spécifié par la propriété 'Filename' du gabarit

'Supprimer le document' - Supprimer le document spécifié·

Générer par lots un certain
nombre de documents

Cliquez-droit sur le nom du dossier Rapport Bibliothèque et sélectionnez l'option '
Générer Documents'; la dialogue « Génération de documents par lots » s'affiche.

La dialogue répertorie tous les documents ressources du dossier Rapport
Bibliothèque , qu'ils soient ou non contenus dans des groupes de documents. Tous
les documents sont sélectionnés par défaut ; décochez la case de chaque document
que vous ne souhaitez pas générer (ou cliquez sur le bouton Désélectionner tout
pour effacer toutes les sélections, puis sélectionnez celles dont vous avez besoin).

Cliquez sur le bouton OK pour générer chacun des rapports restants dans leurs
emplacements de fichiers cibles respectifs.

Alternativement, pour générer automatiquement tous les documents du dossier
Rapport Bibliothèque (là encore, qu'ils soient ou non dans des groupes de
documents), sans afficher la dialogue 'Génération de documents par lots', cliquez
sur l'option de menu contextuel ' Générer tous les documents'.

Gérer les groupes de documents de ressources

Au fur et à mesure que vous créez davantage de documents de ressources, vous trouverez peut-être pratique de les
regrouper par catégorie, telle que la zone de modèle ou l'objectif. Cela vous aide à localiser rapidement le document
requis et affine également la facilité de génération de plusieurs documents, soit par une sélection manuelle rapide dans le
groupe, soit en générant automatiquement l'ensemble du groupe.

Tâche Action

Créer un groupe de
documents

Dans l'onglet 'Ressources' de la fenêtre du Navigateur , au sein du dossier
Publication de Documents , cliquez-droit sur le sous-dossier Rapport Bibliothèque
et sélectionnez l'option 'Groupe Nouvelle Génération'. La dialogue « Entrer le nom
du groupe de génération » s'affiche, dans laquelle vous saisissez le nom du groupe
de documents. Cliquez sur le bouton OK pour créer le groupe.

Vous pouvez ensuite modifier le nom du groupe en cliquant dessus avec le bouton
droit et en sélectionnant l'option « Modifier le nom », puis en écrasant le nom dans
la dialogue « Modifier l'élément ».
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Ajouter des documents de
ressources au groupe

Pour ajouter un document ressource à un groupe de documents, faites-le
simplement glisser de son emplacement actuel (dans un autre groupe ou sous le
sous-dossier Rapport Bibliothèque ) vers le groupe requis.

Supprimer un groupe de
documents

Pour supprimer un groupe de documents et tous les documents ressources qu'il
contient, cliquez-droit sur le nom du groupe et sélectionnez l'option 'Supprimer le
groupe de documents'. Un message d'avertissement s'affiche ; si vous souhaitez
continuer et supprimer le groupe et les documents, cliquez sur le bouton OK .

Générer des Documents
sélectionnés du Groupe

Pour générer certains - mais pas nécessairement la totalité - des documents
ressources du groupe, cliquez-droit sur le nom du groupe et sélectionnez l'option '
Générer des documents'. La dialogue « Génération de documents par lots »
s'affiche, avec tous les documents du groupe sélectionnés.

Décochez la case en regard de chaque document que vous ne souhaitez pas générer
(ou cliquez sur le bouton Désélectionner tout et resélectionnez les cases en regard
des documents à générer). Cliquez sur le bouton OK pour générer les documents
sélectionnés vers leurs fichiers cibles définis, et fermer le dialogue .

Générer tous les documents
du groupe

Pour générer tous les documents ressources du groupe par lots, cliquez-droit sur le
nom du groupe et sélectionnez l'option ' Générer tous les documents'. Le système
commence immédiatement à générer les documents dans l'ordre.
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