
Perspectives

Enterprise Architect

User Guide Series

Author:  Sparx Systems
Date:   26/07/2018

Version:  1.0
CREATED

WITH





Table of Contents

Perspectives 4
Types of Perspective 10
Managing Perspectives 23



User Guide - Perspectives 26 July, 2018

Perspectives

Perspectives are sets of Enterprise Architect modeling tools,
facilities and model and diagram Patterns that are tailored to
domain-specific modeling scenarios. When working in a
team you might want to restrict the available Perspectives,
effectively ensuring that all team members are modeling
with the same languages and technologies.

You select and switch to the required Perspective through
the 'Perspective' option at the top right of the screen or
through the Perspective Portal in the Portals window.
Selecting a Perspective automatically brings up the
Modeling Wizard, which provides a rich set of
system-provided modeling patterns on which to build the
appropriate model. Enterprise Architect also helps you to
create your own Perspectives, simply by customizing the
Global Perspectives Sets and the Perspectives they contain.

Introduction
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Perspectives allow you to focus on a particular modeling
language or technology enabling you to work effectively
and efficiently on the task at hand. When your modeling
focus changes you can simply select another perspective
from a conveniently grouped list of perspective sets.
Enterprise Architect will then hide the previous languages
and Technologies and open the newly selected set. The
diagram below shows an example of three Perspective Sets
each of which contains a number of perspectives.

The 'peeping through a key hole' mechanism reduces the
'background noise' and allows you to effectively switch hats
as your role changes. The perspectives have been crafted to
align with the multitude of roles that modelers perform and
are grouped into sets that make finding the right perspective
easy and just one click away. There are for example
perspective sets for: Strategy, Ux Design, Database
Engineering, Business Modeling, Systems Engineering,
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Code Engineering and many more. Each set contains a
number of relevant and useful perspectives.

With so many modeling languages and capabilities built into
Enterprise Architect it can be difficult to find the right
approach and keep focus. Using the Perspectives facility
helps you to quickly and effectively refine the scope of tools
and options available to meet your exact modeling
requirement or scenario. Perspectives tailor the overall
modeling capability to a specific set of technologies, limit
the options available in the Ribbon menu system and
implement a robust and user-configurable meta-modeling
capability that allows for very fine definition of custom
viewpoints and modeling tool sets.

Through the Model Wizard, Perspectives link to a huge
range of new model patterns and guidance notes, and filter
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them to narrow down the available patterns, technologies,
diagram types and other modeling constructs to the precise
set required with minimal effort. This helps you to quickly
build accurate, focused models with minimal 'noise' and
maximum fidelity.

The Perspectives facility applies the concept that it is easier
to rapidly switch between domain-focused sets of tools on
an as-needs basis than to pick through a mixed set of
technologies and tools that address ALL possible modeling
scenarios. By selecting the appropriate Perspective for the
task at hand, you can avoid the significant distraction of
having multiple technologies all requiring consideration.

To further enhance your modeling experience, you can hide
complete Perspective sets or individual technologies using
the customization wizard. As a huge boost to models
encompassing several disciplines and modeling domains,
hiding a Perspective only removes it as an available tool,
whilst all diagrams that already make use of the hidden
technologies will still render and work as normal.

The Model Wizard and the 'New Diagram' dialog also allow
for swapping Perspectives on the fly, making it easy to find
and use the exact modeling tools required.

System Perspectives

At Release 14.0, Enterprise Architect provides a rich set of
Perspectives built directly into the application. These
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include:

Business sets for Strategy, BPMN, Business Analysis and·

more, helping the business user focus on their current task

SysML, MBSE, Software, Simulation and others, for the·

Systems Engineer and Software Engineer

Archimate, TOGAF, Zachman Framework and·

GRA-UML, version-specific sets that provide the most
common tools for the needs of Enterprise Architects

SPEM, Process Guidance and MDG Technology Builder·

for Project Managers

For further information on the available Perspectives, see
the Types of Perspective Help topic.

Personal Perspectives

There are over sixty pre-built perspectives but you are able
to create any number of your own perspectives as well.
These are conveniently grouped into a My Perspective Set.
Each set can contain any number of individual technologies.
So if you regularly create Prototypes for example you may
want to create a Prototyping Perspective Set and include
languages and technologies that will be the things that you
will use while wearing your prototyping hat. These
Perspectives Sets can be created, modified and deleted as
the roles you perform change over time.
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While the system (built-in) perspectives typically contain a
single language or technology for example the BPMN
perspective allows you to focus on just BPMN (Business
Process Model and Notation), Personal Perspectives allow
you to open a number of technologies at the same time. For
example you may want to focus on Mind Mapping diagrams
to record information in Stakeholder meetings, BPMN to
sketch out the processes and DMN (Decision Modeling
Notation) to model decisions. All three technologies can be
included in a single Perspective entitled for example
'Process Analysis and Modeling'
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Types of Perspective

There are several types of Perspective provided within
Enterprise Architect, each containing a suite of Patterns as
described here. Notice that there is a wide selection
available, and that they can be accessed from a number of
different points. This makes it easy to start your work in the
appropriate environment with the required Perspective from
any point, and to quickly and smoothly switch to a different
Perspective if the need arises.

Access

Some access paths take you to the Perspectives Portal, and
when you select a Perspective from that the Model Wizard
opens and you choose the appropriate Patterns from there.
Other paths take you directly to the Model Wizard.

Ribbons Start > View > Perspective > Select a
Perspective (takes you to the Perspective
Portal)
Show > Portals > Perspective >
<perspective group> (takes you to the
Model Wizard)
Design > Package > Insert > Insert Using
Model Wizard > Model Patterns >
Perspective
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Context
Menu

Click on Package > Add a Model using
Wizard > Model Patterns > Perspective

Other These options all display the Model
Wizard:
Start Page | Open a Portal | Perspective
Portal > <perspective group> >
<perspective>
(Top right corner of screen) >  >
<perspective group> > <perspective>

Navigator Toolbar :  :  >
<perspective group> > <perspective>

Perspectives

Category Perspectives

UML The UML category provides the
Perspectives for normal UML modeling,
including:

All UML Modeling - all modeling tools·

and objects provided by the other
Perspectives in this group
Structural - the modeling tools and·
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objects for structural UML models,
such as:
    - Package diagrams
    - Class diagrams
    - Object diagrams
    - Composite Structure diagrams
    - Component diagrams
    - Deployment diagrams
Behavioral - the modeling tools and·

objects for behavioral UML models,
such as:
    - Use Case diagrams
    - Sequence diagrams
    - Timing diagrams
    - Interaction Overview diagrams
    - StateMachine diagrams
    - Communication diagrams
    - Activity diagrams

Strategy The Strategy category provides
Perspectives for:

Mind Maps - the basic Mind Map·

diagram
Strategy modeling, such as:·

    - Organizational Charts
    - Value Chains
    - Strategy Maps
    - Balanced Scorecards
    - One-level and Two-level
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Flowcharts
    - Decision Analyses with Trees and
with Decision Tables
    - SWOT Analyses
Risk Analysis - the Risk Taxonomy·

Threat Community diagram

Analysis The Analysis category provides
Perspectives for:

White Boarding - diagram structures in·

Whiteboard and/or Hand-drawn mode
Simple Analysis, based on a Two·

Activity Process
Case Management Model & Notation·

(CMMN) analysis, with a:
    - Claims Management example
    - Basic 5-Task Plan
    - Three Choice Tasks Pattern
    - Two Phase Case Plan
Erikson Penker modeling, the basic·

business process
Web Modeling, based on a simple Java·

Server Page (JSP) model

Requirements The Requirements category provides
Perspectives for:

Creating a range of Requirement·

Hierarchy diagrams, and a
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Requirement Specification View
Working with Decision Modeling·

Notation (DMN) to:
    - Create a simple Decision diagram
with a Decision Table
    - Set up a DMN Business
Knowledge Model
    - Model a DMN Decision
Setting up a Business Rule model·

Setting up one-level and two-level Data·

Flow models

UX Design The UX Design category provides a
number of Perspectives for modeling user
interfaces on various devices, including:

Wireframing for various phone and·

tablet devices
IFML Interaction flows on desktop·

applications, information entry,
interaction on wireframe devices, and
information searches
A basic Enterprise Architect user·

interface model for a window with lists
and combo boxes
An alternative simple user interface·

Win 32 User Interface modeling·

Business The Business Modeling category
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Modeling provides these Perspectives:
BPMN - Patterns for:·

    - BPMN 2.0 modeling
    - BPEL 2.0 Starter model
BPSim - Patterns for BPMN 2.0 and·

BPEL 2.0 modeling, plus:
    - Patterns for Business Process
Simulation (BPSim) constructs and
    - Patterns for a number of BPSim
Case Studies
Business Model Patterns for Business·

Use Case models and Use Case
Realization
Business Interaction model Patterns·

BABOK - a wide range of Patterns·

supporting models for:
    - Strategies
    - Collaboration activities
    - Analyses
    - Business Processes
    - Project Management activities
    - Standard business documents
BIZBOK - Patterns for modeling·

BIZBOK activities

Software
Engineering

The Software Engineering category
provides Perspectives for software
development, including:
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Code Engineering, modeling programs·

in a number of programming languages
Service Oriented SOMF 2.1, for·

several Conceptual Association types
SoaML, for modeling aspects of basic·

service provision
XSLT Feature demonstrations, such as·

XSLT transforms and debugging
ICONIX modeling·

GOF Patterns for Creational, Structural·

and Behavioral models

Systems
Engineering

The Systems Engineering category
provides Perspectives to support systems
Engineering projects under:

SysML1.5, with a wide range of·

Patterns for generating:
    - Project structures
    - Requirements diagrams
    - Use Case diagrams
    - Activity diagrams
    - Block Definition diagrams
    - Internal Block diagrams
    - Parametric diagrams
    - State Machine diagrams
    - Libraries
    - Model elements
    - Modelica Case Studies
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UAF, with Patterns for:·

    - Strategic Views (St-xx)
    - Operational Views (Op-xx)
    - Services View (Sv-xx)
    - Personnel Views (Pr-xx)
    - Resources Views (Rs-xx)
    - Security Views (Sc-xx)
    - Projects Views (Pj-xx)
    - Standards Views (Sd-xx)
    - Actual Resources Views (Ar-xx)
    - Dictionary View (Dc)
    - Requirements View (Rq)
    - Summary and Overview (SmOv)
    - Information View (If)
    - Parameters Views (Pm-xx)
    - The SysML 1.5 sets (as listed,
except for Modelica Case Studies)
UPDM with Patterns for:·

    - UPDM Frameworks (DoDAF and
MODAF)
    - DoDAF All Viewpoints (AV-n)
    - DoDAF Capability Viewpoints
(CV-n)
    - DoDAF Data and Information
Viewpoints (DIV-n)
    - DoDAF Operational Viewpoints
(OV-n)
    - DoDAF Project Viewpoints (PV-n)
    - DoDAF Services Viewpoints
(SvcV-n)
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    - DoDAF Standard Viewpoints
(StdV-n)
    - DoDAF Systems Viewpoints
(SV-n)
    - MODAF All Views (AV-n)
Viewpoints
    - MODAF Acquisition (AcV-n)
Viewpoints
    - MODAF Operational (OV-n)
Viewpoints
    - MODAF Service Oriented Views
(SOV-n) Viewpoints
    - MODAF Strategic Views (StV-n)
Viewpoints
    - MODAF System Viewpoints
(SV-n)
    - MODAF Technical Standards
Views (TV-n) Viewpoints
Executable State Machines, with·

various Patterns including a set to
demonstrate case studies

Database
Engineering

The Database Engineering category
provides sets of Perspectives for
modeling a range of DBMS repositories,
including:

Starter Model and Model Structure·

Patterns for each of the main DBMSs
supported by Enterprise Architect
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Patterns for simple Entity Relationship·

models
Patterns for simple ArcGIS projects·

and workspaces
A simple EA Data Modeling diagram·

Pattern

Enterprise
Architecture

The Enterprise Architecture category
provides a number of Perspectives for
Enterprise Architecture frameworks,
including:

ArchiMate, supplying Patterns for:·

    - Basic viewpoints such as
Organization, Application Usage and
Service Realization
    - Motivation Viewpoints such as for
Stakeholders, Principles and
Requirements Realization
    - Strategy Viewpoints
    - Implementation and Migration
Viewpoints
TOGAF, with Patterns for:·

    - A Starter Model
    - The Architecture Development
Method
    - The Enterprise Continuum
    - The Technical Reference Model
    - Catalogs
Zachmann Framework·

(c) Sparx Systems 2018 Page 19 of 30



User Guide - Perspectives 26 July, 2018

GRA-UML annotations library and·

starter model

Information
Exchange

The Information Exchange category
supports a number of built-in
technologies, providing Perspectives and
basic model Patterns for:

Ontology Definition (ODM)·

Geographic GML·

Archetype Modeling Language·

NIEM 3.0, 3.1, 3.2 and 4.0 Reference·

Models and NIEM 3 and 4 starter
models
SIMF·

Universal Business Language·

UPCC 3.0·

UMM 2.0 Profile·

Construction The Construction category provides these
Perspectives:

Project Roadmaps, for a range of·

management work areas
Kanban workflows·

Document Publishing for types of·

Project document
Dashboards and Charts for various·

scenarios
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Reviews and Discussions to define the·

structure and function of these team
collaboration activities
Test Management to define how tests·

are planned and managed
Change Management to define a model·

for managing issues and changes
Resource Management to define how·

resources are identified and managed
Legends to define how diagram·

legends are set up and used

Management The Management category provides
Perspectives to support:

SPEM·

Process Guidance - working up process·

templates
The Enterprise Architect Script Library·

The MDG Technology Builder·

My
Perspectives

The 'My Perspectives' category holds the
Perspectives that you have created for
yourself, using the 'Start > View >
Perspective > Customize List of
Available Perspectives' option. For
further details, see the Managing
Perspectives Help topic.
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Managing Perspectives

Whilst there is a huge range of Perspectives provided in
Enterprise Architect, you might decide to create others more
specifically tailored to your area of work. Equally, you
might prefer to filter this wide range of available
Perspectives so that only those you are likely to use are
made visible. The methods for tailoring Perspectives to
match your work environment are described here.

Access

The access options display the 'Perspective Sets' dialog,
through which you can both filter the existing Perspectives
and create customized Perspectives.
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Ribbon Start > View > Perspective > Customize
List of Available Perspectives
Design > Diagram > Insert > 'Hamburger'
icon > Manage > Customize

Other (Top right corner of screen) >  >
Manage > Customize

Filter Perspectives Listed
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When the 'Perspective Sets' dialog displays, it defaults to the
'Global Perspectives' tab. You use this tab to exclude
Perspectives - or even whole categories of Perspective -
from display in the Model Wizard and  selection
lists.

If you want to exclude a complete category of Perspectives,
deselect the checkbox against that category in the
'Perspective Sets' panel.

Otherwise, if you want to just exclude individual
Perspectives, click on the parent Perspective Set name and
deselect the checkbox against the Perspective name in the
'Perspectives' panel. In this illustration, the CMMN and
Erikson-Penker Model Perspectives have been excluded
from display.

Note that if you exclude a category of Perspectives, the
checkboxes against the individual member Perspectives
remain selected. However, the Perspectives do not show in
the selection lists of Perspectives.

If you decide to show any excluded Perspectives again,
return to the dialog and select the appropriate checkboxes.
Alternatively, to show all excluded Perspectives again,
either:

Click on the Reset button on the 'Perspective Sets' dialog,·
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or

Click on the  button and select the 'Manage >·

Show All Perspectives' option

Create Custom Perspective

On the 'Perspective Sets' dialog, click on the 'My
Perspectives' tab.

Ste
p

Action

1 Click on the New button. The 'Select MDG
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Technologies' dialog displays.

2 In the 'Set Name' field, type a name for the custom
Perspective. Then select the 'Add' checkbox against
each MDG Technology to make visible.
You can click on the All button and then deselect the
checkbox against each Technology to hide, or click
on the None button to clear all selected checkboxes
and then re-select those against Technologies you
want to keep visible.
If you want to group your selections by Technology,
click on the 'Group Categories by Technology'
checkbox.

3 When you have added the necessary Technologies to
the Perspective, click on the OK button. The
Perspective name displays in the 'Create Perspective'
panel, and the Technologies in the Perspective are

(c) Sparx Systems 2018 Page 27 of 30



User Guide - Perspectives 26 July, 2018

listed in the 'MDG Technologies' panel in
alphabetical order.
Notice that all buttons at the bottom of the window
are now enabled.

4 If you prefer to:
List the Technologies in the Perspective in a·

different sequence, click on each Technology
name in turn and use the green Up Arrow button
and Down Arrow button to move the Technology
name to the correct position in the sequence
Remove a Technology from the Perspective, click·

on the Technology name and click on the X button
to redisplay the 'Select MDG Technologies' dialog,
listing just the Technologies that are in the

(c) Sparx Systems 2018 Page 28 of 30



User Guide - Perspectives 26 July, 2018

Perspective; clear the 'Add' checkbox against the
Technology to be removed, and click on the OK
button
Add another Technology to the Perspective, click·

on the + button to redisplay the 'Select MDG
Technologies' dialog, listing the Technologies that
are not already in the set; select the 'Add'
checkbox against the required Technology, and
click on the OK button

5 Click on the Save button and, if you have finished
setting up or changing a Perspective, click on the
Close button.

Revert to General Pattern Lists

If you have been working within a specialized Perspective,
such as SIMF or a customized Perspective, and you want to
return to a non-specific environment, simply select the 'Start
> View > Perspective > Clear Current Perspective' ribbon
option.
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